Bug 128478 - PNG export with transparency broken with OpenGL rendering on some systems
Summary: PNG export with transparency broken with OpenGL rendering on some systems
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Graphics-Export VCL-OpenGL
  Show dependency treegraph
 
Reported: 2019-10-30 13:42 UTC by Steffen Voß
Modified: 2020-09-25 14:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test kit OpenDocument drawing multiple graphics and export with and without OpenGL (418.32 KB, application/x-zip-compressed)
2019-10-31 12:13 UTC, V Stuart Foote
Details
ODG example (2.64 MB, application/vnd.oasis.opendocument.graphics)
2019-11-08 08:21 UTC, Steffen Voß
Details
PNG export of ODG example (1.28 MB, image/png)
2019-11-08 08:22 UTC, Steffen Voß
Details
Test-Kit PNG-Rendering (171.47 KB, image/png)
2019-11-08 08:23 UTC, Steffen Voß
Details
PNG export of ODG example with OpenGL turned off. (1.12 MB, image/png)
2019-11-08 08:26 UTC, Steffen Voß
Details
test document exported to PNG with Skia rendering, cleanly handled transparencies (248.04 KB, image/png)
2020-09-25 14:59 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Voß 2019-10-30 13:42:50 UTC
Since I upgraded to Windows 10 and Libre Office 6.3.2.2 (x64) I am having trouble with the PNG/JPG-export in Draw. All the colours are off and letters have a strange border. Is this a bug? How can I fix this?

See examples: https://ask.libreoffice.org/en/question/214467/draw-png-export-with-transparency-broken/
Comment 1 Roman Kuznetsov 2019-10-31 10:12:58 UTC Comment hidden (obsolete)
Comment 2 V Stuart Foote 2019-10-31 12:13:21 UTC
Created attachment 155423 [details]
test kit OpenDocument drawing multiple graphics and export with and without OpenGL

Export to PNG with OpenGL rendering is garbling Alpha and RGB. Default GDI rendering is correct.

Attached test kit has ODG and resulting exports.

Testing on Windows 10 Home 64-bit en-US (1903) w/Intel HD 620 (driver 26.20.100.7323) and
Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 V Stuart Foote 2019-10-31 12:17:46 UTC
First pass it seems to be OpenGL rendering of PNG RGB and Alpha channel. JPEG does not support Alpha channel transparency. 

For OP could you retest with OpenGL rendering disabled?  Tools -> Options -> View 'Graphics output', checkbox for 'Use OpenGL for all rendering' and restart.
Comment 4 Steffen Voß 2019-11-08 08:21:36 UTC
Created attachment 155623 [details]
ODG example
Comment 5 Steffen Voß 2019-11-08 08:22:10 UTC
Created attachment 155624 [details]
PNG export of ODG example
Comment 6 Steffen Voß 2019-11-08 08:23:31 UTC
Created attachment 155625 [details]
Test-Kit PNG-Rendering
Comment 7 Steffen Voß 2019-11-08 08:26:34 UTC
Created attachment 155626 [details]
PNG export of ODG example with OpenGL turned off.

Turning OpenGL off fixed it for me! Thank you!
Comment 8 Roman Kuznetsov 2019-11-11 18:13:05 UTC
I can't repro it in

Версия: 6.4.0.0.alpha1+ (x64)
ID сборки: 13ac239daa4e40413b02892f5d70a12066f1f731
Потоков ЦП: 4; ОС:Windows 10.0 Build 17763; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded

and in 6.3.3.2 too

I have 

DriverVersion: 24.20.100.6286
DriverDate: 8-15-2018
DeviceID: PCI\VEN_8086&DEV_591B&SUBSYS_1A101043&REV_04
AdapterVendorID: 0x8086
AdapterDeviceID: 0x591b
AdapterSubsysID: 0x1a101043
DeviceKey: System\CurrentControlSet\Control\Video\{50593AB0-5855-11E9-A9D9-E7305D07F358}\0000
DeviceString: Intel(R) HD Graphics 630

may be windows 10 build 1903 problem? 

Mike, do you have latest Windws 10 build? Can you try repro it?
Comment 9 Mike Kaganski 2019-11-11 19:02:05 UTC
Can't repro with Версия: 6.3.3.2 (x64)
ID сборки: a64200df03143b798afd1ec74a12ab50359878ed
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded

on Win10 ver.1903 (build 18362.418) with Intel HD Graphics 620 (driver version 22.20.16.4836) with OpenGL enabled (and reported active by LO).
Comment 10 Timur 2019-11-15 15:55:40 UTC
Cannot reproduce with LO 6.3.3 and 6.5+. Windows 8.1. Intel HD ver. 10.18.14.4264. Default PNG options.

Interesting to see that Mike doesn't reproduce with driver version 22.20.16.4836 while Stuart does with driver 26.20.100.7323.
And it seems from intel page that there are newer versions: https://downloadcenter.intel.com/product/80939/Graphics-Drivers.
So Steffen and Stuart, would you consider to update your drivers?
Comment 11 Steffen Voß 2019-11-18 08:00:23 UTC
I will ask my admin...
Comment 12 QA Administrators 2020-06-06 03:52:07 UTC Comment hidden (obsolete)
Comment 13 Buovjaga 2020-08-28 12:21:06 UTC
As Skia with Vulkan will replace OpenGL UI rendering on all platforms, it does not make sense to keep OpenGL UI reports open.

Details about Skia: https://www.collaboraoffice.com/success-story/implementing-vulkan-capable-libreoffice-user-interface-using-the-skia-library/
Comment 14 V Stuart Foote 2020-09-25 14:59:32 UTC
Created attachment 165848 [details]
test document exported to PNG with Skia rendering, cleanly handled transparencies

confirmed Skia rendering produces clean transparency with PNG export