Bug 128888 - Transparent objects causing excessive CPU usage when exporting PNG from LO Draw
Summary: Transparent objects causing excessive CPU usage when exporting PNG from LO Draw
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Graphics-Export Performance
  Show dependency treegraph
 
Reported: 2019-11-19 07:24 UTC by xordevoreaux
Modified: 2020-10-08 16:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (1.83 MB, application/vnd.oasis.opendocument.graphics)
2019-11-19 07:28 UTC, xordevoreaux
Details
WINDOWS 10 TASK MANAGER DURING EXPORT OF PNG (28.66 KB, image/png)
2019-12-11 13:42 UTC, xordevoreaux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xordevoreaux 2019-11-19 07:24:29 UTC
Description:
When I export a slide to PNG from Draw having text converted to a curve or polygon and the text is set transparent, Windows Task Manager shows "VERY HIGH" for power usage for LO both while the PNG export dialog is preparing to display on the screen and then again while saving.  

The saving process takes considerably longer than slides without transparency (or with transparency and exporting via TIFF).

This does not occur when exporting TIFF files.

Note: This does not happen with other transparent objects, just text that's been converted to a curve (OR POLYGON) and that curve/polygon made transparent.

Text converted to a curve/polygon but not made transparent does not hinder the export process.



Steps to Reproduce:
1. Open LO Draw
2. Import a picture
3. On top of that picture, type some text. 
4. Convert text to a curve
5. Set the text's transparency to something other than 0.
6. Export the slide as PNG

Actual Results:
Manager shows "VERY HIGH" for power usage for LO both while the PNG export dialog is on the screen and then again while saving. 

Expected Results:
Power usage and export time should be essentially no different for transparent objects on a slide when exporting to PNG as opposed to another format like TIFF.


Reproducible: Always


User Profile Reset: No



Additional Info:
Windows 10 Pro Version 1901 Build 19363.476
nVIdia GTX 1050 with driver version 441.20 released Nov 12 2019.
32GB RAM 
3770 K I7 64 Bit Processor

What I experienced happens regardless if hardware acceleration is on or off or if Open GL is used.  I usually work with Open GL off and with hardware acceleration and anti-aliasing on.  

Because I have not been using transparent text until now, I do not know whether this is something new with 6.3.3.2 or would have been happening in earlier versions.
Comment 1 xordevoreaux 2019-11-19 07:28:04 UTC
Created attachment 155934 [details]
test file

For the attached LO draw file to test with for exporting PNGs:

1. Slide 1 exports normally
2. Slide 2 exports normally
3. Slide 3 has a transparent text converted to a curve and hinders export
4. Slide 4 exports normally
5. Slide 5 has a transparent text converted to a polygon and hinders export
6. Slide 6 exports normally having a transparent square on it.
Comment 2 xordevoreaux 2019-11-19 07:32:01 UTC
Sorry, I mistyped. 
I'm using Windows 10 Pro 1909 build 18363.476, not 1901, as stated originally.
Comment 3 Xisco Faulí 2019-12-11 13:00:21 UTC
Hi,
So the problem is when exporting page 3 ?
I can't reproduce it in

Version: 6.5.0.0.alpha0+
Build ID: b9d6ea1dd7541c4bd866571f9e3f0aa894687c07
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 4 xordevoreaux 2019-12-11 13:39:55 UTC
(In reply to Xisco Faulí from comment #3)
> Hi,
> So the problem is when exporting page 3 ?
> I can't reproduce it in
> 
> Version: 6.5.0.0.alpha0+
> Build ID: b9d6ea1dd7541c4bd866571f9e3f0aa894687c07
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

um... from the above, looks like you tested in Unix/Linux. 

I am working in Windows. 

Far be it the case from the many bugs I've posted that Windows bugs always appear in Unix/Linux. Almost every time a developer comes back on one of my bugs that that they couldn't reproduce it, they weren't testing in Windows.

Test in Windows 10 please.
Comment 5 xordevoreaux 2019-12-11 13:42:04 UTC
Created attachment 156493 [details]
WINDOWS 10 TASK MANAGER DURING EXPORT OF PNG

This high level of CPU usage only happens with transparent text. Does not happen, as shown in my previously posted test file for this bug (128888), illustrates.
Comment 6 xordevoreaux 2019-12-11 13:57:02 UTC
Putting LO in safe mode made (default user profile) no difference. 


CPU usage was the same both at the time the export dialog box tried to appear on the screen and during the export process itself.  Again, this is happening on slide #3 of my originally posted test file in this bug when exporting to PNG.
Comment 7 Buovjaga 2020-04-28 19:15:30 UTC
I don't observe any exceptional CPU cycles when the export dialog is open. Sure, it uses some CPU for a couple of seconds while exporting (both on Windows and Linux). How is this a bug, though?

"Power usage and export time should be essentially no different for transparent objects on a slide when exporting to PNG as opposed to another format like TIFF."

Why not? They are different formats after all with their own compression methods. Notice there is a slider for compression level in the PNG export dialog.

Arch Linux 64-bit
Version: 7.0.0.0.alpha0+
Build ID: 6a9c7409ee617b79c327dd7ea4de432f448b6006
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 24 April 2020
Comment 8 xordevoreaux 2020-10-08 16:10:09 UTC
I'm tired of trying to state a case for this so I'm just killing it.