Bug 128561 - FILEOPEN: DOCX: Graphic incorrectly displayed
Summary: FILEOPEN: DOCX: Graphic incorrectly displayed
Status: RESOLVED DUPLICATE of bug 123435
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2019-11-02 21:35 UTC by John Seager
Modified: 2019-11-04 12:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
an MSO created page that wont render correctly and crashed LO when OpenGL tried (91.61 KB, application/zip)
2019-11-02 21:47 UTC, John Seager
Details
word drawing LO 6.4 with OpenGL (251.49 KB, image/png)
2019-11-03 08:56 UTC, Oliver Brinzing
Details
comparison MSO 2010 and LibreOffice 6.4 Master (127.28 KB, image/png)
2019-11-04 12:06 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Seager 2019-11-02 21:35:08 UTC
Description:
Trying to open a MSO Word document to view a graphic.  It rendered incorrectly (with OpenCL or without OpenCL), so tried enabling OpenGL in view settings but this crashed LO when opening the document.

Steps to Reproduce:
1.Open the attached MSO file with OpenGL enabled
2.
3.

Actual Results:
LibreOffice crashes

Expected Results:
It would be good if the page rendered correctly


Reproducible: Always


User Profile Reset: No



Additional Info:
The file isn't rendered correctly without OpenGL, I don't know yet how it will render when the bug is squished!
Comment 1 John Seager 2019-11-02 21:47:49 UTC
Created attachment 155477 [details]
an MSO created page that wont render correctly and crashed LO when OpenGL tried
Comment 2 Oliver Brinzing 2019-11-03 08:56:06 UTC
Created attachment 155482 [details]
word drawing LO 6.4 with OpenGL

i can not conform a crash, but rendering is incorrect
Comment 3 John Seager 2019-11-03 19:31:06 UTC
Now I can't make LO crash with these conditions either!  Using the same version, 6.3.2.2, with OpenCL enabled or disabled, then enabling OpenGL I can't make LO crash!  I can't think how I crashed it before but it most certainly did when I enabled OpenGL.  So same result as Oliver Brinzing is seeing - no crash, but incorrect rendering.
Comment 4 Xisco Faulí 2019-11-04 12:05:28 UTC
The crash was reported in bug 128441 and fixed by Julien. This issue covers the problematic graphic display in LibreOffice
Comment 5 Xisco Faulí 2019-11-04 12:06:24 UTC
Created attachment 155504 [details]
comparison MSO 2010 and LibreOffice 6.4 Master
Comment 6 Xisco Faulí 2019-11-04 12:13:18 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=3272c1eb5563f3bda2caa24f32b1018372622109, which is already reported in bug 123435

*** This bug has been marked as a duplicate of bug 123435 ***