Download it now!
Bug 128605 - FILEOPEN: DOC: section break continuous ends page
Summary: FILEOPEN: DOC: section break continuous ends page
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.5
Keywords: bibisected, bisected, regression
: 105285 110432 117260 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-05 09:04 UTC by Ladislav Nesnera
Modified: 2020-04-24 07:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example doc file (287.50 KB, application/msword)
2019-11-05 09:05 UTC, Ladislav Nesnera
Details
wrong result - "pp_LO_6.3.1-problémový výsledek.PNG" (29.91 KB, image/png)
2019-11-05 09:07 UTC, Ladislav Nesnera
Details
expected result - "pp_Word-očekávaný stav.PNG" (104.67 KB, image/png)
2019-11-05 09:08 UTC, Ladislav Nesnera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ladislav Nesnera 2019-11-05 09:04:25 UTC
Description:
The "section break continuous" should start the new section on the same page but it breaks page too.

Steps to Reproduce:
1. open attached LibreOffice_problem_1.doc in Writer and Word
2. compare result

Actual Results:
have a look at file "pp_LO_6.3.1-problémový výsledek.PNG"

Expected Results:
have a look at file "pp_Word-očekávaný stav.PNG"


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Ladislav Nesnera 2019-11-05 09:05:55 UTC
Created attachment 155519 [details]
example doc file
Comment 2 Ladislav Nesnera 2019-11-05 09:07:18 UTC
Created attachment 155520 [details]
wrong result - "pp_LO_6.3.1-problémový výsledek.PNG"
Comment 3 Ladislav Nesnera 2019-11-05 09:08:47 UTC
Created attachment 155521 [details]
expected result - "pp_Word-očekávaný stav.PNG"
Comment 4 Ladislav Nesnera 2019-11-05 09:09:43 UTC
Comment on attachment 155519 [details]
example doc file

= "LibreOffice_problem_1.doc"
Comment 6 Xisco Faulí 2019-11-05 11:50:39 UTC
Confirmed in

Version: 6.4.0.0.alpha1+
Build ID: ee909ca2c02f949605f68720c3f1eef658502749
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Xisco Faulí 2019-11-05 11:59:37 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=c5ed52b1cd6f22787c94bec035ceecf9e1da3271, which is the same as in bug 87764

*** This bug has been marked as a duplicate of bug 87764 ***
Comment 8 Miklos Vajna 2019-11-25 15:18:18 UTC
Let's separate this from bug 87764; this one is a concrete case, while bug 87764 is more or less a request for a large missing Writer feature.
Comment 9 Commit Notification 2019-11-26 19:05:09 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/162722dfa96dc10243e9a07a3c123f22481d42cd

tdf#128605 DOC import: fix cont sect break with different top/bottom margin

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-11-27 09:25:36 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/89deeb8940c8bc9f1ad0c88075df1afdd73d441a

tdf#128605 DOC import: fix cont sect break with different top/bottom margin

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-11-27 11:17:51 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 3a6f270edfffb97763927b2732feacedbdac1e80
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!
Comment 12 Xisco Faulí 2019-11-27 11:22:17 UTC
*** Bug 105285 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2019-11-27 11:23:45 UTC
*** Bug 110432 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2019-11-27 11:24:15 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/96efa0602717c215d4abb31f8a4916516623c417

tdf#128605 DOC import: fix cont sect break with different top/bottom margin

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Justin L 2020-04-24 07:50:22 UTC
*** Bug 117260 has been marked as a duplicate of this bug. ***