Download it now!
Bug 129546 - Skia: Crash when starting LO without supported device
Summary: Skia: Crash when starting LO without supported device
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0
Keywords:
: 129929 (view as bug list)
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2019-12-22 02:46 UTC by Aron Budea
Modified: 2020-01-15 09:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (6.97 KB, text/plain)
2020-01-11 11:41 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-12-22 02:46:19 UTC
This is an Intel i7-3520 CPU with a HD4000 iGP.
When starting an LO master build (6.5.0.0.alpha0+, ddd1d219beb74f55eefbccc3ab8a8883dd0b4b69 / Windows 7), it outputs the following, and then crashes:

warn:vcl.opengl:10404:11080:vcl/opengl/win/WinDeviceInfo.cxx:496: use :
vkEnumeratePhysicalDevices returned no supported devices.
warn:vcl.skia:10404:11080:vcl/skia/gdiimpl.cxx:269: cannot create Vulkan offscreen GPU surface, disabling Vulkan
Illegal instruction
Comment 1 Xisco Faulí 2020-01-10 11:07:21 UTC
I guess it's fine to move it to NEW
Comment 2 Luboš Luňák 2020-01-10 13:41:32 UTC
Can you please provide a backtrace? The 'illegal instruction' is strange, it should mean either miscompilation or some bad memory corruption.
Comment 3 Aron Budea 2020-01-11 11:41:44 UTC
Created attachment 157077 [details]
Backtrace

Attaching backtrace. At this point VS is giving me this message:
"Unhandled exception at 0x000007FEBE9E0E6E (skialo.dll) in soffice.bin: 0xC000001D: Illegal Instruction."
Comment 4 Commit Notification 2020-01-14 11:17:30 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/51882d9ec5a139bc7bc282ebf4ab03ada9ff2694

fix Skia CPU instruction set support (tdf#129546)

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Roman Kuznetsov 2020-01-15 09:09:19 UTC
*** Bug 129929 has been marked as a duplicate of this bug. ***