Bug 129686 - FILEOPEN: PPTX: Text is transparent when it shouldn't
Summary: FILEOPEN: PPTX: Text is transparent when it shouldn't
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, filter:pptx, regression
: 132684 (view as bug list)
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2019-12-29 13:16 UTC by Xisco Faulí
Modified: 2020-06-01 14:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison MSO 2010 and LibreOffice 6.5 Master (59.31 KB, image/png)
2019-12-29 13:16 UTC, Xisco Faulí
Details
sample document (139.76 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-12-29 13:17 UTC, Xisco Faulí
Details
Possibly further instances of this bug (969.23 KB, application/vnd.ms-powerpoint)
2020-05-22 08:54 UTC, Gerald Pfeifer
Details
Possibly further instances of this bug - screenshot with LO 7.0 alpha1 (27.35 KB, image/png)
2020-05-22 08:57 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-12-29 13:16:14 UTC
Created attachment 156835 [details]
comparison MSO 2010 and LibreOffice 6.5 Master

Steps to reproduce:
1. Open attached document

-> Text 'Profitability analysis' is gone. See comparison image

Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: 1abfc8e2f677024ea058e96f3133e503ba89ea02
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2019-12-29 13:17:26 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e01df3488abe6d319c6874ca870afb82a3ad9b1e

author	Xisco Fauli <xiscofauli@libreoffice.org>	2019-10-13 20:59:20 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2019-11-25 12:43:25 +0100
commit	e01df3488abe6d319c6874ca870afb82a3ad9b1e (patch)
tree	06bff7e3e2064526e5a5349ab1a5296310670d3b
parent	916746a5155a1a17225e85d2c30a1c2322aac589 (diff)
tdf#118776: pptx import: draw char noFill as transparent

Bisected with: bibisect-linux64-6.5

Adding Cc: to Xisco Fauli
Comment 2 Xisco Faulí 2019-12-29 13:17:44 UTC
Created attachment 156836 [details]
sample document
Comment 3 Xisco Faulí 2019-12-29 13:19:36 UTC
attachment 114874 [details] from bug 77881 is also affected
Comment 4 Aron Budea 2020-05-09 02:21:34 UTC
*** Bug 132684 has been marked as a duplicate of this bug. ***
Comment 5 Aron Budea 2020-05-09 02:24:21 UTC
What's interesting is that PP doesn't show the affected characters as no fill. I haven't checked the XML, though.
Comment 6 Aron Budea 2020-05-09 02:25:05 UTC
(In reply to Aron Budea from comment #5)
> What's interesting is that PP doesn't show the affected characters as no
> fill. I haven't checked the XML, though.
I mean, in the color picker.
Comment 7 Gerald Pfeifer 2020-05-22 08:54:55 UTC
Created attachment 161120 [details]
Possibly further instances of this bug

Does the attached document exhibit another issue of this bug, or is this
something different and I should file it separately?

What's puzzling in this one is that within each text block some words show,
and some do not.

Seen with current 7.0.0.0 alpha1.
Comment 8 Gerald Pfeifer 2020-05-22 08:57:48 UTC
Created attachment 161121 [details]
Possibly further instances of this bug - screenshot with LO 7.0 alpha1
Comment 9 Commit Notification 2020-05-22 19:05:12 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8bf3e3fbdb708a75237a120d4f6fc46fe67dbbb9

tdf#129686: Revert "tdf#118776: pptx import: draw char noFill as transparent"

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Gerald Pfeifer 2020-05-23 23:21:23 UTC
I confirm that the issue I had been seeing (which looked like damage done
by moths to a set of text blocks, so a bit differently) was resolved between
the last two daily dev-builds, too, so it's safe to assume that the root
cause was the same.
Comment 11 Xisco Faulí 2020-06-01 14:05:53 UTC
(In reply to Gerald Pfeifer from comment #10)
> I confirm that the issue I had been seeing (which looked like damage done
> by moths to a set of text blocks, so a bit differently) was resolved between
> the last two daily dev-builds, too, so it's safe to assume that the root
> cause was the same.

Setting to VERIFIED.
Thanks for checking!