Bug 129916 - FILEOPEN PPTX: shadow size for rectangle is only a fraction of Office 365
Summary: FILEOPEN PPTX: shadow size for rectangle is only a fraction of Office 365
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.0.0
Keywords: filter:pptx, implementationError
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2020-01-10 08:04 UTC by Gerald Pfeifer
Modified: 2020-11-04 12:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample PPTX document (save from 365) (1.30 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-01-10 08:04 UTC, Gerald Pfeifer
Details
How it should look like (Office 365) (15.24 KB, image/png)
2020-01-10 08:05 UTC, Gerald Pfeifer
Details
How it looks like (LibreOffice) (11.35 KB, image/png)
2020-01-10 08:06 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-01-10 08:04:48 UTC
Created attachment 157050 [details]
Sample PPTX document (save from 365)
Comment 1 Gerald Pfeifer 2020-01-10 08:05:21 UTC
Created attachment 157051 [details]
How it should look like (Office 365)
Comment 2 Gerald Pfeifer 2020-01-10 08:06:49 UTC
Created attachment 157052 [details]
How it looks like (LibreOffice)

Looking at this simple sample document, in Office 365 the shadow nearly 
reaches the lower left corner of the page.  In LibreOffice it by far does
not and is perhaps 20% is large as in 365.
Comment 3 Xisco Faulí 2020-01-10 10:48:36 UTC
Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: 838935758a5ec8e0e68f4df0cf5bfcf737e3f6f2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 Aron Budea 2020-04-27 04:47:54 UTC
Already in 4.0.0.3, no shadow in 3.6.0.4. => implementationError
Comment 5 Commit Notification 2020-05-08 19:01:18 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e2b0e614e1185c960b3015414919f69a1ed35aa0

Related: tdf#129916 svx: improve shadow size of custom shapes

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-05-11 08:55:28 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4ba368a3dd793bdc703858f358e1af7112decadd

Related: tdf#129916 svx: clean up duplicated matrix decompose for shadow size

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-05-11 16:48:25 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e21d522dddce2590ed435890ae8d5fe39658a71a

tdf#129916 svx: fix origin of scaled shadow

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Miklos Vajna 2020-05-12 07:07:16 UTC
This is now fixed on master.