Bug 130074 - Many untranslatable line and arrow styles of shapes
Summary: Many untranslatable line and arrow styles of shapes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium trivial
Assignee: Julien Nabet
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: Not-Localizable
  Show dependency treegraph
 
Reported: 2020-01-18 17:32 UTC by Mihkel Tõnnov
Modified: 2020-04-19 08:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2020-01-18 17:32:53 UTC
There are a bunch of line and arrow styles of shapes that can't be translated.

Line styles:

Dot
Long Dot
Double Dot
Long Dash
Double Dash
Long Dash Dot
Double Dash Dot
Double Dash Dot Dot

Arrow styles:

Half Arrow Left
Half Arrow Right
CF One
CF Only One
CF Many
CF Many One
CF Zero One
CF Zero Many
Reversed Arrow
Comment 1 ian 2020-01-19 21:16:36 UTC
Thank you for reporting the bug. 

Can you please supply additional information about what LibreOffice product i.e. Writer, Draw, etc. you are specifically referring to, as well as what language with which you are experiencing issues?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested information is provided.
Comment 2 Mihkel Tõnnov 2020-01-19 22:40:28 UTC
Affects all components where shapes can be used.
And as these strings are not in Weblate, all languages.
Comment 3 Ming Hua 2020-01-19 23:55:57 UTC
The strings for line styles are in core/extras/source/palettes/standard.sod:
https://opengrok.libreoffice.org/xref/core/extras/source/palettes/standard.sod
and the strings for arrow styles are in core/extras/source/palettes/standard.soe:
https://opengrok.libreoffice.org/xref/core/extras/source/palettes/standard.soe

Not sure why some are translatable while others are not, though.
Comment 5 Julien Nabet 2020-01-20 19:42:38 UTC
Xisco: I can change an existing translation but I don't know how to add one.
=> can't help here.
Comment 6 Julien Nabet 2020-01-31 22:02:00 UTC
New line styles have been added with:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=b2d8093b19642038631dfb8f1ab6745a380a652c

New arrow styles from:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=b15fef02c9311e0c160906769abbf96a96e56c73

Let's try to find how to make them translatable comparing with the existing.
Comment 7 Julien Nabet 2020-01-31 23:44:24 UTC
Here's a try for line styles part:
https://gerrit.libreoffice.org/#/c/core/+/87792/
Comment 8 Julien Nabet 2020-02-04 20:10:51 UTC
(In reply to Julien Nabet from comment #7)
> Here's a try for line styles part:
> https://gerrit.libreoffice.org/#/c/core/+/87792/

No feedback on gerrit, I abandoned it. If someone wants to review it, just restore the patch.
Comment 9 andreas_k 2020-02-05 07:56:07 UTC
Hi Julian,

I am ill since 10 day's but will have a look on the patch. I hope I can help and thanks for your help.
Comment 10 Julien Nabet 2020-02-05 08:13:15 UTC
(In reply to andreas_k from comment #9)
> Hi Julian,
> 
> I am ill since 10 day's but will have a look on the patch. I hope I can help
> and thanks for your help.

No pb! :-) (health IS the real priority in life)
Comment 11 andreas_k 2020-02-22 16:42:58 UTC
I see that I didn't add my patch for new arrow styles into master. So when I add the new arrow styles I will have a look on the translation stuff to.

Also for line style I will check that it's possible to have the strings translated.
Comment 12 Commit Notification 2020-03-26 14:25:27 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/637df9463d0d901616a5d588c71da84a99b9cb42

tdf#130074: add missing translations (line styles part)

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Julien Nabet 2020-04-03 09:06:00 UTC
Backport for 6.4 on review here:
https://gerrit.libreoffice.org/c/core/+/91614
Comment 14 andreas_k 2020-04-03 09:07:02 UTC
Thanks a lot
Comment 15 Julien Nabet 2020-04-03 10:34:42 UTC
Argh, re reading all this, I did only half of the job.
There are still arrow styles.

About backport in 6.4, it's not sure it can be done since the string freeze for 6.4 has already happened.
See comments in https://gerrit.libreoffice.org/c/core/+/91614
Comment 16 Julien Nabet 2020-04-03 11:16:08 UTC
I abandoned the backport patch.

So next step is to take a look at the second part of the bugtracker to try to fix it for next major LO release 7.0
Comment 17 Commit Notification 2020-04-10 07:38:40 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4102c4df3ae0446c9cdd55d64459d975ed18103f

tdf#130074 untranslated Arrow style strings

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Heiko Tietze 2020-04-19 08:55:51 UTC
Guess we can close the ticket.