Download it now!
Bug 130224 - Spellcheck eats footnotes in Writer.
Summary: Spellcheck eats footnotes in Writer.
Status: RESOLVED DUPLICATE of bug 132288
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2020-01-27 13:52 UTC by tehanulilac
Modified: 2020-04-21 07:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
situation before spell check (8.33 KB, application/vnd.oasis.opendocument.text)
2020-04-21 07:11 UTC, giors_00
Details
situation after spellchecking (8.20 KB, application/vnd.oasis.opendocument.text)
2020-04-21 07:11 UTC, giors_00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tehanulilac 2020-01-27 13:52:57 UTC
Description:
Checking the spelling causes a footnote number appended in that sentence to become an actual string of digits, while the footnote proper disappears. I think it only happens if  there is actually some "error" to correct or ignore (an unrecognized proper name, a rare word or a real spelling mistake), not when the whole spellcheck goes smoothly. As many as one fourth of all footnotes are eaten this way. Only seen this in text set to English (UK), but I have no idea if that matters. It may be a worse problem in MS Word formats.

Steps to Reproduce:
1. Have a longish .doc, .docx or .odt with a truckload of footnotes and the language parameter set. I actually arrive at those by translating from another language and apply the language setting arbitrarily before or during the process.
2.Have terms in the text the spellchecker won't recognize.
3.Run a thorough spellcheck.

Actual Results:
Footnotes are probably missing. 150 out of 600 is not unusual. All the places where a footnote disappeared now have a number inserted.

Expected Results:
The same footnotes in the same places and with the same numbers as before the spellcheck. Please.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
I think it's recent-ish. In that the previous version may have done that too, but a year or two years ago the problem didn't exist.
Comment 1 Xisco Faulí 2020-01-28 11:14:22 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 giors_00 2020-04-21 07:05:51 UTC
Same here with Spanish. 

It is frankly quite simple to reproduce the bug. 

1. Just write to words deliberately wrongly (with ortographic mistakes or just two invented words - try with "ooooo" and "iiiiii"). 
2. Make each of them to be followed by a footnote (you can leave the footnote text empty. Just add the footnotes). 
3. press F7 (or launch the spellchecker). Doesn't meter what you do (just press cancel and close dialog): you will see your footnotes have disappeared (!!!) and the anchor has been converted into a number!

It's annoying me very very much since I work with very long and complex documents with a lot of footnotes (in the last one, I have more than 500) and every time a launch the spellchecker some of them disappears!

I desperately look for a workaround

(I reported a bug today that maybe is a duplicate. sorry, didn't see this report before).
Comment 3 giors_00 2020-04-21 07:11:02 UTC
Created attachment 159776 [details]
situation before spell check

I hereby send and example of the situation I have before spellchecking
Comment 4 giors_00 2020-04-21 07:11:43 UTC
Created attachment 159777 [details]
situation after spellchecking

And here you have the situation after spellchecking
Comment 5 giors_00 2020-04-21 07:12:08 UTC
I attached an example (before and after spellchecking).
Comment 6 Dieter 2020-04-21 07:23:10 UTC

*** This bug has been marked as a duplicate of bug 132288 ***