Download it now!
Bug 132288 - Spell check erases footnotes
Summary: Spell check erases footnotes
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.4
Keywords: bibisected, bisected, regression
: 130224 130355 130443 133338 (view as bug list)
Depends on:
Blocks: Footnote-Endnote Spell-Checking-Dialog
  Show dependency treegraph
 
Reported: 2020-04-21 06:37 UTC by giors_00
Modified: 2020-05-25 06:31 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Very simple reproducer document (13.46 KB, application/vnd.oasis.opendocument.text)
2020-04-24 12:53 UTC, NISZ LibreOffice Team
Details
Example file (8.82 KB, application/vnd.oasis.opendocument.text)
2020-04-26 19:53 UTC, Telesto
Details
reproducer steps and that version does the right thing as far as I can see (250.37 KB, video/webm)
2020-04-27 09:11 UTC, Caolán McNamara
Details
Screencast (97.03 KB, video/mp4)
2020-04-27 10:06 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description giors_00 2020-04-21 06:37:42 UTC
Description:
Write two words wrongly each of them followed by a footnote. Launch the spell checker and just close it. Footnotes have disappeared being the anchor converted into a number.

Steps to Reproduce:
1.write at least two words wrongly, following each with a footnote
2.press F7 or open spell check dialog
3.just press close button.footnote have disappeared (if they don't try step 2 another time)

Actual Results:
Footnotes disappear and the anchor is converted into a number

Expected Results:
Spell check should not delete the footnote


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Just correct the wrong word (or nothing)
Comment 1 Dieter 2020-04-21 07:21:27 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 1c9ced04189c9d23ffea05d5570960b54b05ef28
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL

and also with

Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

but not with

Version: 6.1.6.3 (x64)
Build-ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group threaded
Comment 2 Dieter 2020-04-21 07:22:05 UTC
*** Bug 130443 has been marked as a duplicate of this bug. ***
Comment 3 Dieter 2020-04-21 07:22:24 UTC
*** Bug 130355 has been marked as a duplicate of this bug. ***
Comment 4 Dieter 2020-04-21 07:23:10 UTC
*** Bug 130224 has been marked as a duplicate of this bug. ***
Comment 5 NISZ LibreOffice Team 2020-04-24 12:53:01 UTC
Created attachment 159898 [details]
Very simple reproducer document

Bibisected with bibisect-win32-6.3/ to:

https://git.libreoffice.org/core/+/243b5b392906042ab03800e0b5765e6f3513372c

author
Caolán McNamara <caolanm@redhat.com> Fri Jun 14 21:56:44 2019 +0100 
committer
Caolán McNamara <caolanm@redhat.com> Sat Jun 22 19:28:38 2019 +0200 

weld SpellDialog
Comment 6 NISZ LibreOffice Team 2020-04-24 12:54:38 UTC
Adding CC to: Caolán McNamara
Comment 7 NISZ LibreOffice Team 2020-04-24 13:03:15 UTC
It's important with the above test file to have the English dictionary installed, which is not by default in the bibisect repos: https://extensions.libreoffice.org/extensions/english-dictionaries
Comment 8 Commit Notification 2020-04-24 19:04:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9e8bb8fa8a77665552db9c01cac1034d5040da7b

Resolves: tdf#132288 don't merge adjacent properties for spell checking

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2020-04-24 19:05:55 UTC
that should do it, fixed in master backport to 6-4 in gerrit
Comment 10 giors_00 2020-04-26 09:58:15 UTC
Any help for installing the corrected version in Arch linux?
Comment 11 giors_00 2020-04-26 10:53:29 UTC
I installed Libreoffice6-4.4.0.0 (2020-4-25) from rpm package for Linux and I have to confirm that bug there. Don't know if I got the wrong package.... 

here is the link https://dev-builds.libreoffice.org/daily/libreoffice-6-4/Linux-rpm_deb-x86_64@86-TDF/2020-04-25_18.14.39/libreoffice-6-4~2020-04-25_18.14.39_LibreOfficeDev_6.4.4.0.0_Linux_x86-64_rpm.tar.gz

I can confirm that bug keeps being in that version. Someone can check?
Comment 12 Dieter 2020-04-26 11:04:39 UTC
(In reply to giors_00 from comment #11)
> I installed Libreoffice6-4.4.0.0 (2020-4-25) from rpm package for Linux and

Please download and install master: https://dev-builds.libreoffice.org/daily/master/current.html Installation will be in parallel.
Comment 14 giors_00 2020-04-26 15:04:14 UTC
Confirm that at least on linux is not solved
Comment 15 Telesto 2020-04-26 19:53:20 UTC
Created attachment 159969 [details]
Example file

Still reproducible (with different example)

1. Open the attached file
2. Press F7
3. Press Close
Comment 16 Caolán McNamara 2020-04-27 09:11:54 UTC
Created attachment 159988 [details]
reproducer steps and that version does the right thing as far as I can see
Comment 17 Telesto 2020-04-27 10:06:56 UTC
Created attachment 159989 [details]
Screencast

(In reply to Caolán McNamara from comment #16)
> Created attachment 159988 [details]
> reproducer steps and that version does the right thing as far as I can see

It's working fine with the initial example file, as you demonstrated in the screencast. However it isn't working properly for the example I uploaded. Screencast attached

1. Open attachment 159969 [details] 
2. Press F7
3. Press Close
Comment 18 Xisco Faulí 2020-04-28 09:52:28 UTC
(In reply to Telesto from comment #17)
> Created attachment 159989 [details]
> Screencast
> 
> (In reply to Caolán McNamara from comment #16)
> > Created attachment 159988 [details]
> > reproducer steps and that version does the right thing as far as I can see
> 
> It's working fine with the initial example file, as you demonstrated in the
> screencast. However it isn't working properly for the example I uploaded.
> Screencast attached
> 
> 1. Open attachment 159969 [details] 
> 2. Press F7
> 3. Press Close

Yes, reproducible in

Version: 7.0.0.0.alpha0+
Build ID: 4ba1909f12b49f020195b5e767045340717ce6df
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

The bisection also points to https://git.libreoffice.org/core/+/243b5b392906042ab03800e0b5765e6f3513372c
Comment 19 Commit Notification 2020-04-29 07:48:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0877e320b8498f3ee3875f2730a6040f708154b4

tdf#132288 preservation of footnote depends on reverse iteration

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-04-29 08:15:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/994526fadb3faeb57c47cf1060a2ad7d53bd4f94

Resolves: tdf#132288 don't merge adjacent properties for spell checking

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Caolán McNamara 2020-04-29 11:55:03 UTC
second case now also works, as far as I can see
Comment 22 Dieter 2020-05-02 15:28:34 UTC
(In reply to Caolán McNamara from comment #21)
> second case now also works, as far as I can see

Verified with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: b8fb7ecd9cdbe1898c41eaecd9894df8e8f01e25
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Caolán, thanks for fixing this issue!
Comment 23 giors_00 2020-05-03 09:50:13 UTC
Good morning everybody, 

I can confirm it is also solved on linux. The patch seems to solve also the issue I mentioned here (https://bugs.documentfoundation.org/show_bug.cgi?id=132290).

Really look forward to having the possibility to install through the stable channel. Any idea on when will it be possible? (now running 6.4.3.2 on arch linux).

Finally, I would like to thank you all for the quick solution!
Comment 24 Dieter 2020-05-03 10:25:33 UTC
(In reply to giors_00 from comment #23)
> Really look forward to having the possibility to install through the stable
> channel. Any idea on when will it be possible? (now running 6.4.3.2 on arch
> linux).

LO 6.4.4. will be released in second half of may, see https://wiki.documentfoundation.org/ReleasePlan
Comment 25 Telesto 2020-05-25 06:31:30 UTC
*** Bug 133338 has been marked as a duplicate of this bug. ***