Download it now!
Bug 130393 - FILEOPEN DOCX Paragraph direct formatting not applied inside table
Summary: FILEOPEN DOCX Paragraph direct formatting not applied inside table
Status: RESOLVED DUPLICATE of bug 130494
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2020-02-03 15:09 UTC by NISZ LibreOffice Team
Modified: 2020-02-12 09:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Word and Writer (218.43 KB, image/png)
2020-02-03 15:09 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-02-03 15:09:03 UTC
Created attachment 157619 [details]
Screenshot of the original document side by side in Word and Writer

Attachment #156045 [details] has some tables that had font size with direct formatting set to 12 pt. Recently this started to change to 14 pt, effectively making longer text overflow.
The 14pt setting is visible in Word when I position the cursor on the end of cell marker (¤) but 12 pt is set for the text.

Steps to reproduce:
    1. Open Attachment #156045 [details] from bug #128959

Actual results:
The second and third lines text in the first table does not fit in the cell.

Expected results:
All text visible

LibreOffice details:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: ee9a15422561dfae0ae259c1641695f6c5c41388
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: en-US (hu_HU); UI-Language: en-US
Calc: CL

Additional Information: 

Bibisected using bibisect-win64-6.5 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=2ab481b038b62b1ff576ac4d49d03c1798cd7f84
author	László Németh <nemeth@numbertext.org>	2020-01-08 14:26:40 +0100
committer	László Németh <nemeth@numbertext.org>	2020-01-09 18:00:16 +0100
summary: tdf#90069 DOCX: fix character style of new table rows
Comment 1 NISZ LibreOffice Team 2020-02-03 15:14:07 UTC
Adding CC to: László Németh
Comment 2 Dieter 2020-02-04 18:24:05 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: eeb2d19e77d6dc47c68e8ba0920a02cf64a1247b
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 3 Xisco Faulí 2020-02-06 21:30:10 UTC
attachment 103915 [details] from bug 82076 is also affected by this issue. See text 'limited'
Comment 4 Xisco Faulí 2020-02-06 21:33:21 UTC
attachment from bug 42486 is also affected
Comment 5 Xisco Faulí 2020-02-06 21:47:28 UTC
just for the record, the office-interoperability-tools found quite some files affected by 2ab481b038b62b1ff576ac4d49d03c1798cd7f84. I've just mentioned a few. If needed, I can mention more.
Comment 6 László Németh 2020-02-11 15:35:08 UTC
Xisco: The fix for Bug 130494 fixed the reported documents of this issue. If there are no other failing tests cases, it's possible to close this as a duplicate of Bug 130494. Thanks for your help!
Comment 7 Xisco Faulí 2020-02-11 15:39:57 UTC
(In reply to László Németh from comment #6)
> Xisco: The fix for Bug 130494 fixed the reported documents of this issue. If
> there are no other failing tests cases, it's possible to close this as a
> duplicate of Bug 130494. Thanks for your help!

sure, please go ahead.
I'll run the scripts with your patch included
Comment 8 Xisco Faulí 2020-02-12 09:52:52 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 718f540fb63af27c1336f89213444e9af753b8a9
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Closing as dupe of bug 130494

*** This bug has been marked as a duplicate of bug 130494 ***