Download it now!
Bug 130494 - FILEOPEN: DOCX: Text is incorrectly highlighted
Summary: FILEOPEN: DOCX: Text is incorrectly highlighted
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
: 105593 130393 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-06 21:10 UTC by Xisco Faulí
Modified: 2020-05-19 08:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (47.03 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-02-06 21:10 UTC, Xisco Faulí
Details
Comparison MSO 2010 and LibreOffice 7.0 master (518.61 KB, image/png)
2020-02-06 21:12 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-02-06 21:10:23 UTC
Created attachment 157710 [details]
sample file

Steps to reproduce:
1. Open attached document

-> Some strings have yellow highlight. See comparison file

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: d41d7ecb60fb38204fafcb1aa4595992721855e6
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-02-06 21:12:31 UTC
Created attachment 157711 [details]
Comparison MSO 2010 and LibreOffice 7.0 master
Comment 2 Xisco Faulí 2020-02-06 21:13:37 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2ab481b038b62b1ff576ac4d49d03c1798cd7f84


author	László Németh <nemeth@numbertext.org>	2020-01-08 14:26:40 +0100
committer	László Németh <nemeth@numbertext.org>	2020-01-09 18:00:16 +0100
commit	2ab481b038b62b1ff576ac4d49d03c1798cd7f84 (patch)
tree	9739e3b799bd06ba07d8cca7ad6c8b85de75dda8
parent	79084665f0e351a3f83fdee88071919f05ec9cc3 (diff)
tdf#90069 DOCX: fix character style of new table rows

Bisected with: bibisect-linux64-6.5

Adding Cc: to László Németh
Comment 3 Commit Notification 2020-02-11 15:33:42 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/abb9c7db8bcc06f907d39a7811711882161d5803

tdf#130494: DOCX import: limit paragraph-level character property

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2020-02-12 09:48:40 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 718f540fb63af27c1336f89213444e9af753b8a9
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Lázló, thanks for fixing this issue!!
Comment 5 Xisco Faulí 2020-02-12 09:51:32 UTC
*** Bug 105593 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2020-02-12 09:52:52 UTC
*** Bug 130393 has been marked as a duplicate of this bug. ***