Bug 130482 - Can't align text in a textbox
Summary: Can't align text in a textbox
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+ Master
Hardware: All All
: highest critical
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.0.0 target:6.4.2 target:6.4.1
Keywords: bibisected, bisected, regression
: 130038 130683 130703 130718 130743 130820 130918 131583 (view as bug list)
Depends on:
Blocks: Textbox
  Show dependency treegraph
 
Reported: 2020-02-06 10:03 UTC by Maxim Monastirsky
Modified: 2020-03-25 20:57 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Monastirsky 2020-02-06 10:03:22 UTC
Steps to reproduce:

1. Open Writer.
2. Insert text box.
3. Try to align the text inside it (to either left, center, right, justified) using the toolbar or sidebar buttons => nothing happens.

This used to work in at least:

Version: 6.3.4.2.0+
Build ID: 6.3.4.2-2.fc31
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

=> regression.
Comment 1 Maxim Monastirsky 2020-02-06 10:04:56 UTC
Confirmed in Bug 130403 comment 2 and in Bug 130463 comment 1 => NEW.
Comment 2 Maxim Monastirsky 2020-02-06 10:58:20 UTC
There seems to be more formatting functions that are broken now with text boxes, e.g. superscript and subscript. Also setting anything from the Format > Character... dialog has no effect. I guess all these are related somehow, as they all follow similar code path in SwDrawTextShell::Execute.
Comment 3 Xisco Faulí 2020-02-06 14:19:10 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a3c7a8282ddd08c7ed4a15d23089d09e418f8fae

author	Szymon Kłos <szymon.klos@collabora.com>	2019-11-08 17:13:05 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2019-11-11 14:25:13 +0100
commit	a3c7a8282ddd08c7ed4a15d23089d09e418f8fae (patch)
tree	00f5b11225acc1abe88bb7deeda873172d54cca9
parent	572a8132e0e460b17c80c456dfb5e07f6b9a9c6a (diff)
jsdialogs: apply .uno:Color and CharBackColor to floating text frames

Tested locally by reverting the commit

Adding Cc: to Szymon Kłos
Comment 4 Miklos Vajna 2020-02-07 11:43:58 UTC
I'll take a look.
Comment 5 Commit Notification 2020-02-08 08:05:58 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b03504bf054bd4094b985ef8ebb9ac55fa69a487

tdf#130482 sw: fix text alignment in shape text

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-02-10 08:37:57 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 4188c7e2132ec3f1c3e879c179e92ff75c86d24f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 7 Commit Notification 2020-02-10 11:44:04 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/942c0d71a91839fc1762c7e93417e7bb703ea3cf

tdf#130482 sw: fix text alignment in shape text

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Maxim Monastirsky 2020-02-12 09:01:57 UTC
*** Bug 130038 has been marked as a duplicate of this bug. ***
Comment 9 Ming Hua 2020-02-12 20:49:30 UTC
*** Bug 130627 has been marked as a duplicate of this bug. ***
Comment 10 Julien Nabet 2020-02-15 15:25:23 UTC
*** Bug 130683 has been marked as a duplicate of this bug. ***
Comment 11 Dieter 2020-02-16 11:49:56 UTC
*** Bug 130703 has been marked as a duplicate of this bug. ***
Comment 12 Julien Nabet 2020-02-16 19:23:07 UTC
*** Bug 130718 has been marked as a duplicate of this bug. ***
Comment 13 Julien Nabet 2020-02-17 20:27:52 UTC
*** Bug 130743 has been marked as a duplicate of this bug. ***
Comment 14 raal 2020-02-17 21:52:54 UTC Comment hidden (obsolete)
Comment 15 Commit Notification 2020-02-20 19:09:32 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-1":

https://git.libreoffice.org/core/commit/21b531f5dc2452a0bd42273ce0aa1d7809a4ebec

tdf#130482 sw: fix text alignment in shape text

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Dieter 2020-02-21 19:38:02 UTC
*** Bug 130820 has been marked as a duplicate of this bug. ***
Comment 17 Julien Nabet 2020-02-25 08:57:47 UTC
*** Bug 130918 has been marked as a duplicate of this bug. ***
Comment 18 Julien Nabet 2020-03-25 20:57:18 UTC
*** Bug 131583 has been marked as a duplicate of this bug. ***