Bug 131233 - improve UX around info message "Missing hyphenation info - please install the hyphenation package for locale "de".
Summary: improve UX around info message "Missing hyphenation info - please install the...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.3.0
Keywords: difficultyMedium, easyHack, skillCpp, topicUI
: 142644 (view as bug list)
Depends on:
Blocks: Infobar
  Show dependency treegraph
 
Reported: 2020-03-09 12:15 UTC by steve
Modified: 2022-02-09 23:33 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Infobar (7.39 KB, image/png)
2020-03-12 13:40 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description steve 2020-03-09 12:15:50 UTC
Description:
When I open LibreOffice 6.4.1.2 I see the error message:
"Missing hyphenation info - please install the hyphenation package for locale "de".

Steps to Reproduce:
Open a writer file (with german text and a few "-")

Actual Results:
Error message is shown when document is opened.

Expected Results:
The eror message is not actionable and not helpful to users in its current form.

Searching the help is not useful: https://help.libreoffice.org/6.4/en-US/text/swriter/guide/using_hyphen.html

The error message should probably be rephrased? In it's current form it is not clear this is about a missing extension.

Also users are not informed how to resolve the problem and where to look for which information.


Reproducible: Always


User Profile Reset: No



Additional Info:
installing the following extension solved the problem:
https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries

Unsure how I ended up in that state - in my case, I didn't have any german dictionary at all.

Version: 6.4.1.2
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Mac OS X 10.15.3; UI render: default; VCL: osx; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 ian 2020-03-11 13:41:52 UTC
Thank you for reporting the error dialog suggestion. 

I have set the bug's severity to "enhancement".
Comment 2 Thomas Lendo 2020-03-12 09:22:21 UTC
Is this an infobar message or in a dialog?

If there is any request to the user, then a link to a help page that explains the next steps or a link to the hyphenation install package page should be shown. Otherwise it's useless.
Comment 3 Cor Nouws 2020-03-12 13:16:43 UTC
(In reply to Thomas Lendo from comment #2)
> Is this an infobar message or in a dialog?
Infobar.

> If there is any request to the user, then a link to a help page that
> explains the next steps or a link to the hyphenation install package page
> should be shown. Otherwise it's useless.
Not completely useless, but relevant information is definitely preferred.
Comment 4 Heiko Tietze 2020-03-12 13:40:01 UTC
Created attachment 158653 [details]
Infobar

New document, some German text, paragraph style with automatic hyphenation, save - open without dictionary.
Comment 5 Adalbert Hanßen 2020-03-16 12:53:47 UTC
Today I installed the latest development version, which currently is

Version: 7.0.0.0.alpha0+
Build-ID: 17e712ccc8fa93d57672916e3c8adaa8febc9f8c
CPU-Threads: 4; BS: Linux 5.3; UI-Render: Standard; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-03-13_16:53:06
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

I got the message

Missing hyphenation data Please install the hyphenation package for locale "en"

The message did not go away even after I installed LibreOfficeDev_7.0.0.0.alpha0_Linux_x86-64_deb_langpack_en-GB

An indication how to install the proper language package would be very helpful in this situation.
Comment 6 Heiko Tietze 2020-03-16 17:08:28 UTC
So let's add a button to the infobar, which links to the right help page. The button is pretty easy to implement, just look at how WhatsNew [1] and on/offline help links [2] are implemented.
But we need a help page first. Olivier/Ilmari, anything that exists? 

[1] https://opengrok.libreoffice.org/xref/core/sfx2/source/view/viewfrm.cxx?r=9ad252b2#1276
[2] https://opengrok.libreoffice.org/xref/core/cui/source/dialogs/tipofthedaydlg.cxx
Comment 7 Buovjaga 2020-03-17 06:48:07 UTC
(In reply to Heiko Tietze from comment #6)
> So let's add a button to the infobar, which links to the right help page.
> The button is pretty easy to implement, just look at how WhatsNew [1] and
> on/offline help links [2] are implemented.
> But we need a help page first. Olivier/Ilmari, anything that exists? 

No, there is no help page explaining this in the way steve would have needed (we investigated this while chatting back when he filed this report).
Comment 8 j.a.swami 2020-07-11 14:01:16 UTC
I am experiencing what seems essentially the same issue, with English rather than German. The error message, however, appears only intermittently (I'm not sure under which conditions). And as far as I can tell, the required files for hyphenation are already installed. 

LibreOffice
Version: 6.4.4.2
Build ID: 1:6.4.4-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US

Ubuntu 20.04.
Comment 9 Jon Piesing 2020-07-14 13:50:10 UTC
(In reply to j.a.swami from comment #8)
> I am experiencing what seems essentially the same issue, with English rather
> than German. The error message, however, appears only intermittently (I'm
> not sure under which conditions). And as far as I can tell, the required
> files for hyphenation are already installed. 
> 
> LibreOffice
> Version: 6.4.4.2
> Build ID: 1:6.4.4-0ubuntu0.20.04.1
> CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
> Locale: en-US (en_US.UTF-8); UI-Language: en-US
> 
> Ubuntu 20.04.

Same here. Idential version of LibreOffice. Also Ubuntu 20.04. I've not managed to find what I need to install to get this to go away.
Comment 10 ads 2020-07-16 12:06:31 UTC
Same thing for me except the system thinks I need the hyphenation package for locale 'fr'. I have no idea why it thinks I am editing a french document. I don't have or want any french dictionary.

In my opinion this should not be marked as an enhancement, it is broken code in some new feature. This same document worked quite well with whatever version of libreoffice I had installed in May 2019, without giving irritating and useless messages in the infobar.
Comment 11 ads 2020-07-16 12:09:38 UTC
Sorry I should have my version details:
Version: 6.4.5.2
Build ID: 6.4.5-2
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Comment 12 Putu Shinoda 2020-07-23 14:00:25 UTC
In my case (Indonesia, using Bahasa Indonesia, with locale "id"), with this command :
putu-shinoda@my-dell-machine:~$ sudo apt-get install -y hyphen-hyphenation-patterns-id

You can try it with your locale (de). 

Hope it help.

Regard
Comment 13 Heiko Tietze 2021-06-07 07:25:25 UTC
*** Bug 142644 has been marked as a duplicate of this bug. ***
Comment 14 Heiko Tietze 2021-07-01 09:02:08 UTC
(In reply to Heiko Tietze from comment #6)
> ... links to the right help page.

The help is too static for the various option to install a package. I requested a hub link to https://wiki.documentfoundation.org/Language/Support in rdm#3528.
Comment 15 Commit Notification 2021-07-13 12:57:16 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/14653f89a83982ef36346ebc15f14099fd5cf8f1

Resolves tdf#131233 - UX around "Missing hyphenation"

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Michael 2022-02-09 10:22:22 UTC
Hi, I just installed Open Office 7.3.0.3 again after a very long time. The warning '"Please install the hyphenation package for locale “de-DE”.' appeared. From the perspective of a new user, this is very confusing and not at all helpful.

Google brought me here and I knew that some extension is missing. However "hyphenation package" is not an extension. So it took further research. This is very off-putting for new users. I'd suggest you change this into:

"Please install the Extension: German Spellchecker (de-DE frami)"

Ideally with a link or button to the necessary extension. If the help text is not giving an answer, you might as well do "Error code 737474747". At least that would be much easier to search for.

Hope you don't take this feedback too negatively, I'm just trying to give you the perspective from a first-time user.
Comment 17 Buovjaga 2022-02-09 10:24:10 UTC
Ok, but please don't change the status just to comment.
Comment 18 Heiko Tietze 2022-02-09 11:20:48 UTC
(In reply to Michael from comment #16)
> "Please install the Extension: German Spellchecker (de-DE frami)"

What if a language has different dictionaries? Or if a better extension is released by someone else? The power of extensions would be lost if we hard-code a reference to one specific. Your freedom of choice is also a burden at usability.
Comment 19 steve 2022-02-09 12:02:19 UTC
I have been a long time LibreOffice user and I have no understanding of which extension to look for or where to look for that extension or how to even understand if a better extension than the extension I am already having a hard time finding exists.

I can only imagine how less computer affine users handle this (they won't).

At least give users a chance to resolve the problem by hinting at the location this problem needs to be solved at and give some guidance.

There was a fix but I am not sure what the fix looks like in LibreOffice and how the UI has changed.

@Heike could you add a screenshot of what the solution now looks like in LO?
Comment 20 Heiko Tietze 2022-02-09 12:54:57 UTC
(In reply to steve from comment #19)
> @Heike could you add a screenshot of what the solution now looks like in LO?

The patch adds a button to the infobar which opens https://hub.libreoffice.org/HyphenationMissing/. It's resolved/fixed, if anything is missing, please open another ticket.
Comment 21 steve 2022-02-09 23:33:54 UTC
@Michael: since the patch went into 7.3.0, the button Heiko mentioned should have been visible in your case. Did you click it and then land on the wiki page?