Download it now!
Bug 131333 - Cannot change data point icons in Calc's XY or points and lines chart
Summary: Cannot change data point icons in Calc's XY or points and lines chart
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All Mac OS X (All)
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords: bibisected, bisected, regression
: 131647 132998 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-14 09:00 UTC by Hans
Modified: 2020-05-16 19:38 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
v6.3.5.2, icon does change (1.15 MB, video/quicktime)
2020-03-28 09:38 UTC, Hans
Details
v6.4.x.x, icon does not change (664.90 KB, video/quicktime)
2020-03-28 09:39 UTC, Hans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans 2020-03-14 09:00:22 UTC
Description:
In Calc, I cannot change the data point icons in my XY charts. No matter what I select from Symbols or Gallery, the icon stays the default one.
(I didn't try other chart types yet.)

Steps to Reproduce:
1. In Calc, create some data for XY chart with 1st row and 1st column as labels
2. create XY chart with points and lines
3. select data series
4. change data point icon

Actual Results:
data point icon stays the same

Expected Results:
data point icons should change to the selected one


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.1.2
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 2; OS: Mac OS X 10.11.6; UI render: GL; VCL: osx; 
Locale: de-DE (en.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Julien Nabet 2020-03-14 16:31:03 UTC
On pc Debian x86-64 with LO Debian package 6.4.1.2, I don't reproduce this.

What icon did you choose precisely? (from symbols? from gallery? other?)
Perhaps MacOS only bug?
Comment 2 Hans 2020-03-14 16:58:27 UTC
I've tried every icon from symbols and about 10 gallery icons. They all failed.

Yes, it could be Mac only.

I compared with 2 older versions:
v6.4.1.2 on Mac OS X 10.11 fails,
v6.4.0.0 on Mac OS X 10.11 fails,
v6.3.5.2 on Mac OS X 10.11 works fine.

It's in both 6.4 releases.
Comment 3 Hans 2020-03-14 17:01:00 UTC
(In reply to Hans from comment #2)
> I've tried every icon from symbols and about 10 gallery icons. They all
> failed.
> 
> Yes, it could be Mac only.
> 
> I compared with 2 older versions:
> v6.4.1.2 on Mac OS X 10.11 fails,
> v6.4.0.0 on Mac OS X 10.11 fails,
> v6.3.5.2 on Mac OS X 10.11 works fine.
> 
> It's in both 6.4 releases.

Typo correction: v6.4.0.0 should read v6.4.0.3.
Comment 4 Hans 2020-03-28 09:18:34 UTC
Bug is in the new release, 6.4.2.2, Mac OS X 10.11.6, too.
The older release, 6.3.5.2, does not have it.

Version: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 2; OS: Mac OS X 10.11.6; UI render: GL; VCL: osx; 
Locale: de-DE (en.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Julien Nabet 2020-03-28 09:24:04 UTC
Would it be possible you attach a screencast?
It may help people to reproduce this.
Comment 6 Hans 2020-03-28 09:38:43 UTC
Created attachment 159088 [details]
v6.3.5.2, icon does change
Comment 7 Hans 2020-03-28 09:39:22 UTC
Created attachment 159089 [details]
v6.4.x.x, icon does not change
Comment 8 Hans 2020-03-28 09:41:49 UTC
You're right. Here they are.
6.3.5.2, as it should be. And 6.4.2.2, as it currently is.
Comment 9 Julien Nabet 2020-03-28 12:57:01 UTC
Thank you for your feedback.
I gave a new try with master sources updated today (gtk3 and gen rendering), I still don't reproduce this.
Idem with LO Debian package 6.4.2.2

Would it be possible you attach a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#macOS:_How_to_get_debug_information)

Alex: Would you have some time to give it a try on your Mac?
Comment 10 Hans 2020-03-28 13:53:14 UTC
I tried the 'force quit' procedure, but I don't have the report-dialog for LibreOffice.
I've tried admin and verified com.apple.CrashReporter DialogType with no success.
But I know I have the dialog when force-quitting an app that is not responding.
So, sorry, no backtrace.
Comment 11 Hans 2020-03-28 14:02:52 UTC
I reproduced the faulty behavior on another Macbook running 10.15 Catalina.
So it's not just in 10.11 El Capitan and not only on my Macbook.
(I'm using a mid2009 Macbook and cannot install a Mac OS newer than 10.11 El Capitan.)

Version: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 8; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Julien Nabet 2020-03-29 10:27:13 UTC
*** Bug 131647 has been marked as a duplicate of this bug. ***
Comment 13 Julien Nabet 2020-03-29 10:27:43 UTC
Confirmed with duplicate tdf#131647
Comment 14 Julien Nabet 2020-03-29 10:29:20 UTC
Remove "wantbacktrace", it's not a crash (stupid me!)
Comment 15 Julien Nabet 2020-03-29 13:59:46 UTC
I don't know if it may be related but when going to Tools/Options/View, what's your Icon style?

(Mine is "Elementary" by default)
Comment 16 Commit Notification 2020-03-29 14:13:11 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e0550b3c0969a8ff70028d2c02b56ced058b0d9a

Related tdf#131333: Cannot change data point icons in Calc's XY chart

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Julien Nabet 2020-03-29 14:19:57 UTC
(It was just a patch passing by but it won't fix anything here)
Comment 18 eisa01 2020-05-13 20:03:12 UTC
*** Bug 132998 has been marked as a duplicate of this bug. ***
Comment 19 eisa01 2020-05-13 20:06:18 UTC
Bumping severity as was done in duplicate bug 132998

Seems to have been introduced with 6.4 as per comment #2
Comment 20 Xisco Faulí 2020-05-14 17:18:27 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1a57e75bba8c10f0a3fcedace57b746e0fdf1967

author	Caolán McNamara <caolanm@redhat.com>	2019-10-17 14:16:21 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-10-19 17:31:57 +0200
commit	1a57e75bba8c10f0a3fcedace57b746e0fdf1967 (patch)
tree	8649e419c3fd93ce43f0a2c0a489774645699493
parent	6f7cd8f4238060249de11c4ec7d167c439f7a781 (diff)
weld ScDataProviderDlg

Bisected with: mac64-6.4

Adding Cc: to Caolán McNamara
Comment 21 Peter 2020-05-14 18:29:34 UTC
Bug still exists in 6.4.3.2 as distributed by Ubuntu.  I've had to revert to 6.3 to avoid this very annoying problem.
Comment 22 Caolán McNamara 2020-05-15 08:04:53 UTC
"Bug still exists in 6.4.3.2 as distributed by Ubuntu"

Looking into this, you are probably using the kde variant of LibreOffice, the issue only seems to arise on those versions which don't use gtk but do have "native" popup menus.
Comment 23 Caolán McNamara 2020-05-15 08:25:14 UTC
for gen MenuFloatingWindow::EndExecute will set the submenu selected id into the toplevel menus nSelectedId so the toplevel can be queryed after the fact to see what submenu entry was selected.

this isn't happening for the kde/macos native menus, its only available from the submenu. A submenu Menu::Select would set the toplevel id in the native case, but only if the aSelectHdl returned false.
Comment 24 Commit Notification 2020-05-15 09:34:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c9ba2d9373b40ae6262f4078bf5f5e64a5ba855b

tdf#131333 SalMenus propogate to parent their selected id conditionally

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2020-05-15 11:21:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/98d3ef152b7655e1aab2023304d4644380d5850c

tdf#131333 SalMenus propogate to parent their selected id conditionally

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Caolán McNamara 2020-05-16 19:38:08 UTC
that works now under kde and should also be working under macos