Download it now!
Bug 131629 - Requested feature: table header for multipage table with conditional text
Summary: Requested feature: table header for multipage table with conditional text
Status: RESOLVED DUPLICATE of bug 77336
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Tables Writer-Tables-Enhancements Writer-Table-Properties-Dialog
  Show dependency treegraph
 
Reported: 2020-03-27 16:33 UTC by sergio.callegari
Modified: 2020-04-14 10:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2020-03-27 16:33:35 UTC
Description:
When a long table is needed, spanning more than one page, it is good to be able to repeat the first row of the table (or the first rows of the table) for greater clarity and indeed LibO provides this behavior.

However, it would be particularly good to be able to slightly vary this text depending on the page.

For instance suppose that the first row contains the table title. It would be great to have it repeated on the second page with the word " (continued)" attached to it.

IMHO, this result could be obtained in various ways, I am proposing two:

1) Conditional text

LibO already has the idea of a conditional text. However, it is unclear what can be used as a boolean condition. If one could write something like "page eq page(reference(sym))" there would be the possibility of setting a reference in the first row and then add in the same row a piece of conditional text so that some text is shown when the row is printed on the same page where the reference is set and some other text is printed in other pages.

2) Rows that can be hidden

One could write all the rows that may be needed and then have an option to conditionally hide them (Only show row in first page, always show row). 

Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Dieter 2020-04-13 04:52:56 UTC
Sergio, thank you for your proposal. Just for clarification? Should this options be part of Text Flow Tab of Table Properties Dialog? If not, where should the user find the settings?

Personally I won't support the idea, because I'm afraid that this would bloat the dialog. But let's ask Design-Team.

cc: Design-Team
Comment 2 sergio.callegari 2020-04-13 16:33:39 UTC
After more thinking on this, what I think is that the best would be to have some properties that can be attached to the table on a row-by-row basis.  Something like that already exists for the "Allow row to break across pages and columns" in the "text flow" that can be activated for individual rows.

My view is that this could be extended to these properties:

1) Allow this row to break across pages and columns [on/off]
2) Allow table to split across multiple pages or columns after this row [on/off]
3) Repeat row [off / as table heading on every page / as table heading after first page
 / as table footer / as table footer except last page ]

Item 1 is already there. Item 2 would superseed the current "Allow table to split across multiple pages or columns" that is not activable on a row-by-row basis. Item 3 would superseed the current "repeat heading" entry.

The rationale for item 2 is to improve tables with multi row headings that look bad when the first row of headings is separated from the next ones.

The rationale for item 3 is to solve the issue of differentiating headings on subsequent pages.

IMHO this solution would contain the bloat because no new option is really added (current options are used differently). The mapping of past documents to the new options would be quite easy too.

I only see two potential issues:

1) row discoverability:

- Rows that are set to repeat as table heading after the first page or as table footer would actually remain visible and editable only when the table is actually made to span multiple pages. This does not seem a big issue to me.

2) compatibility with the ODF format. It is unclear to me if the ODF format supports selecting the possibility of splitting the table on multiple pages on a row by row basis.

These are my 2 cents, but I think the changes could really improve the appearance of long tables.
Comment 3 Heiko Tietze 2020-04-14 09:43:31 UTC
Don't think a per-row option makes sense since your content might change and it becomes the previous row which breaks now. The request was made before in bug 77336 for the caption. Meaning "Table 1" on p1 and "Table 1 (cont.)" on the following pages, which is common for this layout.

*** This bug has been marked as a duplicate of bug 77336 ***
Comment 4 sergio.callegari 2020-04-14 10:22:59 UTC
How about previous item 2: allow/prevent table from breaking after specific rows. Should I open another feature request for that?
Comment 5 Heiko Tietze 2020-04-14 10:45:18 UTC
(In reply to sergio.callegari from comment #4)
> How about previous item 2: allow/prevent table from breaking after specific
> rows. Should I open another feature request for that?

Maybe, but please check first if it hasn't done yet. Maybe bug 78756, bug 125972, bug 108233, or bug 116358. Searching for "table break row" returns many results.