Download it now!
Bug 131679 - Crash cutting a chart
Summary: Crash cutting a chart
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords: bibisected, bisected, regression
: 134955 (view as bug list)
Depends on:
Blocks: Chart Cut-Copy Crash
  Show dependency treegraph
 
Reported: 2020-03-29 16:51 UTC by Telesto
Modified: 2020-11-08 19:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["sw::DocumentContentOperationsManager::CopyImplImpl(SwPaM &,SwPosition &,SwCopyFlags,SwPaM * const)"]


Attachments
BT without symbols (60.89 KB, text/plain)
2020-03-30 18:50 UTC, Telesto
Details
Screencast (953.49 KB, video/mp4)
2020-04-01 17:14 UTC, Telesto
Details
Backtrace w symbols (6.75 KB, text/plain)
2020-10-19 01:05 UTC, Aron Budea
Details
backtrace of ClearMark (13.07 KB, text/plain)
2020-10-22 16:48 UTC, Michael Stahl (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-03-29 16:51:18 UTC
Description:
Crash cutting a chart

Steps to Reproduce:
1. Open attachment 157129 [details] (bug 1291010
2. Insert a chart
3. Click outside the chart
4. Right Click the chart -> Cut -> Crash 

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 7ae9c9572ccac55c0926b8a9779bb63c4236291c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-03-29 16:52:12 UTC
(bug 129101)
Comment 2 Dieter 2020-03-30 09:29:51 UTC
I can't confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 1c9ced04189c9d23ffea05d5570960b54b05ef28
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL
Comment 3 Xisco Faulí 2020-03-30 17:48:04 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: 11e6582b23b983fde4b04ece5b37c546bcd98a43
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Telesto, can you reproduce it with another document ? it would be helpful if it can be reproduced with a smaller document, the one mentioned is just too heavy to work with it and makes it very tedious to works with...
Comment 4 Telesto 2020-03-30 18:50:11 UTC
Created attachment 159173 [details]
BT without symbols
Comment 5 Telesto 2020-03-30 18:54:41 UTC
(In reply to Xisco Faulí from comment #3)
> @Telesto, can you reproduce it with another document ? it would be helpful
> if it can be reproduced with a smaller document, the one mentioned is just
> too heavy to work with it and makes it very tedious to works with...

Sorry, I don't have simply variant lying around.. Maybe the BT can help to find something similar?
Comment 6 QA Administrators 2020-03-31 03:30:57 UTC Comment hidden (obsolete)
Comment 7 Timur 2020-04-01 15:03:39 UTC
No repro. Needinfo to add minimal sample with exact steps where to insert, which data.
Comment 8 Telesto 2020-04-01 17:14:35 UTC
Created attachment 159241 [details]
Screencast
Comment 9 Sinem 2020-05-06 16:57:00 UTC
Sinem Isik 06.05.2020

I was able to reproduce the bug on Windows10 64-bit OS by using attached odt file (attachment 157129 [details]) as shown in the video (attachment 159241 [details]).

Tested in:
Version: 6.4.4.1 (x64)
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU threads: 12; OS: Windows 10.0 Build 17763; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

Steps to reproduce:
1. Open Writer
2. Open performance-bug.odt 
3. Add chart (from the shortcut or Insert->Chart) 
4. Click on the empty area below the chart (or the gray area) 
4. right click on the chart and cut

I've tried to replicate the problem with other documents. Started from scratch with empty document, added symbols and text box. Didn't lead to crash. 

Also tried to replicate on MacOS Version 10.14.6 with LibreOffice_6.4.4.1_MacOS_x86-64.dmg by using the attached file again. Could no reproduce.
Comment 10 Dieter 2020-05-06 18:44:30 UTC
(In reply to Sinem from comment #9)
> Sinem Isik 06.05.2020
> 
> I was able to reproduce the bug on Windows10 64-bit OS by using attached odt
> file (attachment 157129 [details]) as shown in the video (attachment 159241 [details]
> [details]).

Sinem, if you're able to reproduce it, you are allowed to change status to NEW (Idid it for you now)
Comment 12 Aron Budea 2020-10-18 01:07:59 UTC
I could reproduce and bibisect this to the 6.4 backport of the following commit using repo. Adding CC: to Michael Stahl.

It doesn't occur all the time. Either cutting will follow through, or it will crash. Before the patch instead of the crash, nothing happens (but in the other case it works fine).

I think if you don't see the selection handles around the chart after right-clicking, that's when it crashes on cut.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=81ec0039b2085faab49380c7a56af0c562d4c9e4
author		Michael Stahl <Michael.Stahl@cib.de>	2020-01-20 13:48:27 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2020-01-20 19:25:41 +0100

tdf#129582 sw: fix copying of flys in header/footer in DOCX/RTF import
Comment 13 Aron Budea 2020-10-18 01:08:44 UTC
(In reply to Aron Budea from comment #12)
> I could reproduce and bibisect this to the 6.4 backport of the following
> commit using repo. Adding CC: to Michael Stahl.
...using repo bibisect-linux-64-6.4.
Comment 14 Aron Budea 2020-10-18 01:31:02 UTC
(In reply to Aron Budea from comment #12)
> I think if you don't see the selection handles around the chart after
> right-clicking, that's when it crashes on cut.
Then again, that's not the case in the screencast.
Comment 15 Aron Budea 2020-10-19 01:05:32 UTC
Created attachment 166485 [details]
Backtrace w symbols
Comment 16 Michael Stahl (CIB) 2020-10-22 16:48:01 UTC
Created attachment 166640 [details]
backtrace of ClearMark

the problem: during layout, the SdrView's list of marked objects is cleared
Comment 17 Michael Stahl (CIB) 2020-10-23 14:54:04 UTC
fixed on master
Comment 18 Commit Notification 2020-10-23 14:54:22 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/40bff2567fa4a3fa8ec4445182cbbe3547c17410

tdf#131679 sw: fix crash when copying fly via context menu

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2020-10-26 17:50:40 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f63afb95b5c2d80d33a35820ef1d9abd9e70d3ca

tdf#131679 sw: follow-up: Unmark before SetSelection()

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-10-27 08:47:26 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/142dc93d9ad793e036baa5573aea31cb6f416f57

(related: tdf#131679) sw: only unmark if this SwFlyFrame is marked

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2020-10-27 10:16:54 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/8d51308a91206f6dc1bbd71bfe2a865cf5f3849e

tdf#131679 sw: fix crash when copying fly via context menu

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Attila Baraksó (NISZ) 2020-11-08 19:42:09 UTC
*** Bug 134955 has been marked as a duplicate of this bug. ***