Download it now!
Bug 131876 - split window in libre writer
Summary: split window in libre writer
Status: RESOLVED DUPLICATE of bug 31481
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0 all versions
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-04-04 14:24 UTC by Duns
Modified: 2020-04-05 12:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Duns 2020-04-04 14:24:49 UTC
I suggest as un very important enhancement that you let split the libre writer window of a document.
It would be absolutely useful for long documents. And it could give to librewriter a larghe appreciation in the academic world.
Comment 1 Jean-Francois Nifenecker 2020-04-05 07:47:43 UTC
(In reply to Duns from comment #0)
> I suggest as un very important enhancement that you let split the libre
> writer window of a document.
> It would be absolutely useful for long documents. And it could give to
> librewriter a larghe appreciation in the academic world.

This already exists under another form: try the Window > New Window menu entry :)

You then get the same document in two windows (or more if you repeat the operation). If you've got several screens, you may display your documents on more than one.

BTW, this works on the four main LibreOffice modules (Writer, Calc, Draw and Impress).
Comment 2 Duns 2020-04-05 08:27:37 UTC
I disagree: I knew already this possibility, but it is not at all the same what I am asking for.
I mean split the same window, not open another window.
Kate, in Linux, can do it, LibreCalc can do it: could you explain me why LibreWriter should not?
Comment 3 Jean-Francois Nifenecker 2020-04-05 09:03:22 UTC
(In reply to Duns from comment #2)
> I disagree: I knew already this possibility, but it is not at all the same
> what I am asking for.
> I mean split the same window, not open another window.

I did get it. But I'm failing to see why splitting windows is, in your point of view, better than a new window. Would you mind explaining a bit?
Comment 4 Duns 2020-04-05 09:56:24 UTC
I work with long files and therefore it would often be convenient for me to see two parts of the same document, distant from each other, at the same time.
Your way seems to me inadequate: a) first of all adjusting two windows, so that they exactly divide all the screen space, is not the simplest undertaking in the world, but above all b) the focus is only on one window at a time, and c) anyway one should always catapult from one window to another.
Since LibreOffice already has the technical ability to split a window (it does it with LibreCalc) and since for someone, who works with long documents, it would be useful to have it also in LibreWriter: I insist, why not? 
If you don't care, nobody will force you to use it. Does it take anything from you? No, it adds something that would be very, very useful to someone.
Comment 5 Jean-Francois Nifenecker 2020-04-05 11:04:16 UTC
(In reply to Duns from comment #4)
> I work with long files and therefore it would often be convenient for me to
> see two parts of the same document, distant from each other, at the same
> time.

Yes, I understand this need. Which is *exactly* what the New Window is meant for.

> Your way seems to me inadequate: a) first of all adjusting two windows, so
> that they exactly divide all the screen space, is not the simplest
> undertaking in the world, 

wouldn't adjusting two split parts lead to the same ?

> but above all b) the focus is only on one window
> at a time,

mmm... this is just like it works with the split window thing, isn't it? You've got only one split part active at a given time.

>  and c) anyway one should always catapult from one window to
> another.

just the New Window alike.

BTW Under Windows you may split the screen with one half for both (vertical or horizontal). Just right click the Task Bar and select the split you prefer.
Under Linux, it is easier: use the Ctrl+Super+Left Arrow / Ctrl+Super+Right Arrow
(on most PC keyboards, Super is the "Windows" key)

> Since LibreOffice already has the technical ability to split a window (it
> does it with LibreCalc) and since for someone, who works with long
> documents, it would be useful to have it also in LibreWriter: I insist, why
> not?

These are two ways of seeing the same functionality and I'm not here to dictate anyone's preference.

> If you don't care, nobody will force you to use it. Does it take anything
> from you? No, it adds something that would be very, very useful to someone.

No harsh words here from me to anyone. Just stating a possibly unknown/hidden functionality and my own opinion. YMMV.

BTW the "split window vs two windows" discussion is a very old one. I remember the Windows 3 times (yes! ;) where the very same discussions occurred for MSWord :)
Comment 6 Duns 2020-04-05 11:52:28 UTC
Thank you, but I disagree with many points

(In reply to Jean-Francois Nifenecker from comment #5)
> Yes, I understand this need. Which is *exactly* what the New Window is meant
> for.

I don't think so.

> Under Linux, it is easier: use the Ctrl+Super+Left Arrow / Ctrl+Super+Right
> Arrow
> (on most PC keyboards, Super is the "Windows" key)

This doesn't work in my Linux (KDE Neon 5.18.4)


> No harsh words here from me to anyone. Just stating a possibly
> unknown/hidden functionality and my own opinion. YMMV.

OK, thank you. But this possibility is not what I am looking for.

Can I ask you why, in your opinion, LibreCalc gives this option (split window) if it is something useless (perfectly replacable by two windows)?

> BTW the "split window vs two windows" discussion is a very old one. I
> remember the Windows 3 times (yes! ;) where the very same discussions
> occurred for MSWord :)

Uhm: can you please suggest a link?

A last question: are you a LibreOffice developer?
Comment 7 Regina Henschel 2020-04-05 12:23:26 UTC
Your request exists already as bug 31481.

Besides the request for split in same window, there exists requests for tabbed UI for different documents (bug 37134) and for sections inside a document (bug 33173).

I put this as duplicate to bug 31481.

A remark to the split window in Calc: Disadvantages compared to using two Windows is, that you can have only a single zoom setting and that it works only on a single sheet.

*** This bug has been marked as a duplicate of bug 31481 ***
Comment 8 Regina Henschel 2020-04-05 12:28:50 UTC
Bug 42428 is more similar to yours, but that is also included in bug 31481.
Comment 9 Jean-Francois Nifenecker 2020-04-05 12:31:48 UTC
(In reply to Duns from comment #6)
> 
> > Under Linux, it is easier: use the Ctrl+Super+Left Arrow / Ctrl+Super+Right
> > Arrow
> > (on most PC keyboards, Super is the "Windows" key)
> 
> This doesn't work in my Linux (KDE Neon 5.18.4)

I'm not a KDE user but I'd be surprised if KDE wouldn't support any "tiling" mode.

> > BTW the "split window vs two windows" discussion is a very old one. I
> > remember the Windows 3 times (yes! ;) where the very same discussions
> > occurred for MSWord :)
> 
> Uhm: can you please suggest a link?

Well, Windows 3 is faaar away. Just remembering my old times using MSWord :)

> 
> A last question: are you a LibreOffice developer?

Nope. Just a happy OOo then LibO user and trainer.