Bug 132373 - EDITING Remove Blinking character property from UI/Editor
Summary: EDITING Remove Blinking character property from UI/Editor
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on: 140395
Blocks: Character
  Show dependency treegraph
 
Reported: 2020-04-24 07:18 UTC by NISZ LibreOffice Team
Modified: 2021-12-13 12:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example doc file from Word 2003 (22.00 KB, application/msword)
2020-04-24 07:18 UTC, NISZ LibreOffice Team
Details
Example docx file from Word 2003 (10.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-04-24 07:19 UTC, NISZ LibreOffice Team
Details
The example file in Word 2010 (62.19 KB, image/png)
2020-04-24 07:19 UTC, NISZ LibreOffice Team
Details
The example file in Word 2013 and LO 6.5 master (112.08 KB, image/png)
2020-04-24 07:19 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-04-24 07:18:19 UTC
Created attachment 159886 [details]
Example doc file from Word 2003

We have the Character – Font Effects – Blinking property on the Writer UI, but it’s a dated feature, one that could be retired.

Word had in 2003 6 different types of character effects, while LO has a single one. 
2010 no longer offers them on the UI, but in existing documents they do work.
In 2013 and newer they are ignored in existing documents too.

To be more consistent with newer Word versions and online trends (such as HTML5 deprecating the blink tag: https://developer.mozilla.org/en-US/docs/Web/HTML/Element/blink )
I think we could do two things:
- Stop applying the blinking effect in the editor for existing files
- Remove the Character – Font Effects – Blinking checkbox

The export/import filter code and data model could be left alone, for interoperability with older software, such as Word < 2013 and LO < 7.

Steps to reproduce:
1.	Open attached documents

Actual results:
Text has character level effects in Word < 2013 and in LO.

Expected results:
We should not show these blinking effects, only the text.

LibreOffice details:
Version: 7.0.0.0.alpha0+ (x64)Build ID: bf536201ae83e7ca6a565eb8ff0dbc0e4e887d64CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; Locale: hu-HU (hu_HU); UI-Language: en-USCalc: CL
Comment 1 NISZ LibreOffice Team 2020-04-24 07:19:18 UTC
Created attachment 159887 [details]
Example docx file from Word 2003
Comment 2 NISZ LibreOffice Team 2020-04-24 07:19:42 UTC
Created attachment 159888 [details]
The example file in Word 2010
Comment 3 NISZ LibreOffice Team 2020-04-24 07:19:58 UTC
Created attachment 159889 [details]
The example file in Word 2013 and LO 6.5 master
Comment 4 V Stuart Foote 2020-04-24 13:45:46 UTC
+1
Comment 5 Gabor Kelemen (allotropia) 2020-04-24 17:20:52 UTC
Proposed patch: https://gerrit.libreoffice.org/c/core/+/92875
Comment 6 Regina Henschel 2020-04-24 22:22:43 UTC
Why do you want to hide the feature? It is not even deprecated in ODF and it belongs to our published API.
Comment 7 Gabor Kelemen (allotropia) 2020-04-26 17:26:13 UTC
(In reply to Regina Henschel from comment #6)
> Why do you want to hide the feature? It is not even deprecated in ODF and it
> belongs to our published API.

Some time ago we got a user ticket and they complained about a bit of highlighted text in a docx that also flashed in Writer, but not in Word. Turns out it was some old template, which indeed had flashing property set.

They were unaware of that, because Word already ignores this property - turns out since 2013.
This, and its fate in HTML shows how relevant is this property in these days from user perspective.

That's why I'd like to hide it.
Comment 8 Heiko Tietze 2020-04-30 14:26:41 UTC
Discussed this idea in the ESC and hiding the UI is a reasonable step. The feature was probably introduced back in the 1990th when Starwriter was used as HTML editor.
Comment 9 Commit Notification 2020-05-06 07:15:34 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1eb6210d678bbb0c875f0f72bd876a9e7795dfbe

tdf#132373 Remove blinking character property from the UI/editor

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Mike Kaganski 2020-05-06 07:28:02 UTC
Hiding the feature disallows users to turn it off in existing documents?
Comment 11 NISZ LibreOffice Team 2020-05-06 08:58:27 UTC
(In reply to Mike Kaganski from comment #10)
> Hiding the feature disallows users to turn it off in existing documents?

From the dialog yes, but the Remove Direct Formatting (Ctrl-M) button does the trick.
Comment 12 Mike Kaganski 2020-05-06 09:23:44 UTC
(In reply to NISZ LibreOffice Team from comment #11)
> (In reply to Mike Kaganski from comment #10)
> > Hiding the feature disallows users to turn it off in existing documents?
> 
> From the dialog yes, but the Remove Direct Formatting (Ctrl-M) button does
> the trick.

Even for glowing property defined at style level?

... and will that be documented then for users?
Comment 13 Mike Kaganski 2020-05-06 09:24:23 UTC
s/glowing/blinking/

(was a thinko, sorry)
Comment 14 Mike Kaganski 2020-05-06 09:25:56 UTC
Also doesn't "want to remove this blinking? Just drop every bit of formatting from here, and then try to figure how and what to restore" looks a bit ... strange?
Comment 15 Adolfo Jayme Barrientos 2020-05-11 13:05:47 UTC
Please document this change in the 7.0 release notes thoroughly.
Comment 16 NISZ LibreOffice Team 2021-02-08 11:35:29 UTC
Verified in
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 44b914b1e2616ca8f70e896e653a46ca93610234
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded