Download it now!
Bug 132420 - An image is gone after undo in 6.4 not in 7.0
Summary: An image is gone after undo in 6.4 not in 7.0
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2020-04-25 21:41 UTC by Telesto
Modified: 2020-06-03 15:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-04-25 21:41:51 UTC
Description:
An image is gone after undo

Steps to Reproduce:
1. Open attachment 127476 [details] (bug 91993)
2. CTRL+A CTRL+A
3. CTRL+X
4. CTRL+V
5. CTRL+Z -> Bottom right image gone

Actual Results:
Image missing

Expected Results:
Not missing


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Versie: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU-threads: 4; Besturingssysteem: Windows 6.3 Build 9600; UI-render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-taal: nl-NL
Calc: CL

but not in
4.4.7.2
Comment 1 Telesto 2020-04-25 21:45:25 UTC
Image shows up in
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 951b6a9570ae2665f7b6e7cdd6d24d1fc513ba90
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

However at the wrong position. Save & Reload -> everything at right place
Comment 2 Dieter 2020-05-01 10:32:11 UTC
I confirm result from comment 1 with

Version: 7.0.0.0.alpha0+ (x64)Build ID: 8c8b3a4f83f67882b284ddc3b3fe10d3fe6dedf4CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; Locale: de-DE (de_DE); UI-Language: en-GBCalc: CL

Additional info:
I think step 5 needs one CTRL+Z more
Comment 3 BogdanB 2020-05-15 22:11:24 UTC
Version 3.6.7.2 (Build ID: e183d5b) - everything ok

Version: 5.4.7.2 - everything ok
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk2; 
Locale: ro-RO (ro_RO.UTF-8); Calc: group

Version: 6.3.1.2 the image 6 is really missing, in 7.0 is just moving down. (after save and refresh is back)
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

With version 6.3.2.2 the image 6 is really missing, in 7.0 is just moving down. (after save and refresh is back)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.3.3.2 the image 6 is really missing, in 7.0 is just moving down. (after save and refresh is back)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.3.5.2 the image 6 is really missing, in 7.0 is just moving down. (after save and refresh is back)
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.0.3 the image 6 is really missing, in 7.0 is just moving down. (after save and refresh is back)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.2.2 the image 6 is really missing, in 7.0 is just moving down. (after save and refresh is back)
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.4.1 the image 6 is just moving down. 
(after save and refresh is back)
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2020-06-03 10:00:00 UTC
I can't reproduce it in

Version: 7.0.0.0.beta1+
Build ID: 2506d8221dd940dfd93d3d7c183430ba6ba3089d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Telesto, are you sure it dissapears ? for me it's shifted to the next available position
Comment 5 Dieter 2020-06-03 10:18:00 UTC
(In reply to Xisco Faulí from comment #4)
> @Telesto, are you sure it dissapears ? for me it's shifted to the next
> available position

That's what he says in comment 1 and what is confirmed by me and Bogdan in comment 2 and 3 => missing in 6.4 and shift of position in 7.0
Comment 6 Xisco Faulí 2020-06-03 10:32:00 UTC
(In reply to Dieter from comment #5)
> (In reply to Xisco Faulí from comment #4)
> > @Telesto, are you sure it dissapears ? for me it's shifted to the next
> > available position
> 
> That's what he says in comment 1 and what is confirmed by me and Bogdan in
> comment 2 and 3 => missing in 6.4 and shift of position in 7.0

that's not what the summary says. please update it
Comment 7 Xisco Faulí 2020-06-03 11:17:22 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=6c7245e789f973cf6dad03f7008ab3f9d12d350c which has been backported to libreoffice-6-4 branch and will be available in LibreOffice 6.4.5
Comment 8 Xisco Faulí 2020-06-03 11:20:13 UTC
BTW, the images are not gone, are just hidden.

Verified in

Version: 7.1.0.0.alpha0+
Build ID: 8d0b7e5b2f6773f4b3feb75f1ac73ea1a26609f7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 9 Xisco Faulí 2020-06-03 12:17:15 UTC
Actually the previous summary was accurate
Comment 10 Commit Notification 2020-06-03 15:15:38 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c9faea128e46a5284948343f4f2cfc6f9e9174b8

tdf#132420: sw: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.