Bug 131684 - Crash when doing undoing
Summary: Crash when doing undoing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.0.0 target:6.4.4 target:6.3....
Keywords: bibisected, bisected, regression
: 132156 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-29 20:51 UTC by Telesto
Modified: 2020-07-01 13:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["SwPageFrame::Cut()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-03-29 20:51:05 UTC
Description:
Crash when doing undoing

Steps to Reproduce:
1. Open attachment 155421 [details]
2. CTRL+A 3x (select everything)
3. CTRL+X
4. CTRL+Z
5. CTRL+V
6. CTRL+Z

Like a duplicate (rather common steps), but can't be sure without proper BT


Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 7ae9c9572ccac55c0926b8a9779bb63c4236291c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Xisco Faulí 2020-03-30 17:15:53 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=723728cd358693b8f4bc9d913541aa4479f2bd48

author	Michael Stahl <Michael.Stahl@cib.de>	2018-08-22 17:09:02 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-09-19 10:18:29 +0200
commit	723728cd358693b8f4bc9d913541aa4479f2bd48 (patch)
tree	1ac75a662a46987301ea85d32957eb08f435ffd6
parent	41d8ca9686c7c184f586e99674b443c34bfd4f33 (diff)
sw_redlinehide_2: SwUndoDelete

Bisected with: bibisect-linux64-6.2

Adding Cc: to Michael Stahl
Comment 2 Commit Notification 2020-04-08 08:58:29 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6c7245e789f973cf6dad03f7008ab3f9d12d350c

tdf#131684 sw_redlinehide: fix SwUndoDelete for entire doc in section

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Michael Stahl (CIB) 2020-04-08 09:02:42 UTC
fixed on master
Comment 4 Timur 2020-04-08 09:09:25 UTC
Thank you for doing undoing of undoing regression that caused crash when doing undoing :)
Comment 5 Commit Notification 2020-04-09 13:15:06 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5e2fc4864a5ed4c8361863ba7fa8e83d1c768638

tdf#131684 sw_redlinehide: fix SwUndoDelete for entire doc in section

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-04-14 18:23:31 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 35fc5ef0a759884b24ed8b83cd05702a0fab64cc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!
Comment 7 Commit Notification 2020-04-14 22:23:16 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3ee27693301b50cdebd6a47e35b6621f0ac50cfe

tdf#131684: Add unittest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-04-15 09:01:55 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/283f36ab037c78c81392153288a554d486d57c98

tdf#131684 sw_redlinehide: fix SwUndoDelete for entire doc in section

It will be available in 6.3.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-04-16 15:38:51 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-6":

https://git.libreoffice.org/core/commit/a56fe34196565e9c59799b11233dae70ce799895

tdf#131684 sw_redlinehide: fix SwUndoDelete for entire doc in section

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-05-27 17:18:19 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/55576842ec72a748d0bad123d41fa03c89fc136d

tdf#131684 tdf#132236 sw_redlinehide: fix upper of frame moved...

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Telesto 2020-05-28 08:56:02 UTC
No crash
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 41d8b41767032681a9897b7551f011d450e3725e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 12 Commit Notification 2020-05-28 10:45:29 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/bc6faecf24feca423b48ed1ea3d26fa6a64112db

tdf#131684 tdf#132236 sw_redlinehide: fix upper of frame moved...

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-05-29 08:30:15 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/03fe7a259e71d1c3f5190652649f9d4a6f75b4b7

tdf#131684: Add unittest

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-05-29 16:05:37 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/8871f81f218dd49de27d528e54a515d1648d3554

tdf#131684 tdf#132236 sw_redlinehide: fix upper of frame moved...

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2020-07-01 13:24:22 UTC
*** Bug 132156 has been marked as a duplicate of this bug. ***