Download it now!
Bug 132236 - Crash in: swlo.dll ( steps in comment 12)
Summary: Crash in: swlo.dll ( steps in comment 12)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.0.0 target:7.0.0.1 target:6.4.5
Keywords: bibisected, bisected, regression
: 126413 (view as bug list)
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-04-18 18:15 UTC by Jeff Wilburn
Modified: 2020-06-14 10:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["swlo.dll"]


Attachments
Example file (61.30 KB, application/vnd.oasis.opendocument.text)
2020-04-19 15:11 UTC, Telesto
Details
minimized document (10.12 KB, application/vnd.oasis.opendocument.text)
2020-05-07 10:40 UTC, Xisco Faulí
Details
Screencast of the crash with example file attached (260.06 KB, video/mp4)
2020-05-10 18:54 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Wilburn 2020-04-18 18:15:57 UTC
This bug was filed from the crash reporting server and is br-14ed6e9a-22c7-4e51-8b26-d66a970b134e.
=========================================
Libre Office Writer

After a paste from a webpage I was backspacing some extra lines out of the document. I went one line to far and ctrl-z twice. The first restore the previous change. The second crashed Writer and generated this bug report.

Jeff Wilburn 
4/18/2020
Comment 1 Telesto 2020-04-18 20:16:20 UTC
Thanks for the report.. is it possible to share the link to the site
Comment 2 Jeff Wilburn 2020-04-18 20:50:46 UTC
https://www.yahoo.com/news/best-drip-coffee-makers-consumer-100327813.html

My cut from the above webpage started at "Best ...: in the article title and ended at the end of the article at "but you can count on it to last."

There were several blank line as the top after the paste. Those deleted with no problem. Clicking on the line at the authors name, I backspaced to far into the title. The font for thet author's name changed to the title font. Here I hit the ctrl-Z. The first restored the line below but the font did not revert. The second ctrl-z caused the crash.
Comment 3 MM 2020-04-18 20:56:29 UTC
Maybe a dup from bug 132160 ?
Comment 4 Jeff Wilburn 2020-04-18 21:23:53 UTC
It sounds similar.

I was able to duplicate the problem with the same source page.

The issue appears to be that Ctrl+z is tripping over Undo text vs Undo Paragraph or the way the undo information is saved and some of the web formatting that was copied in is conflicting with the undo.

Libre Writer does recover to the last state effectively so nothing is lost. I'm not a coder so it's just another oddity. It won't keep from using Libre office either.
Comment 5 Telesto 2020-04-19 15:11:16 UTC
Created attachment 159718 [details]
Example file

Different crash.. swlo!SwTextFrame::HasFootnote+aa7
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4475bcd83aac7e033fc5250f268eb922bd471e7b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

1. Open the attached file
2. Enter bottom table cell on page 1
3. Hold Backspace for a while
4. CTRL+Z everything -> Crash
Comment 6 Telesto 2020-04-19 15:12:33 UTC
Not in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 7 Telesto 2020-04-22 19:28:23 UTC
crashreport.libreoffice.org/stats/crash_details/0e131deb-42d4-42be-87b2-10b9100cc734
Comment 8 Telesto 2020-04-22 19:30:35 UTC
No repro with
Versie: 6.1.6.3
Build ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: GL; 
Locale: nl-NL (nl_NL); Calc: CL

Repro with 
6.3
Comment 9 Telesto 2020-04-22 19:41:18 UTC
Bisected to:
author	Michael Stahl <Michael.Stahl@cib.de>	2018-08-22 17:09:02 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-09-19 10:18:29 +0200
commit	723728cd358693b8f4bc9d913541aa4479f2bd48 (patch)
tree	1ac75a662a46987301ea85d32957eb08f435ffd6
parent	41d8ca9686c7c184f586e99674b443c34bfd4f33 (diff)
sw_redlinehide_2: SwUndoDelete
This is problematic because of the calls to SplitNode.
Ideally we'd want the SplitNode to create merged frames already, but
that doesn't seem to be easy to achieve; several problems with this are:

1. the redlines are only restored at the end of UndoImpl
2. even if we store another set of SwRedlineSaveDatas right before the
   Join (while preventing the first SwRedlineSaveDatas from deleting
   them), and restore them by passing a closure to SplitNode, there
   are complaints about empty redlines, and also this case isn't
   handled properly:

     f<delete start>o<redline start>o
     b<redline end>a<redline start>r
     b<redline end>a<delete end>z

So instead, let SplitNode create whatever frames it does, and fix it up
at the end manually on the start node's frames.

This necessitates delaying the creation of the frames on the moved nodes
until the end too.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=723728cd358693b8f4bc9d913541aa4479f2bd48
Comment 10 Telesto 2020-04-22 19:42:31 UTC
Adding CC to Michael Stahl
Comment 11 Telesto 2020-04-22 19:50:06 UTC
*** Bug 126413 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2020-05-07 10:29:28 UTC
(In reply to Telesto from comment #5)
> Created attachment 159718 [details]
> Example file
> 
> Different crash.. swlo!SwTextFrame::HasFootnote+aa7
> Version: 7.0.0.0.alpha0+ (x64)
> Build ID: 4475bcd83aac7e033fc5250f268eb922bd471e7b
> CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
> Locale: nl-NL (nl_NL); UI-Language: en-US
> Calc: CL
> 
> 1. Open the attached file
> 2. Enter bottom table cell on page 1
> 3. Hold Backspace for a while
> 4. CTRL+Z everything -> Crash

Doesn't crash for me in

Versão: 6.4.3.2 (x64)
ID da versão: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
Processos do CPU: 1; SO: Windows 6.1 Service Pack 1 Build 7601; Gestão da interface: padrão; VCL: win; 
Configuração regional: es-ES (es_ES); Idioma da interface: pt-PT
Calc: threaded

however the steps from bug 126413 crash systematically:
1. Open attachment 152299 [details] (bug 126017)
2. Set the cursor at the beginning of the title of the table of content (so before: aasasascvcvcv
3. Press SHIFT Arrow down (select the full TOC)
4. CTRL+X
5. CTRL+Z -> Crash
Comment 13 Xisco Faulí 2020-05-07 10:40:24 UTC
Created attachment 160488 [details]
minimized document
Comment 14 Telesto 2020-05-10 18:54:19 UTC
Created attachment 160622 [details]
Screencast of the crash with example file attached
Comment 15 Commit Notification 2020-05-27 17:18:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/55576842ec72a748d0bad123d41fa03c89fc136d

tdf#131684 tdf#132236 sw_redlinehide: fix upper of frame moved...

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-05-27 17:19:57 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ca8e04f1ab739e14288ab5e0be44723536b9ca4e

tdf#132236 sw_redlinehide: fix SwUndoDelete with sections even more

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Michael Stahl (CIB) 2020-05-27 17:21:01 UTC
should be fixed on master
Comment 18 Telesto 2020-05-28 08:53:49 UTC
I'm happy!
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 41d8b41767032681a9897b7551f011d450e3725e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

Thanks for fixing!
Comment 19 Commit Notification 2020-05-28 10:45:44 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/bc6faecf24feca423b48ed1ea3d26fa6a64112db

tdf#131684 tdf#132236 sw_redlinehide: fix upper of frame moved...

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-05-28 10:45:51 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/beec1b1f594aa345ea4ee5a64bd70f8dccda64c3

tdf#132236 sw_redlinehide: fix SwUndoDelete with sections even more

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2020-05-29 16:05:30 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/9c84242dcee576147e520624641b208e874e908c

tdf#132236 sw_redlinehide: fix SwUndoDelete with sections even more

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2020-05-29 16:05:42 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/8871f81f218dd49de27d528e54a515d1648d3554

tdf#131684 tdf#132236 sw_redlinehide: fix upper of frame moved...

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.