Bug 136452 - Crash swlo!SwTextFrame::HasFootnote+0xc0d: at undo
Summary: Crash swlo!SwTextFrame::HasFootnote+0xc0d: at undo
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: target:7.4.0 target:7.3.0.0.beta2 tar...
Keywords: bibisected, bisected, regression
: 133655 138618 138635 139635 (view as bug list)
Depends on:
Blocks: Undo-Redo redlinehide-regressions
  Show dependency treegraph
 
Reported: 2020-09-03 20:45 UTC by Telesto
Modified: 2021-12-20 14:15 UTC (History)
6 users (show)

See Also:
Crash report or crash signature: ["InsertCnt_(SwLayoutFrame *,SwDoc *,unsigned __int64,bool,unsigned __int64,SwFrame *,sw::FrameMode)"]


Attachments
Example file (19.56 KB, application/vnd.oasis.opendocument.text)
2020-09-03 20:45 UTC, Telesto
Details
Screencast (870.98 KB, video/mp4)
2020-09-03 20:45 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-03 20:45:07 UTC
Description:
Crash swlo!SwTextFrame::HasFootnote+0xc0d: at undo

Steps to Reproduce:
1. Open the attached file
2. Scroll to bottom
3. CTRL arrow up to select a part of text
4. Backspace
5. Last selection should end section contain A5
7. CTRL+Z couple of times -> Crash

See screencast

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: e8b8e7be0b2ad693224cd94062a55610eb69df7e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-09-03 20:45:19 UTC
Created attachment 165122 [details]
Example file
Comment 2 Telesto 2020-09-03 20:45:58 UTC
Created attachment 165123 [details]
Screencast
Comment 3 Telesto 2020-09-03 20:50:03 UTC
No crash with
Version: 6.2.0.0.alpha0+
Build ID: 9d754a59154c40235c240bb0e7f47a2006fa85bd
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 Xisco Faulí 2020-09-07 08:54:04 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 6b2eff7d69c6e14d89dd33eaa58c01d82c541266
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 raal 2020-09-08 18:40:03 UTC
This seems to have begun at the below commit.
Adding Cc: to Michael Stahl; Could you possibly take a look at this one?
Thanks

e10b27a4bccbf917348bd88fa19fe0352d4cc1b3 is the first bad commit
commit e10b27a4bccbf917348bd88fa19fe0352d4cc1b3
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Apr 8 13:26:54 2020 +0200

    source sha:6c7245e789f973cf6dad03f7008ab3f9d12d350c

author	Michael Stahl <Michael.Stahl@cib.de>	2020-04-07 18:33:34 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-04-08 10:57:52 +0200
commit	6c7245e789f973cf6dad03f7008ab3f9d12d350c (patch)
tree	dabb268bf9cd66124698965ba4a1224d2bae9994
parent	969ebe1c5801fa194ee29ffc7abfad7363ebd08f (diff)
tdf#131684 sw_redlinehide: fix SwUndoDelete for entire doc in section
Comment 6 Xisco Faulí 2020-11-04 14:42:15 UTC
Still reproducible in

Version: 7.1.0.0.alpha1+
Build ID: a373a7c1705b9abc5551388998131dacc4698642
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 7 Telesto 2020-12-03 10:15:21 UTC
*** Bug 138635 has been marked as a duplicate of this bug. ***
Comment 8 Telesto 2020-12-03 10:16:25 UTC
Bug 138635 same file... didn't pay attention.. slightly different steps..
Comment 9 Telesto 2021-01-15 11:04:12 UTC
*** Bug 139635 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2021-12-03 09:23:27 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2b256c84aa4c063c8161b32a7b424daa28b5741b

tdf#136452 sw_redlinehide: fix crash in undo of delete across sections

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Michael Stahl (allotropia) 2021-12-03 09:26:05 UTC
fixed on master
Comment 13 Commit Notification 2021-12-03 19:08:18 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/24d2a5198efd994a7e53d1cd0d9740dab0ea5fb0

tdf#136452 sw_redlinehide: fix crash in undo of delete across sections

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-12-04 15:01:24 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/4990df35e5036d78599c54884810b062c834def7

tdf#136452 sw_redlinehide: fix crash in undo of delete across sections

It will be available in 7.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Christian Lohmaier 2021-12-06 13:30:12 UTC
7.2.4 was a hotfix release, updating target in status-whiteboard
Comment 16 Michael Stahl (allotropia) 2021-12-20 12:24:23 UTC
*** Bug 138618 has been marked as a duplicate of this bug. ***
Comment 17 Michael Stahl (allotropia) 2021-12-20 14:15:27 UTC
*** Bug 133655 has been marked as a duplicate of this bug. ***