Bug 132472 - FILEOPEN PPTX Table text imported with white color
Summary: FILEOPEN PPTX Table text imported with white color
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All All
: high normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:7.2.0 target:7.1.3 target:7.0.6
Keywords: bibisected, bisected, filter:pptx, regression
: 139043 (view as bug list)
Depends on:
Blocks: PPTX-Tables
  Show dependency treegraph
 
Reported: 2020-04-27 18:17 UTC by Johnny_M
Modified: 2021-05-05 21:52 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
PPTX file for import (56.97 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-04-27 18:17 UTC, Johnny_M
Details
Correct example in PowerPoint (42.00 KB, image/png)
2020-04-27 18:19 UTC, Johnny_M
Details
Wrong example in LO (86.92 KB, image/png)
2020-04-27 18:20 UTC, Johnny_M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny_M 2020-04-27 18:17:44 UTC
Created attachment 160005 [details]
PPTX file for import

Black color text in a table gets imported in white color, making it not visible against white background.

The attached example file "Example.pptx" was created with MSO 365 (16.0.12730.20144) 32-bit.

Test procedure:
1. Open "Example.pptx"

Expected results:
1. Text is shown as in "Correct_example_in_PowerPoint.png"

Actual results:
1. Black text is invisible, because imported with white color - see "Wrong_example_in_LO.png".


Reproducible in:
LO portable on Win10:
Version: 6.4.3.2 (x86)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

LO on Ubuntu:
Version: 6.3.5.2
Build ID: 1:6.3.5-0ubuntu0.19.10.1
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Johnny_M 2020-04-27 18:19:48 UTC
Created attachment 160006 [details]
Correct example in PowerPoint
Comment 2 Johnny_M 2020-04-27 18:20:11 UTC
Created attachment 160007 [details]
Wrong example in LO
Comment 3 Durgapriyanka 2020-04-28 01:00:25 UTC
Thank you for reporting the bug. I can reproduce this bug in another way. Whereas I can see that instead of the text, the table lines are imported in white color making it invisible.

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
	

and in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Johnny_M 2020-05-10 12:03:42 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2020-05-11 08:33:52 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2020-05-11 08:49:01 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2c3f7d4ee0a0b2bf6efc41670645bd361f1b76ef

author	Gülşah Köse <gulsah.kose@collabora.com>	2019-12-27 21:06:08 +0300
committer	Andras Timar <andras.timar@collabora.com>	2020-01-07 14:49:50 +0100
commit	2c3f7d4ee0a0b2bf6efc41670645bd361f1b76ef (patch)
tree	50f782069c5b3c30d28cf2b189074e614f3f2a6f
parent	363b7ab405f70fe0f61d57103d5ae28a0b24e0c5 (diff)
tdf#107604 Handle predefined table styles.

Bisected with: bibisect-linux64-6.4

Adding Cc: to Gülşah Köse
Comment 7 Xisco Faulí 2020-09-15 16:34:07 UTC
Still reproducible in

Version: 7.1.0.0.alpha0+
Build ID: 6f1e02c96b887750f974c187a82ecd6236e6a435
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 8 Pablo 2021-02-02 17:12:07 UTC
Projects usually give regressions higher priority then new bugs. Is there a chance to do the same in LibreOffice?
Regressions can cause more frustration and fixing them early by the same author can be much faster.
Comment 9 Timur 2021-04-19 11:19:30 UTC
*** Bug 139043 has been marked as a duplicate of this bug. ***
Comment 10 Xisco Faulí 2021-04-22 11:13:40 UTC
I have a fix for it
Comment 11 Commit Notification 2021-04-22 14:28:57 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/54f7c32beca5a9c99d7316dc38818edad55f7415

tdf#132472: do not set text color when table style is 'Themed-Style-2'

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-04-26 10:08:12 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/62cbb4b7694893a39de41cebd5f785122b154961

tdf#132472: do not set text color when table style is 'Themed-Style-2'

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Timur 2021-04-26 10:55:04 UTC
Good, looking even better than before, colors are ok and borders are seen now (except a single one in the right upper table, I will not report). 
Duplicate is also good now.
Comment 14 Commit Notification 2021-04-26 14:38:29 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/b20c3473a9ba9ca0f96e9d004989233a32d3853c

tdf#132472: do not set text color when table style is 'Themed-Style-2'

It will be available in 7.0.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2021-04-28 11:49:45 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-3":

https://git.libreoffice.org/core/commit/caf67b938e60768eb9b93cccd49dbeac5ac43afb

tdf#132472: do not set text color when table style is 'Themed-Style-2'

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-05-05 21:48:46 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-6":

https://git.libreoffice.org/core/commit/c38003805d345da611ef6416fc8a95d0a134f40e

tdf#132472: do not set text color when table style is 'Themed-Style-2'

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.