Download it now!
Bug 107604 - Fileopen PPTX: no table style applied so B&W instead of colors for header row and banded rows
Summary: Fileopen PPTX: no table style applied so B&W instead of colors for header row...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.4.0.2 target:6.3.5
Keywords: filter:pptx
Depends on:
Blocks: ImpressDraw-Tables PPTX
  Show dependency treegraph
 
Reported: 2017-05-03 16:39 UTC by Timur
Modified: 2020-09-12 00:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test PPTX with 3-color table (145.86 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-05-03 16:39 UTC, Timur
Details
comparison MSO 2010 and LibreOffice 5.4 (146.35 KB, image/png)
2017-05-04 07:56 UTC, Xisco Faulí
Details
Test PPTX compared MSO2013 LO6.4.0.1 LO70+ (93.98 KB, image/png)
2020-02-08 15:14 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2017-05-03 16:39:41 UTC
Created attachment 133046 [details]
Test PPTX with 3-color table

In attached PPTX (slide 49 in attachment 53342 [details] from Bug 42753), LO doesn't import table style so table is black&white instead of colored for header row and banded rows. 
LO supports all this but it doesn't work here.
Comment 1 Xisco Faulí 2017-05-04 07:55:48 UTC
Confirmed in

Version: 5.4.0.0.alpha1+
Build ID: f12096272e684ddcd8ffa4e34dcb0a680cc594c2
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Xisco Faulí 2017-05-04 07:56:08 UTC
Created attachment 133059 [details]
comparison MSO 2010 and LibreOffice 5.4
Comment 3 Timur 2017-05-04 13:23:13 UTC Comment hidden (obsolete)
Comment 4 Yousuf Philips (jay) (retired) 2017-05-04 14:04:55 UTC
(In reply to Timur from comment #3)
> Yousuf, is this a duplicate of Bug 101757 or I misunderstood it?

No that is different. LO should be able to import styled tables fine if its applied to the table as direct formatting, which MS does. But to make sure, someone would have to look into the xml to be certain.

LO 3.3 to 5.1, the background of the table used to be blue.
Comment 5 QA Administrators 2018-10-22 02:50:51 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2018-10-22 07:09:34 UTC
still repro in

Version: 6.2.0.0.alpha0+
Build ID: cec31fdedd7c94f4ebf903a66456a75867db22b0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-21_22:54:44
Locale: ru-RU (ru_RU); Calc: threaded
Comment 7 Buovjaga 2019-09-29 16:06:13 UTC
Still confirmed

Version: 6.4.0.0.alpha0+ (x64)
Build ID: d744838991594eebe27acc4c7d9fb4579d654853
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-29_05:12:00
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 8 Commit Notification 2020-01-07 09:20:33 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7f82e6dae98bc5e75ec03885eb955a7a72047bb4

tdf#107604 Handle predefined table styles.

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-01-07 13:50:46 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/2c3f7d4ee0a0b2bf6efc41670645bd361f1b76ef

tdf#107604 Handle predefined table styles.

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-01-07 13:51:02 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/1bc8726a3ae59c10c87abc993aa053da621c4436

tdf#107604 Handle predefined table styles.

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Timur 2020-02-08 15:14:53 UTC
Created attachment 157748 [details]
Test PPTX compared MSO2013 LO6.4.0.1 LO70+

Looks fine. I don't know why Gülşah didn't close, so I'll do it.