Bug 129961 - FILEOPEN PPTX: shadow effect for table completely missing
Summary: FILEOPEN PPTX: shadow effect for table completely missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2
Keywords: filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2020-01-12 22:36 UTC by Gerald Pfeifer
Modified: 2021-01-11 08:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample PPTX document (1.31 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-01-12 22:36 UTC, Gerald Pfeifer
Details
How it should look like (Office 365) (18.83 KB, image/png)
2020-01-12 22:38 UTC, Gerald Pfeifer
Details
How it looks like (LibreOffice) (15.84 KB, image/png)
2020-01-12 22:38 UTC, Gerald Pfeifer
Details
Sample PPTX compared MSO LO (83.60 KB, image/png)
2020-02-08 15:40 UTC, Timur
Details
Alternate test document showing outer shadows (1.22 MB, application/vnd.ms-powerpoint)
2020-11-16 23:37 UTC, Gerald Pfeifer
Details
Alternate test document - Office 365 vs LibreOffice (205.83 KB, image/png)
2020-11-16 23:51 UTC, Gerald Pfeifer
Details
Comparison of Office 365 vs LibreOffice w/o and with the shadow patches (409.23 KB, image/png)
2021-01-09 19:54 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-01-12 22:36:37 UTC
Created attachment 157094 [details]
Sample PPTX document

The attached PowerPoint presentation contains a table with a shadow
effect.

In Office 365 that effect is clearly visible; in LibreOffice 6.5 (and
earlier 6.x versions I could test) there is no trace of a shadow effect.
Comment 1 Gerald Pfeifer 2020-01-12 22:38:00 UTC
Created attachment 157095 [details]
How it should look like (Office 365)
Comment 2 Gerald Pfeifer 2020-01-12 22:38:37 UTC Comment hidden (obsolete)
Comment 3 ian 2020-01-13 01:47:21 UTC
Thank you for reporting the bug. I can confirm that the bug is present in  recent master builds in Windows and in Linux. I have also changed the importance to "minor," given that this bug is only a visual imperfection. 

Windows:

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 209fc9fd7fa433947af0bf86e210d73fa7f5a045
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

Linux:

Version: 6.5.0.0.alpha0+
Build ID: 8930a7d8b8e649336300d98f0a1f27114ad392ea
CPU threads: 1; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master,
Locale: es-ES (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Buovjaga 2020-01-25 20:18:01 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2020-02-05 14:55:42 UTC
(In reply to Buovjaga from comment #4)
> Looks like the table borders and cell colours were not rendered at all in
> versions earlier than 6.5, so at least this is progress.

Implemented in https://cgit.freedesktop.org/libreoffice/core/commit/?id=7f82e6dae98bc5e75ec03885eb955a7a72047bb4
Gülşah Köse, I thought you might be interested in this issue
Comment 6 Timur 2020-02-08 15:40:43 UTC
Created attachment 157749 [details]
Sample PPTX compared MSO LO

Seems like Impress only has a simple Format-Shadow, just on/off. 
And that's different from MSO settings.
Comment 7 Gerald Pfeifer 2020-11-16 23:37:04 UTC
Created attachment 167346 [details]
Alternate test document showing outer shadows

Here is another document that also misses shadows for a table, specifically
"outer shadows".
Comment 8 Gerald Pfeifer 2020-11-16 23:51:55 UTC
Created attachment 167349 [details]
Alternate test document - Office 365 vs LibreOffice
Comment 9 Commit Notification 2020-11-30 18:55:37 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a7505356872f981c951b2ec64383a95538890876

tdf#129961 svx: add doc model xml dump for shadow-related pool items

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Miklos Vajna 2020-12-01 08:33:49 UTC
This is just one patch, I'll update this bug explicitly when I believe this is working on master.
Comment 11 Commit Notification 2020-12-01 19:25:57 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/55d4c6cfe5bd9b737698c6cd1f28ee8234abb5d0

tdf#129961 svx: add UNO API for table shadow as direct format

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-12-02 16:20:20 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a75bf43a8d6c5dec6dcc86908c142ceec541aa8c

tdf#129961 svx: add rendering for table shadow as direct format

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-12-10 14:27:58 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b273e82aaa916b0f6198097dc32740faced73741

tdf#129961 oox: add PPTX import for table shadow as direct format

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-12-11 07:06:15 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/3728f19f1abc949dc0ff6cc627c6dbff9c667cfa

tdf#129961 svx: add doc model xml dump for shadow-related pool items

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-12-11 07:07:26 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/5d375815df5c0a509d99292616112052f199a053

tdf#129961 svx: add UNO API for table shadow as direct format

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-12-11 07:07:37 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/3fa5fa234b1862a7455a68c7620765dab7a25bc0

tdf#129961 svx: add rendering for table shadow as direct format

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-12-11 07:08:47 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/d0ed3efca42ffa859cc86343ef61a9968d05ceef

tdf#129961 oox: add PPTX import for table shadow as direct format

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Miklos Vajna 2020-12-11 08:39:00 UTC
I think this is now fixed on master and 7.1.
Comment 19 Timur 2020-12-11 16:15:24 UTC
I cannot test but it would be useful to write how MSO-saved PPT opens.
Comment 20 Commit Notification 2020-12-14 12:02:45 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/74ba28fe238b7f15d1fb7d119e4cef3a7b544e0b

tdf#129961 cui: start UI for table shadow as direct format

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2020-12-15 21:41:55 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fdeb04f7c59cf8032fe17072ed779e70505cc6ab

tdf#129961 svx: finish UI for table shadow as direct format

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2020-12-17 08:08:37 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/252cdd5f43d65095543e317d37e1a0ea4fd839e0

tdf#129961 oox: add PPTX export for table shadow as direct format

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2020-12-17 09:22:19 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/16d05d51444dff723fe0efc57d68750845ed3e34

tdf#129961 cui: start UI for table shadow as direct format

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2020-12-17 12:57:47 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/12be9c3205b1dc7901ce015ed1eefdc232ed9099

tdf#129961 svx: finish UI for table shadow as direct format

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2020-12-17 12:58:59 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/dbd0fd75c86983d88f4f62c680deeaa845358c8a

tdf#129961 oox: add PPTX export for table shadow as direct format

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Timur 2020-12-23 07:24:34 UTC
Original PPTX used to open in LO without shading, while fill color was correct (transparency 80% in MSO). 
Now, there's shading but color is darker. I don't know how that transparency from MSO is read in LO. I couldn't find a bug for transparency in shape fill, only bug 111725.

 
I tested MSO saved PPT, shading seems to be there.
Comment 27 Gerald Pfeifer 2020-12-27 00:02:52 UTC
(In reply to Timur from comment #26)
> Original PPTX used to open in LO without shading, while fill color was
> correct (transparency 80% in MSO). 
> Now, there's shading but color is darker. I don't know how that transparency
> from MSO is read in LO. I couldn't find a bug for transparency in shape
> fill, only bug 111725.

I just reconfirmed bug 111725.

Are you going to file a separate issue for this (regression), Timur,
or how do you suggest to best handle this?
Comment 28 Buovjaga 2021-01-07 13:51:08 UTC
(In reply to Gerald Pfeifer from comment #27)
> (In reply to Timur from comment #26)
> > Original PPTX used to open in LO without shading, while fill color was
> > correct (transparency 80% in MSO). 
> > Now, there's shading but color is darker. I don't know how that transparency
> > from MSO is read in LO. I couldn't find a bug for transparency in shape
> > fill, only bug 111725.
> 
> I just reconfirmed bug 111725.
> 
> Are you going to file a separate issue for this (regression), Timur,
> or how do you suggest to best handle this?

Timur was not in Cc.
Comment 29 Timur 2021-01-08 08:06:44 UTC
I hope Miklos will make a comment on color. I will not filw a bug until then.
Comment 30 Miklos Vajna 2021-01-08 08:18:46 UTC
> Now, there's shading but color is darker.

This is intentional I think: the background is semi-transparent, so the original cell background and the shadow background adds up. As far as I see, PowerPoint does the same.
Comment 31 Gerald Pfeifer 2021-01-09 19:54:39 UTC
Created attachment 168801 [details]
Comparison of Office 365 vs LibreOffice w/o and with the shadow patches

(In reply to Miklos Vajna from comment #30)
>> Now, there's shading but color is darker. 
> This is intentional I think: the background is semi-transparent, so the
> original cell background and the shadow background adds up. As far as I see,
> PowerPoint does the same.

Miklos (and Timur), let me add a comparison between

 - Office 365
 - LibreOffice before the shadow patches
 - LibreOffice after the shadow patches
 
Office 365 and LibreOffice from before your patches match (modulo the
missing shadows), LibreOffice now appears quite different.


(Disclaimer: I cannot exclude there's been another change that caused
this in the same time frame.)
Comment 32 Miklos Vajna 2021-01-11 08:37:23 UTC
Thanks. It seems that when the shadow is semi-transparent, then the already semi-transparent cell background should be more light than what we currently paint. 

Timur: could you please file a follow-up bug for this?

> This is intentional I think: the background is semi-transparent, so the original cell background and the shadow background adds up.

So this is not correct, sorry. I didn't realize that we have 3 different grays in this case (original cell background, shadow, overlap), not just 2.