Bug 132596 - Crash in: SwPosition::SwPosition(SwPosition const &)
Summary: Crash in: SwPosition::SwPosition(SwPosition const &)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:6.4.5 target:7.0.0.1
Keywords: bibisected, bisected, regression
: 133169 (view as bug list)
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-05-01 18:54 UTC by Telesto
Modified: 2020-06-09 16:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["SwPosition::SwPosition(SwPosition const &)"]


Attachments
minimized document (10.80 KB, application/vnd.oasis.opendocument.text)
2020-05-07 09:50 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-01 18:54:39 UTC
This bug was filed from the crash reporting server and is br-f013e7fc-080d-41b7-8620-3bcf9dda7503.
=========================================

1. Open attachment 147292 [details]
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+SHIFT+V
6. CTRL+Z -> Crash
Comment 1 Telesto 2020-05-01 19:11:51 UTC Comment hidden (obsolete)
Comment 2 Telesto 2020-05-01 19:12:05 UTC
File from bug 92372
Comment 3 MM 2020-05-02 09:24:19 UTC
Confirmed on windows 10 x64 with Version: 6.4.4.1 (x64)
Build ID: b50bc319eca5cd5b66fbfe2ebd0d3bd1eed099b5
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: default; VCL: win

With step 5 you need to select rtf, because it hangs when pasting with lo format / html.
Comment 4 Xisco Faulí 2020-05-07 09:50:16 UTC
Created attachment 160482 [details]
minimized document
Comment 6 Xisco Faulí 2020-05-07 10:16:23 UTC
No need to create a new document:
1. Open minimized document
2. Select all
3. Copy
4. Paste as RTF
5. Undo
Comment 7 Xisco Faulí 2020-05-29 09:28:46 UTC
File sw/qa/extras/uiwriter/data3/tdf129805.docx is also affected by this issue
Comment 8 Michael Stahl (CIB) 2020-06-08 12:28:35 UTC
*** Bug 133169 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2020-06-08 15:51:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/27151ccf2305eac4192f8c4ceeee267170096a19

tdf#132596 writerfilter: fix paste of RTF with header/footer

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Michael Stahl (CIB) 2020-06-08 15:55:07 UTC
there is a (header/footer) substream containing a fieldmark.

the substream is erroneously imported into the body text.

RemoveLastParagraph() removes the text node 23 containing the fieldmark.
Comment 11 Xisco Faulí 2020-06-09 08:06:58 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: e0f058bcd5e185b89e4b7c680a7901bc7eb2a790
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Michael, thanks for fixing this issue!!
Comment 12 Commit Notification 2020-06-09 08:40:47 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c9d842ddc54b701eb57cc79032fabcf14391a3a1

tdf#132596 writerfilter: fix paste of RTF with header/footer

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-06-09 12:44:30 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/e0e1c3bcc9445c177a4d97ba11639ae4f2f83163

tdf#132596 writerfilter: fix paste of RTF with header/footer

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-06-09 16:31:18 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2ea830c2877f30cf3ac6f261a399c414dd9968c8

tdf#132596: sw: Add UItest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.