Bug 132660 - Crash in: BigPtrArray::Index2Block(unsigned __int64)
Summary: Crash in: BigPtrArray::Index2Block(unsigned __int64)
Status: RESOLVED DUPLICATE of bug 135167
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Crash-BigPtrArray Crash
  Show dependency treegraph
 
Reported: 2020-05-03 21:35 UTC by Telesto
Modified: 2020-07-27 11:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["BigPtrArray::Index2Block(unsigned __int64)"]


Attachments
Example file (359.80 KB, application/vnd.oasis.opendocument.text)
2020-05-03 21:35 UTC, Telesto
Details
bt Windows (windbg) (254.38 KB, text/plain)
2020-05-04 12:03 UTC, Julien Nabet
Details
Example file (71.28 KB, application/vnd.oasis.opendocument.text)
2020-05-04 22:15 UTC, Telesto
Details
bt with debug symbols (8.11 KB, text/plain)
2020-07-27 11:03 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-03 21:35:03 UTC
Created attachment 160302 [details]
Example file

This bug was filed from the crash reporting server and is br-ef271c12-af62-43c3-a79e-29ee43adc1b4.
=========================================

1. Open the attached file
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+V
6. CTRL+Z -> Crash or hang


Source file: attachment 137750 [details] bug 113721 but re-saved
Comment 1 Julien Nabet 2020-05-04 12:03:34 UTC
Created attachment 160318 [details]
bt Windows (windbg)

On Win10 with master sources updated today, I got an assert at the first Ctr-Z
Comment 2 Telesto 2020-05-04 22:15:44 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2020-05-06 18:17:56 UTC
Also reproducible in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Xisco Faulí 2020-06-11 09:08:12 UTC
Still reproducible in

Version: 7.1.0.0.alpha0+
Build ID: 03b77f972f6be23f75dfe3773266a660e61e5607
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Julien Nabet 2020-07-27 11:03:33 UTC
Created attachment 163610 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got an assertion.
Comment 6 Telesto 2020-07-27 11:16:56 UTC

*** This bug has been marked as a duplicate of bug 135167 ***