Bug 132782 - FILEOPEN PPTX Custom Y Error Bar values not imported
Summary: FILEOPEN PPTX Custom Y Error Bar values not imported
Status: RESOLVED DUPLICATE of bug 127720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-05-06 15:43 UTC by NISZ LibreOffice Team
Modified: 2022-02-23 12:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from PowerPoint with 4 chart types and Y error bars with Custom values (93.07 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-05-06 15:43 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in PowerPoint and Impress with editing the custom amounts in PP (115.71 KB, image/png)
2020-05-06 15:43 UTC, NISZ LibreOffice Team
Details
Data table of the chart in PP and Impress (97.55 KB, image/png)
2020-05-06 15:44 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-06 15:43:29 UTC
Created attachment 160460 [details]
Example file from PowerPoint with 4 chart types and Y error bars with Custom values

Attached document contains some basic chart types in PPTX with custom Y Error Bar values set in PP.
These are not imported in LO at all, also the custom amounts set in PP are lost.
Also the bugs in See Also are using the same Custom type for Error Bars, only those are sourced from an external file.

Steps to reproduce:
    1. Create a simple chart in PP, set it to use Error Bars
    2. Format the Error bars, set the Error Amount to Custom and press the Specify Amount button
    3. In the dialog that opens select a range from the data table of the chart – I added the Custom Error Min and Custom Error Max columns for this and some random values, then selected the values for the Positive error amount and Negative error amount
    4. In the Select Data dialog of PP unselect the manually added data table columns so that they do not appear on the chart
    5. Save the file and open it in LO

Actual results:
The error bars do not appear for any of the charts (line, bar, column, area). The data table of the chart does not contain the manually added columns.

Expected results:
Error bars appear and the custom error values are imported.

LibreOffice details:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: d8a52f21ce23a37f7d1137501...
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-05-06 15:43:49 UTC
Created attachment 160461 [details]
Screenshot of the original document side by side in PowerPoint and Impress with editing the custom amounts in PP
Comment 2 NISZ LibreOffice Team 2020-05-06 15:44:03 UTC
Created attachment 160462 [details]
Data table of the chart in PP and Impress
Comment 3 Xisco Faulí 2020-05-06 16:38:59 UTC
reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 1eb6210d678bbb0c875f0f72b...
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Justin L 2022-02-23 12:38:20 UTC

*** This bug has been marked as a duplicate of bug 127720 ***