Bug 133029 - Copy/Paste
Summary: Copy/Paste
Status: RESOLVED DUPLICATE of bug 128714
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-14 09:09 UTC by dcutto
Modified: 2020-05-19 06:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
video of the bug (6.14 MB, video/mp4)
2020-05-15 16:57 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dcutto 2020-05-14 09:09:08 UTC
Description:
Hi, I use LibreOffice 6.4.0 on Ubuntu 20.04 and on Windows 10. When I open Writer and I use Copy Paste on a select lines of text it almost always doesn't work. Or it works badly.

Actual Results:
I select lines, then I use botton Copy. I move the cursor where I want to do Paste. I push the botton Paste and it doesn't work. The same if I use shortcut keyboard

Expected Results:
It doens't work or it paste old selceted lines text 


Reproducible: Always


User Profile Reset: Yes



Additional Info:
It shoud copy and paste what I selected
Comment 1 Xisco Faulí 2020-05-14 09:54:49 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 BogdanB 2020-05-14 18:56:51 UTC
Hi, Xisco, why this is not a bug? In the last days I was replacing some characters with some other characters in a text with a new version of LO and when I was copying the text when I paste it it was pasting the previous text, or if I had nothing before, no paste was inserted.

It is quite annoying.

To use LO on my Ubuntu 20.04 I needed to use GEN/X11 in order to use it. But for some users would be hard to change something like this in order to make LO usable. 

The only option that I had was to copy 2 times and paste once.

If you need a video I can create one.
Comment 3 Xisco Faulí 2020-05-14 19:30:29 UTC
Hello Bogdan,
Maybe you are talking about another issue.
I asked the reported to provide a sample file and he/she closed it as RESOLVED FIXED without giving any other info so I just closed it as RESOLVED NOTABUG.
Comment 4 dcutto 2020-05-15 08:34:09 UTC
yesterday I did a mistake. The bug exist, I just tried again and it doesn't correctly work. I confirm I get the same behavior who Bogdan Described.
Then if you ask me to attach any prove do what you want.
Comment 5 Xisco Faulí 2020-05-15 08:40:29 UTC
(In reply to BogdanB from comment #2)
> Hi, Xisco, why this is not a bug? In the last days I was replacing some
> characters with some other characters in a text with a new version of LO and
> when I was copying the text when I paste it it was pasting the previous
> text, or if I had nothing before, no paste was inserted.
> 
> It is quite annoying.
> 
> To use LO on my Ubuntu 20.04 I needed to use GEN/X11 in order to use it. But
> for some users would be hard to change something like this in order to make
> LO usable. 
> 
> The only option that I had was to copy 2 times and paste once.
> 
> If you need a video I can create one.

Hello,
Sure, please create a video reproducing it.
Comment 6 BogdanB 2020-05-15 09:41:54 UTC
Dcutto, could you create a video using Simple Screen Recorder? Just video, without sound.

I get the bug with a .deb install, but I unintalled and now I have a snap version, in which I can not reproduce.
Comment 7 tim 2020-05-15 09:51:13 UTC
I have a very similar problem.

I copy and paste, and get the previous copy, not the latest one.  Sometimes the last line gets duplicated in a very peculiar way, such that if I edit it the duplicate gets edited as well. It is very strange.


I'm using Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

And have also tried the pre-release of 6.4.4.

This is using the ubuntu ppa vcersions.
Comment 8 tim 2020-05-15 10:19:54 UTC
I might add that on my system it seems to be infuriatingly inconsistent, which makes reporting it and providing an example almost impossible.

I'm sure there's some pattern, but until I find it I can't provide an example.
Comment 9 BogdanB 2020-05-15 16:57:36 UTC
Created attachment 160871 [details]
video of the bug

I could reproduce. See the video.

Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

I can reproduce this with above version installed from terminal on Ubuntu 20.04
sudo apt install libreoffice

Maybe it's a problem with Ubuntu repository...
Comment 10 BogdanB 2020-05-15 16:59:31 UTC
It happens sometimes. Not everytime you paste the text.
Comment 11 Italo Vignoli 2020-05-16 14:10:48 UTC
Works with Linux Mint and LibreOffice Vanilla (downloaded from LibreOffice website). The issue might be related to Ubuntu 20.04 or to the LibreOffice version recompiled by Canonical.
Comment 12 BogdanB 2020-05-16 16:55:47 UTC
Exactly Italo, can you report this to Ubuntu?... To check that?...
It's a very annoying bug, I lost hours of work replacing wrong elements because I was't attentive at what I replaces. I was sure that copy was working ok, so every copy was wrong and many hours of correction after that...
Comment 13 tim 2020-05-16 17:07:18 UTC
I have raised  #1879078 in launchpad/ubuntu.

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1879078
Comment 14 dcutto 2020-05-18 08:01:18 UTC
I got the same BUG in Calc.
Comment 15 tim 2020-05-18 09:42:54 UTC
See also https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1852183?comments=all

It seems there is a long-standing bug in ubuntu, which may be the same one.  Please feel free to comment on launchpad as well, to try to get this resolved soon.
Comment 16 Timur 2020-05-18 11:46:46 UTC
This bug has no steps. 
But key issue is: did you search before reporting and discussing? 
There are many paste bugs like bug 57147, bug 90120, bug 128714 etc.
I set to Needinfo.
Comment 17 Timur 2020-05-18 11:51:43 UTC
I guess we can mark duplicate.

*** This bug has been marked as a duplicate of bug 128714 ***
Comment 18 tim 2020-05-18 12:22:59 UTC
(In reply to Timur from comment #16)
> This bug has no steps. 
> But key issue is: did you search before reporting and discussing? 
> There are many paste bugs like bug 57147, bug 90120, bug 128714 etc.
> I set to Needinfo.

This was the fiurst report I found that stated the problem I have.

It has a video - isn't that 'info'?  

There seem to be a variety of bugs with somewhat similar problems. Some ubuntu-only, others not.  It is very unclear whether they are the same or not.

All I can say is that before ubuntu 20.04 I had zero similar problems, so none of the the other reports seemed relevant.

One of the reports has been closed as an ubuntu 19.10 bug.  I did not have this problem on ubuntu 19.10 (or earlier), only 20.04.

Given that some reports are extremely old, and still open, I'm a little worried that all similar issues might get kicked into the long grass.  I hope not.

It is, to be honest, very puzzling, and worrying.  I am, as yet, unconvinced that it is resolved and proven to be not an issue in libreoffice, especially since the very first report mentions Windows 10.
Comment 19 tim 2020-05-18 15:16:58 UTC
I have tried to run more tests.  This is tricky with a problem that seems to come and go.

So far I cannot reproduce it on Windows 10.

I reproduced the problem with both the ubuntu build version I reported previously, and also with 

Version: 6.4.3.2
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

So in my case it is not just the ubuntu build.

I have tried to replicate it with other editors on plain text (on ubuntu), but have no far failed to do so.

It would currently appear to be an ubuntu 20.04 problem, but not the same as the ubuntu 19.10 one as suggested in #128714 (since I've never had the problem before and was on 19.10 until a week or 2 ago).
Comment 20 tim 2020-05-19 06:24:38 UTC
There is a possible fix for ubuntu 20.04.  See https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1852183 regarding 'mutter'.
Comment 21 tim 2020-05-19 06:25:45 UTC Comment hidden (obsolete)