Bug 133175 - Draw Functions line thickness always increasing while trying to change it
Summary: Draw Functions line thickness always increasing while trying to change it
Status: RESOLVED DUPLICATE of bug 132169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-05-19 16:03 UTC by Victor Preatoni
Modified: 2020-06-03 11:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Preatoni 2020-05-19 16:03:56 UTC
Description:
Seems to be a strange behavior when changing line thickness using Draw Functions.

YouTube link: https://youtu.be/TaCEdr7bE5Q


Steps to Reproduce:
1.Draw a Line
2.Use +/- buttons to change thickness



Actual Results:
Line thickness increase no matter what button I click on.

Expected Results:
Line thickness should increase or decrease properly.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: es-AR (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2020-05-20 06:46:42 UTC
*** Bug 133128 has been marked as a duplicate of this bug. ***
Comment 2 Telesto 2020-05-20 18:36:12 UTC
Bisected to:
author	Szymon Kłos <szymon.klos@collabora.com>	2019-11-07 15:53:49 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2019-11-08 10:04:57 +0100
commit	f7c751439d4616f43509301d71af92b13b576a84 (patch)
tree	3db40e6d9a27b44d5b4e771658fd7ad101125c05
parent	b94dd252730512f14d6939a250152b3e4c9e7583 (diff)
jsdialog: consume .uno:LineWidth double value

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f7c751439d4616f43509301d71af92b13b576a84


~/win64-6.4
4e582258051b40db0c6b7795280740e1a7ac7007 is the first bad commit
commit 4e582258051b40db0c6b7795280740e1a7ac7007
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Nov 8 01:33:25 2019 -0800

    source sha:f7c751439d4616f43509301d71af92b13b576a84

    source sha:f7c751439d4616f43509301d71af92b13b576a84

:040000 040000 47e6d51778a2d0e5953028641725b863cd3535d1 f235bed8a6a90a1faa373931272550998ba5a51d M      instdir
Comment 3 Telesto 2020-05-20 18:37:40 UTC
Adding CC to Szymon Kłos
Comment 4 Xisco Faulí 2020-05-25 10:41:15 UTC
@Telesto, do you reproduce this on master? I think this is a duplicate of bug 132169 which is already fixed
Comment 5 Telesto 2020-05-25 11:27:12 UTC
Working as expected:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: b587de60d4e6aa96238766272d94f1499b22f696
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

*** This bug has been marked as a duplicate of bug 132169 ***
Comment 6 Telesto 2020-05-25 12:21:18 UTC
(In reply to Xisco Faulí from comment #4)
> @Telesto, do you reproduce this on master? I think this is a duplicate of
> bug 132169 which is already fixed

@Xisco / Szymon
There is still a revert in gerrit
https://gerrit.libreoffice.org/c/core/+/94673
Comment 7 Szymon Kłos 2020-05-25 13:11:56 UTC
(In reply to Telesto from comment #6)
> (In reply to Xisco Faulí from comment #4)
> > @Telesto, do you reproduce this on master? I think this is a duplicate of
> > bug 132169 which is already fixed
> 
> @Xisco / Szymon
> There is still a revert in gerrit
> https://gerrit.libreoffice.org/c/core/+/94673

I'm going to revert my original patch as I changed the online and it is no longer needed