Download it now!
Bug 132169 - Drawing line width changes randomly while changing
Summary: Drawing line width changes randomly while changing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords: bibisected, bisected, regression
: 131645 132974 133128 133175 133374 (view as bug list)
Depends on:
Blocks: Writer-Toolbars Shapes-Line
  Show dependency treegraph
 
Reported: 2020-04-17 02:17 UTC by Anatoliy Rodnikov
Modified: 2020-08-02 20:57 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
line width changing (18.26 KB, image/png)
2020-04-17 02:31 UTC, Anatoliy Rodnikov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anatoliy Rodnikov 2020-04-17 02:17:19 UTC
Description:
When you change the line thickness of Drawing using the keyboard or mouse wheel, it changes unpredictably.

Steps to Reproduce:
1. Create new Writer document
2. Enable Drawing Panel
3. Draw any Primitive (Rectangle for example)
4. Try to change line width in box by keyboard or mouse wheel( set it 0.1cm for example)

Actual Results:
Line width automaticaly set to 0.18
Turning wheel of mouse in any side increases line width till 5cm

Expected Results:
The change in line thickness must be precise and predictable.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Версия: 6.4.3.2 (x64)
ID сборки: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
Потоков ЦП: 2; ОС: Windows 10.0 Build 18363; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 1 Anatoliy Rodnikov 2020-04-17 02:31:26 UTC
Created attachment 159646 [details]
line width changing
Comment 2 Christian 2020-04-17 11:00:10 UTC
I have an analogous problem while changing the line width of an arrow using the „drawing object properties“ toolbar.

Description:
When I increase the line width of an arrow from 0,00 cm to 0,1 cm using the number field of the „drawing object properties“ toolbar, the value jumps to 0,18 cm, in the next step from 0,2 cm, which is showed for a short time while using the mouse pointer, to 0,35 cm, from 0,3 cm to 0,71 cm and so on and it is not possible to decrease the line width, the value is still increasing. Also the ratio of the arrow head and the line is broken.

Steps to Reproduce:
1. Create new Writer document
2. Enable Drawing Panel
3. Draw an arrow
4. Try to increase the line width of the arrow from 0,00 cm to 0,1 cm using the number field of the „drawing object properties“ toolbar

Actual Results:
Line width automatically is set to 0.18 cm and so on and then randomly changed the line width on further changing the line width 


Expected Results:
Changing the line width in 0,1 cm steps with conserving the ratio of line and arrow head width. In Libreoffice Writer 6.3.5 this function works correct.


Reproducible: Always




Additional Info:
Version: Version: 6.4.3.2
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded
OS: Linux OpenSuse 15
Comment 3 Dieter 2020-04-22 06:30:27 UTC
(In reply to Anatoliy Rodnikov from comment #0)
> Description:
> When you change the line thickness of Drawing using the keyboard or mouse
> wheel, it changes unpredictably.

I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 1c9ced04189c9d23ffea05d5570960b54b05ef28
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL

But not with

Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

It affects line width changing in Drawing Object Properties Toolbar (changing line width in sidebar seems to work correctly)
Comment 4 Attila Baraksó (NISZ) 2020-04-29 07:42:04 UTC
Bibisected using bibisect-win64-6.4 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=f7c751439d4616f43509301d71af92b13b576a84
author: Szymon Kłos <szymon.klos@collabora.com>
committer: Szymon Kłos <szymon.klos@collabora.com>
summary: jsdialog: consume .uno:LineWidth double value

Adding Cc: Szymon Kłos
Comment 5 Buovjaga 2020-05-13 19:42:54 UTC
*** Bug 132974 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2020-05-13 21:16:40 UTC
@Caolán, I thought you might be interested in this issue
Comment 7 Xisco Faulí 2020-05-14 08:13:43 UTC
*** Bug 131645 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2020-05-14 08:15:16 UTC
Increasing importance based on duplicates
Comment 9 Caolán McNamara 2020-05-14 10:01:47 UTC
I can see in sfx2/source/appl/appuno.cxx TransformParameters that in 6.3 we use PutValue with CONVERT_TWIPS, but with the addition or parameters in 6.4 we end up with PutValue with 0 on using the different branch
Comment 10 Commit Notification 2020-05-14 15:28:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dadc965b6ff5b86526420c5f1812fe4baca52b3d

tdf#132169 we always get the value in MapUnit::Map100thMM

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2020-05-14 16:13:11 UTC
works in master, backport to 6-4 in gerrit
Comment 12 Xisco Faulí 2020-05-19 18:32:23 UTC
Verified in

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 13 Commit Notification 2020-05-19 18:35:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f53a6e025e58f723d15ac601b3759b5929c83627

tdf#132169 we always get the value in MapUnit::Map100thMM

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-05-20 08:20:16 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/05d7dbb911349c0b529c3f3a64223e447958d435

tdf#132169: sw: Add UItest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Telesto 2020-05-25 11:27:12 UTC
*** Bug 133175 has been marked as a duplicate of this bug. ***
Comment 16 Telesto 2020-05-26 06:26:04 UTC
*** Bug 133374 has been marked as a duplicate of this bug. ***
Comment 17 Aron Budea 2020-08-02 20:57:58 UTC
*** Bug 133128 has been marked as a duplicate of this bug. ***