Download it now!
Bug 133358 - Crash in: sw::GetParaPropsNode
Summary: Crash in: sw::GetParaPropsNode
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: high normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.3 target:6.4....
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-05-25 05:50 UTC by Luke Kendall
Modified: 2020-09-30 12:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["sw::GetParaPropsNode"]


Attachments
Example file (3.72 MB, application/vnd.oasis.opendocument.text)
2020-05-25 18:12 UTC, Telesto
Details
bt with debug symbols (gen) (11.66 KB, text/plain)
2020-05-26 06:29 UTC, Julien Nabet
Details
minimal document (17.21 KB, application/vnd.oasis.opendocument.text)
2020-05-28 14:49 UTC, Xisco Faulí
Details
bt with debug symbols (7.70 KB, text/plain)
2020-07-30 13:35 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2020-05-25 05:50:20 UTC
This bug was filed from the crash reporting server and is br-34613b7f-8e76-476a-adc9-0a50c8d599dd.
=========================================

I had a file opened and unsaved from the day before, with about 10 changes made.

I undid each change to see what it was; then applied Redo to each change.
I think it was when I reapplied the last change (Increasing the indent of a paragraph in the TOC I think?), Writer crashed.

From memory, the changes were (from oldest to newest):

Insert Page break (manual)
Insert Page break (manual)
Change paragraph style
Insert "  "
Insert "     "
Delete "     "
Indent paragraph
Indent paragraph
Outdent paragraph

Something like that.

I often find that a sequence of Undo and Redo crashes Writer.
Comment 1 Telesto 2020-05-25 06:48:08 UTC
I often find that a sequence of Undo and Redo crashes Writer.

-> True, there multiple of those, sadly. Tables an image anchor undo/redo crashes are quite well documented, IMHO. Those are actually hard to track down.

This one surely not.. the crash is related to SwDoc::MoveLeftMargin

If you have some time..  figure out sequence.. so make change abc.. undo/ redo. It's probably indent outdent something

And add the example file :-). Often can be reduced to one page following certain pattern..

Getting those steps quite hard. Again optional.. and no hurry..

This is not highly common crash.. but of course really annoying if it happens
Comment 2 Telesto 2020-05-25 18:12:32 UTC
Created attachment 161273 [details]
Example file
Comment 3 Telesto 2020-05-25 18:15:40 UTC
1. Open the attached file
2. Select the text under Acknowledgments
3. Indent few times
4. Undo everything
5. Redo -> Crash

No repro with
Version: 6.0.6.0.0+
Build ID: c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 Julien Nabet 2020-05-26 06:29:09 UTC
Created attachment 161289 [details]
bt with debug symbols (gen)

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 5 Telesto 2020-05-26 15:03:35 UTC
Increasing priority, rather easy to reproduce.. OTOH not a major crasher.

Adding Michael Stahl, in advance (no bibisect yet).. BT looks like red lining.
Comment 6 Xisco Faulí 2020-05-28 13:55:50 UTC Comment hidden (obsolete)
Comment 7 Telesto 2020-05-28 14:13:49 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2020-05-28 14:25:18 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b070202b420129b5edd368420e0e50ec45261d01

author	Michael Stahl <Michael.Stahl@cib.de>	2018-11-20 18:26:18 +0100
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-12-01 08:44:44 +0100
commit	b070202b420129b5edd368420e0e50ec45261d01 (patch)
tree	64967f05ceaf342270658a440346a2e9a9649b05
parent	a382ecb5689ee425e77f830fd81b8696dc90a68b (diff)
sw_redlinehide_4a: SwEditShell::IsMoveLeftMargin(), MoveLeftMargin()

Bisected with: bibisect-linux64-6.3

Adding Cc: to Michael Stahl
Comment 9 Xisco Faulí 2020-05-28 14:49:58 UTC
Created attachment 161375 [details]
minimal document

1. Open minimal document
2. Indent 6 times
3. Undo 6 times
4. Redo
Comment 10 Telesto 2020-07-29 21:03:29 UTC
(In reply to Xisco Faulí from comment #9)
You don't need a sample file 

1. Indent
2. Undo
3. Redo
Comment 11 Julien Nabet 2020-07-30 13:35:02 UTC
Created attachment 163775 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got a crash just by following Telesto's last comment.
Comment 12 Commit Notification 2020-09-29 10:06:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dc6e005c79b6c23b805dea44cd89fa83ea945f03

tdf#133358 fix crash in redoing indent

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Heiko Tietze 2020-09-29 11:42:33 UTC
Issue in bug 137038 is solved with the patch.
Comment 14 Commit Notification 2020-09-29 13:29:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/fdc92d35d95f5b89a333cc48fdc36108e1094973

tdf#133358 fix crash in redoing indent

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-09-29 15:28:42 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/416cb76758719b88a4cdefe8c9d16131c35cfdf5

tdf#133358: sw_uiwriter: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-09-29 17:03:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c1955f26cb772fc90ca81affcb524ebf1f12f3a3

tdf#133358 fix crash in redoing indent

It will be available in 6.4.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-09-30 11:16:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-2":

https://git.libreoffice.org/core/commit/0218f75a6f2a4504993aacf1c9dfccd462cdf603

tdf#133358 fix crash in redoing indent

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2020-09-30 11:16:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-7":

https://git.libreoffice.org/core/commit/1162b94cfe81303012a04e45d6cf9d254cd2ed4c

tdf#133358 fix crash in redoing indent

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2020-09-30 12:40:01 UTC
I guess we can close this one now.