Download it now!
Bug 133365 - Master: Crash when pasting from external program
Summary: Master: Crash when pasting from external program
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: bibisected, bisected, regression
: 133592 133624 133642 133825 133947 133948 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-25 10:22 UTC by Jean-Baptiste Faure
Modified: 2020-06-19 18:36 UTC (History)
8 users (show)

See Also:
Crash report or crash signature: crashreport.libreoffice.org/stats/crash_details/dfd5e544-9cf1-481b-bc42-15c93bf0659b


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2020-05-25 10:22:41 UTC
Description:
Writer crashes when pasting some text copied from another program.

Steps to Reproduce:
Step to reproduce:
1/ open a new empty text document in Writer
2/ open gedit (or your preferred text editor) and type some word
3/ select and copy (Ctrl+C) the word typed in gedit
4/ go back to Writer and paste (ctrl+V)

Actual Results:
Crash

Expected Results:
No crash and text pasted


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.0.0.alpha1+
Build ID: 7b47a96b20122863e77aa1918e878372b3485c9f
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Ubuntu_18.04_x86-64
Calc: threaded
Comment 1 steve -_- 2020-05-25 10:40:46 UTC
Cannot reproduce here. Linux only?

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 8; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 2 MM 2020-05-25 10:43:42 UTC
Confirmed on mint 19.3 x64 with Version: 7.0.0.0.alpha1+
Build ID: f2561331534459f8aebc57e8615fa5f626521bcb
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-24_14:20:49
Calc: threaded


Unconfirmed with Version: 7.0.0.0.alpha1+
Build ID: 0677d46bcc56c1f6c27b9331662990b38fd452d6
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-21_12:54:11
Calc: threaded


crashreport.libreoffice.org/stats/crash_details/dfd5e544-9cf1-481b-bc42-15c93bf0659b
Comment 3 Xisco Faulí 2020-05-29 08:43:49 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f2561331534459f8aebc57e8615fa5f626521bcb

author	Mike Kaganski <mike.kaganski@collabora.com>	2020-05-24 12:21:13 +0200
committer	Mike Kaganski <mike.kaganski@collabora.com>	2020-05-24 14:15:34 +0200
commit	f2561331534459f8aebc57e8615fa5f626521bcb (patch)
tree	11b9d83ec043bcdc6dc214843c33106a098f9fec
parent	a64ad061282f8fb0591bb697f1d7e81367964210 (diff)
Prevent deadlock accessing clipboard

Bisected with: bibisect-linux64-6.5

Adding Cc: to Mike Kaganski
Comment 4 Mike Kaganski 2020-05-29 08:58:08 UTC
Actually I was expecting something like this. I only wasn't sure if we ever call the code without solar mutex guard, so thought that I won't introduce possibly unnecessary guards there as a defensive measure. But now it's clear - thanks!

Please test if https://gerrit.libreoffice.org/c/core/+/95088 fixes that (I can't repro using Windows).
Comment 5 Commit Notification 2020-05-30 18:50:08 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/80c9fae6aa8638e192e5b622d12305b304890b43

tdf#133365: only release solar mutex on Windows

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-05-30 19:54:34 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/06ba0ab749930cf404f0e4a5a1b8abe9be87bce5

tdf#133365: only release solar mutex on Windows

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Jean-Baptiste Faure 2020-05-30 20:10:57 UTC
Verified fixed in Version: 7.1.0.0.alpha0+
Build ID: 80c9fae6aa8638e192e5b622d12305b304890b43
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Ubuntu_18.04_x86-64
Calc: threaded

Thank you very much Mike !

Best regards. JBF
Comment 8 Dieter 2020-06-07 06:37:19 UTC
*** Bug 133624 has been marked as a duplicate of this bug. ***
Comment 9 Timur 2020-06-09 11:55:35 UTC
*** Bug 133592 has been marked as a duplicate of this bug. ***
Comment 10 Timur 2020-06-11 09:21:24 UTC
*** Bug 133825 has been marked as a duplicate of this bug. ***
Comment 11 Julien Nabet 2020-06-13 10:37:36 UTC
*** Bug 133948 has been marked as a duplicate of this bug. ***
Comment 12 Julien Nabet 2020-06-13 10:38:15 UTC
*** Bug 133947 has been marked as a duplicate of this bug. ***
Comment 13 Michael Zylla 2020-06-16 17:20:17 UTC
This bug was filed from the crash reporting server and is br-c36c99c0-f26f-4068-b109-51a79d698e7b.
=========================================

Description:
Calc also crashes when pasting text (in this case tab separated digits) copied from another program.

Step to reproduce:
1/ open a new empty spreadsheet document in Calc
2/ open gedit (or your preferred text editor) and type some digits with tabs as separators and <Enter> for new line i.e.

1	2
3	4
5	6

3/ select and copy (Ctrl+C) the text above typed in gedit
4/ go back to Calc and paste (ctrl+V)

Actual Results:
Crash

Expected Results:
No crash and text import dialog with options for encoding, separator, etc.


Reproducible: Always

*** Fixed in 7.1.0.0.alpha0+ (just checked it after discovering this very bug report)! ***



Version: 7.0.0.0.beta1
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 14 Xisco Faulí 2020-06-18 10:39:24 UTC
*** Bug 133642 has been marked as a duplicate of this bug. ***
Comment 15 Michael Zylla 2020-06-19 18:36:44 UTC
(In reply to Michael Zylla from comment #13)

> 
> *** Fixed in 7.1.0.0.alpha0+ (just checked it after discovering this very
> bug report)! ***

Also verified fixed in 
Version: 7.0.0.0.beta2+
Build ID: 08b86198bd03af1655877f525e55bc6190635f4e
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-06-19_01:53:06
Calc: threaded

Thanks fot fixing this!

Regards