Bug 133378 - Crash if Print Preview is closed with User Interface “Groupedbar Compact”
Summary: Crash if Print Preview is closed with User Interface “Groupedbar Compact”
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: QA:needsComment
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-25 15:58 UTC by Harald Koester
Modified: 2020-06-09 03:43 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2020-05-25 15:58:04 UTC
It is not sure that the following procedure always leads to the crash. On my system it does in most cases. If you don't get a crash on your system you should try to play a bit with the View options (Options > LibreOffice > View).

In order to reproduce the bug:
[1] In order to start with a new user profile: Rename or delete user profile.
[2] Start LibreOffice.
[3] If not selected change to the English user interface and restart LibreOffice.
[4] Create new spreadsheet. Close Tip of the Day. Close blue Release Notes bar.
[5] Select user interface Groupedbar Compact with menu: View > User Interface >  Groupedbar Compact.
[6] Select icon style Karasa Jaga: Menu > Options… > View > Icon Style > Karasa Jaga. Then OK.
[7] In group View click icon Toggle Print Preview. “No Data” is displayed.
[8] In group Print click icon Close Preview. LibreOffice crashes.

Crash Report: 
crashreport.libreoffice.org/stats/crash_details/1bc5c4b3-b2d9-40f2-96e3-19b7a1a9d5b7

Bug 130187 describes a similar (or equal?) bug. The status of that bug is Resolved Fixed (fixed in versions 6.4.1 and 6.4.2). I have the suspect that 130187 or one of the dupes of 130187 has not been solved in versions 6.4.1 and 6.4.2.

Bug also exists with version 6.4.4.2. According a report on the German mailing list the bug also exists on Linux systems.