Download it now!
Bug 133498 - kf5: Spinboxes to set mail merge server port are broken (and probably others, too)
Summary: kf5: Spinboxes to set mail merge server port are broken (and probably others,...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: bibisected, bisected, regression
: 133543 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-29 14:45 UTC by Michael Weghorn
Modified: 2020-06-02 12:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast demonstrating the issue (3.10 MB, video/webm)
2020-05-29 14:45 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2020-05-29 14:45:26 UTC
Created attachment 161394 [details]
Screencast demonstrating the issue

Steps to reproduce (s.a. attached screencast):

0) Use kf5 VCL plugin on Linux, e.g. by setting "SAL_USE_VCLPLUGIN=kf5" env variable
1) open Writer
2) go to "Tools" -> "Options" -> "LibreOffice Dev Writer" -> "Mail Merge Email"
3) look closely at the spinbox for the SMTP port in the "Outgoing Server (SMTP) Settings)"
4) Select the currently entered port/text in that spinbox
5) Manually enter a different port number, like "44"

Results:

* at step 3: The spinbox does not fit the style of the other controls in the dialog, it looks "non-native" for the kf5 VCL plugin
* after step 5: rendering is broken, the old value is still somewhat visible in addition to the newly entered one

Expected results:

* The spinbox should look "native", like the other controls in the dialog.
* Only the newly entered value should be visible.

Further information:

This looks OK when using e.g. the "gen" VCL plugin instead.

Version: 7.1.0.0.alpha0+
Build ID: 8c84448febf817875ad0d377de0f0b34987992cb
CPU threads: 4; OS: Linux 5.6; UI render: default; VCL: kf5
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 1 Michael Weghorn 2020-05-29 14:46:34 UTC
This is a regression from

commit 2a694f9e0e7789b4b3b792a9eedd29366fa10c1c
Author: Henry Castro <hcastro@collabora.com>
Date:   Wed May 6 14:08:07 2020 -0400

    lok: fix the window type of the formatted field control
    
    Change-Id: Iab87c94ca19314eacec18e71d7d09ba42f1756e7
    Reviewed-on: https://gerrit.libreoffice.org/c/core/+/93586
    Tested-by: Jenkins
    Reviewed-by: Henry Castro <hcastro@collabora.com>

I've taken a look, will submit a patch soon.
Comment 2 Michael Weghorn 2020-05-29 14:59:40 UTC
(In reply to Michael Weghorn from comment #1)
> I've taken a look, will submit a patch soon.

-> https://gerrit.libreoffice.org/c/core/+/95156
Comment 3 Commit Notification 2020-05-29 18:23:42 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/33cac418db78f64f7fa84b8e65c01c2b02cf17a7

tdf#133498 Make native drawing of FormattedField work (again)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-05-29 20:54:49 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/b03223b25366c981f40973152afaf9ed404fca76

tdf#133498 Make native drawing of FormattedField work (again)

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Weghorn 2020-06-01 13:28:58 UTC
*** Bug 133543 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2020-06-02 12:26:22 UTC
Good catch, thanks for fixing, Michael!