Download it now!
Bug 133543 - Broken spinner widgets in LibODev 7.0 Beta 1 with kf5 and qt5 vcl plugins
Summary: Broken spinner widgets in LibODev 7.0 Beta 1 with kf5 and qt5 vcl plugins
Status: RESOLVED DUPLICATE of bug 133498
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2020-05-31 09:44 UTC by sergio.callegari
Modified: 2020-06-01 13:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2020-05-31 09:44:15 UTC
Description:
When the up/down arrow of a spinner widget is pressed, the new value text is rewritten over the previous one rather than substituting the previous one, so messing up the widget text field and making it unreadable.

Seen with the KDE5 VCL.

Steps to Reproduce:
1. Perform any action that involves a spinner widget (e.g. try to change the position of an object in draw, or to set an option in the options interface)
2. Press the up or down arrow of the spinner widget

Actual Results:
New text is written over the old one

Expected Results:
New text should replace the old one


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: DrawingDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Jan-Marek Glogowski 2020-05-31 11:02:00 UTC
The real bug is the now broken native widget support for the ControlType::Spinbox (that's just my guess), at least on kf5. I didn't dig further into it, but did a quick bibisected to:

commit 2a694f9e0e7789b4b3b792a9eedd29366fa10c1c
Author: Henry Castro <hcastro@collabora.com>
Date:   Wed May 6 14:08:07 2020 -0400

    lok: fix the window type of the formatted field control
    
    Change-Id: Iab87c94ca19314eacec18e71d7d09ba42f1756e7
    Reviewed-on: https://gerrit.libreoffice.org/c/core/+/93586
    Tested-by: Jenkins
    Reviewed-by: Henry Castro <hcastro@collabora.com>

That looks more like it revealed some underlying bug, probably somewhere in VCL. gtk3 looks ok and didn't need any adaption I could identify in a 

  git log vcl/unx/gtk3

Very strange.

CC'ing him.
Comment 2 Michael Weghorn 2020-06-01 13:28:58 UTC
(In reply to Jan-Marek Glogowski from comment #1)
> The real bug is the now broken native widget support for the
> ControlType::Spinbox (that's just my guess), at least on kf5. I didn't dig
> further into it, but did a quick bibisected to:
> 
> commit 2a694f9e0e7789b4b3b792a9eedd29366fa10c1c
> Author: Henry Castro <hcastro@collabora.com>
> Date:   Wed May 6 14:08:07 2020 -0400
> 
>     lok: fix the window type of the formatted field control
>     
>     Change-Id: Iab87c94ca19314eacec18e71d7d09ba42f1756e7
>     Reviewed-on: https://gerrit.libreoffice.org/c/core/+/93586
>     Tested-by: Jenkins
>     Reviewed-by: Henry Castro <hcastro@collabora.com>
> 
> That looks more like it revealed some underlying bug, probably somewhere in
> VCL. gtk3 looks ok and didn't need any adaption I could identify in a 
> 
>   git log vcl/unx/gtk3
> 
> Very strange.
> 
> CC'ing him.

Closing this as a duplicate of tdf#133498, which I also bibisected to this commit. It's fixed in the meantime.

*** This bug has been marked as a duplicate of bug 133498 ***