Download it now!
Bug 133809 - Pimp layer tabbed bar on bottom of Draw
Summary: Pimp layer tabbed bar on bottom of Draw
Status: RESOLVED DUPLICATE of bug 116917
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Layers
  Show dependency treegraph
 
Reported: 2020-06-08 21:59 UTC by andreas_k
Modified: 2020-06-16 19:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2020-06-08 21:59:47 UTC
The layer tabbed bar on bottom has two default layers called
- Layout
- Controls
- Dimension Lines
you can show/hide them by right click modify.
Comment 1 andreas_k 2020-06-08 22:05:42 UTC
In general it's not very common to have layers arranged that way ordinary you have layers arranged in a list grouped by folders and you can show/hide them with an symbol or lock them by an symbol.

So my proposal for the layer tabbed bar on bottom of draw is:

1. rename at least Layout to Layer1, so that it's easier to understood that we talk about layers (in calc you also call them Sheet1).

2. remove Controls and Dimension Line cause you can add new layers (like in calc) but you can't delete the predefined one (Controls and Dimension Line can't be deleted)

3. move settings for Visible, Printable and Locked to the right click so if you would like to use them you don't need an dialog to hide or lock the layer.
Comment 2 V Stuart Foote 2020-06-08 22:46:41 UTC
Actually, before this goes ANY further--please take the time to read the Draw Guide (it has not been updated since the 4.3 release but is still applicable).

https://documentation.libreoffice.org/assets/Uploads/Documentation/en/DG4.3/DG43-DrawGuide.pdf

And specifically Chpt. 11 Advanced Draw Techniques which covers use of the 'Layers bar' and its three 'default' layers.

Suffice to say, Layers in LibreOffice function a lot different than other Vector/Raster editing programs in common use--and that the Layer bar is not Z-order sensitive nor are its layers 'groupable'.

There have been a lot of improvement requests about the Drawing UI, but the underlaying framework and ODF dictate a lot about what is appropriate.

Point is there is no sense banging away at the Layer bar without understanding how LibreOffice Draw handles layers. Please read the documentation.
Comment 3 Regina Henschel 2020-06-08 23:37:34 UTC
I think we do not need another bug. The problems are already covered by bug 90244, bug 90320, bug 89130, and bug 56498 and their duplicates.
And look at bug 99648 "[META] Improve Layer Handling", whether your ideas not already reported.


(In reply to andreas_k from comment #1)
> In general it's not very common to have layers arranged that way ordinary
> you have layers arranged in a list grouped by folders and you can show/hide
> them with an symbol or lock them by an symbol.
>
Which applications do you have in mind? Remember, that layers in Draw do not determine the stacking order.

> So my proposal for the layer tabbed bar on bottom of draw is:
> 
> 1. rename at least Layout to Layer1, so that it's easier to understood that
> we talk about layers (in calc you also call them Sheet1).
> 
Renaming the label "Layout" to something different is a task of the translation teams. Only the English string is in source (sd/inc/strings.hrc).
But keep in mind, that you need very good reasons to rename something that has its name already for twenty years.

> 2. remove Controls and Dimension Line cause you can add new layers (like in
> calc) but you can't delete the predefined one (Controls and Dimension Line
> can't be deleted)

I have already looked, whether it is possible to get rid of these two layers.  But there are so many internal consequences to the code that I've refrained from trying.

> 
> 3. move settings for Visible, Printable and Locked to the right click so if
> you would like to use them you don't need an dialog to hide or lock the
> layer.
You can use click+Shift (hide/show), click+Ctrl (lock/unlock) and click+Shift+Ctrl (printable/not printable).
Comment 4 Heiko Tietze 2020-06-09 09:24:48 UTC
(In reply to andreas_k from comment #1)
> 1. rename
-1, "Layer1" has no different meaning to me than "Layer". If you want to advertise the feature a plus-labeled button like Calc make sense (not urgently needed IMHO)

> 2. remove Controls and Dimension Line
+1, but likely a huge effort.

> 3. move settings for Visible, Printable and Locked to the right click..
don't move but make it available in the context menu not least to show the shortcuts. => dup of 89130


My take: either resolve as duplicate or keep for #2.
Comment 5 Regina Henschel 2020-06-09 12:26:53 UTC
(In reply to Heiko Tietze from comment #4)
> > 2. remove Controls and Dimension Line
> +1, but likely a huge effort.
> My take: either resolve as duplicate or keep for #2.

The ticket for removing "Controls" is bug 133809. It would surely be a huge effort.

Removing "Dimension Lines" might be possible. But the current implementation is really helpful. It allows to quickly measure objects and show/hide this without explicitly switching the layer. That would no longer be possible, if you need a user defined layer to separate drawing and measurement.
Comment 6 Heiko Tietze 2020-06-09 16:39:23 UTC
(In reply to Regina Henschel from comment #5)
> "Dimension Lines" ... is really helpful.

We could add the layer when dimension lines are placed on the canvas.
Comment 7 Heiko Tietze 2020-06-16 16:11:23 UTC

*** This bug has been marked as a duplicate of bug 116917 ***
Comment 8 V Stuart Foote 2020-06-16 19:07:17 UTC
(In reply to Regina Henschel from comment #5)
>
> The ticket for removing "Controls" is bug 133809. It would surely be a huge
> effort.

That should have been bug 116917, but yes if Controls from Forms are the same controls Draw, that tracks as the same issue.

(In reply to Heiko Tietze from comment #7)
> 
> *** This bug has been marked as a duplicate of bug 116917 ***

But is it, seems bug 90320 is closer. Or bug 99648 is the general case.

And, I really think any work on the Draw Layer bar is mute if we press on with work on bug 90244 to get the Draw layers (including Controls and Dimensions) into the Sidebar, either into Navigatior or as a new Deck.

=-ref-=

https://design.blog.documentfoundation.org/2016/07/31/how-the-navigator-may-support-object-handling-in-libreoffice-draw/