Download it now!
Bug 133816 - No way to set a document's overall direction
Summary: No way to set a document's overall direction
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-UI
  Show dependency treegraph
 
Reported: 2020-06-09 10:39 UTC by Eyal Rozenberg
Modified: 2020-06-20 10:31 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2020-06-09 10:39:02 UTC
Description:
In LibreOffice Writer, paragraphs and some other elements  can have their direction set to one of: RTL, LTR, or "Use superordinate object settings" (i.e. inherited).

The "superordinate object" for paragraphs on a page of a (simple) document is _not_ the page (which itself can have a direction LTR or RTL), but rather something else - likely, the entire document. 

There LO writer UI, to my knowledge, does not offer a way of changing this top-level direction. Specifically, it's not an option via File | Properties on the menus, nor is it kept in sync with, say, the Default Page style.

There should be UI for changing this (or, alternatively, the document should not _have_ a direction at all)

Steps to Reproduce:
N/A

Actual Results:
N/A

Expected Results:
N/A


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
I think LO has had this issue always, so I chose the earliest version on the list.

Also, I feel this is probably a dupe, but I couldn't find it reported.
Comment 1 Eyal Rozenberg 2020-06-20 10:04:41 UTC
Oh, wait wait! I was wrong. the paragraphs _do_ inherit the page style. But there's another bug which masks that. Closing this for now.