Download it now!
Bug 133980 - EDITING: Using Select all 3 times doesn't work in a nested table
Summary: EDITING: Using Select all 3 times doesn't work in a nested table
Status: RESOLVED DUPLICATE of bug 135682
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, implementationError
Depends on:
Blocks:
 
Reported: 2020-06-14 10:32 UTC by Xisco Faulí
Modified: 2020-09-15 07:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-06-14 10:32:53 UTC
Steps to reproduce:
1. Open attachment 131273 [details] from bug 106043
2. Click on 'Start selection here'
3. Use select all three times

-> Nothing is selected ( or the selection vanished after a few seconds ). Instead, content of both tables should be selected

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: ff508f6d8a3e58d29e9e7622006a7103fb0a2849
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-06-14 10:34:04 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c56bf1479cc71d1a2b0639f6383e90c1f7e3655b

author	Miklos Vajna <vmiklos@collabora.com>	2019-09-16 21:15:28 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2019-09-17 08:57:15 +0200
commit	c56bf1479cc71d1a2b0639f6383e90c1f7e3655b (patch)
tree	3db679971be5be40d2f737202de6b8106dc1d53c
parent	813cca94cd3a08d98c09fc7c34afddd02dc912ce (diff)
tdf#105330 sw: fix lost cursor on undoing nested table insert

Bisected with: bibisect-linux64-6.4

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2020-06-14 11:11:27 UTC
also reproduced with attachment 92052 [details] from bug 73616
Comment 3 Miklos Vajna 2020-06-16 07:25:45 UTC
Hmm, I don't think this ever worked. Yes, it "worked" after e4509eea8fc7c07ddff48edf0d4c015c2663d896 and before 	c56bf1479cc71d1a2b0639f6383e90c1f7e3655b but only with serious side-effects. So yes, it makes sense to fix this at some stage, but we need to came up with a plan on how to do these notifications in some better way. Clearly whatever you do (you only do it conditionally or unconditionally), currently you have problems. Till a better condition is found, it makes sense to have the state that was there forever, not replacing an old problem with a new one.

Adjusting keywords accordingly.
Comment 4 Xisco Faulí 2020-07-01 09:57:17 UTC
So this issue is only happening with GTK3, in the summary I was wrong with the about LibreOffice info.

@Caolán, I thought you might be interested in this issue
Comment 5 Xisco Faulí 2020-07-01 10:04:36 UTC
ok, no gtk3 only, can happen with gen but with gtk3 it happens all the time, with gen, sometimes...
Comment 6 Xisco Faulí 2020-09-15 07:41:57 UTC
Issue fixed by 
https://git.libreoffice.org/core/commit/6f1e02c96b887750f974c187a82ecd6236e6a435

Closing as a dupe of bug 135682

*** This bug has been marked as a duplicate of bug 135682 ***