Download it now!
Bug 135682 - EDITING: If a table is the first element of the document, "Select All" does not select all
Summary: EDITING: If a table is the first element of the document, "Select All" does n...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: All All
: high normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:6.4.7
Keywords: bibisected, bisected, regression
: 133980 (view as bug list)
Depends on:
Blocks: Writer-Tables-Select Selection
  Show dependency treegraph
 
Reported: 2020-08-12 20:07 UTC by Leroy
Modified: 2020-09-15 08:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leroy 2020-08-12 20:07:04 UTC
Description:
If a table is the first element of the document, menu `Edit` - `Select All` or `Ctrl+A` does not select all.

Steps to Reproduce:
1. Open a new text document
2. Insert a table
3. Choose menu Edit - Select All (or Ctrl+A) twice

Actual Results:
First time table is selected, second time all content is selected and inmediatelly deselected.

Expected Results:
First time table is selected, second time all content is and remain selected.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.3.6.2 (x86)
Build ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: es-MX (es_MX); UI-Language: en-US
Calc: threaded

The same with and without OpenGL.
Comment 1 Dieter 2020-08-27 09:15:40 UTC
I confirm it with

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Steps to reproduce

1. Open a new text document
2. Insert a table
3. Insert Cursor outside table
4. Choose menu Edit - Select All (or Ctrl+A)

Actual Results:
All content is selected and inmediatelly deselected.
Comment 2 Xisco Faulí 2020-09-03 13:30:22 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c56bf1479cc71d1a2b0639f6383e90c1f7e3655b

author	Miklos Vajna <vmiklos@collabora.com>	2019-09-16 21:15:28 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2019-09-17 08:57:15 +0200
commit	c56bf1479cc71d1a2b0639f6383e90c1f7e3655b (patch)
tree	3db679971be5be40d2f737202de6b8106dc1d53c
parent	813cca94cd3a08d98c09fc7c34afddd02dc912ce (diff)
tdf#105330 sw: fix lost cursor on undoing nested table insert

Bisected with: bibisect-linux64-6.4

Adding Cc: to Miklos Vajna
Comment 3 Commit Notification 2020-09-15 07:08:23 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6f1e02c96b887750f974c187a82ecd6236e6a435

tdf#135682 sw: fix lost selection-all when doc starts with table

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2020-09-15 07:41:57 UTC
*** Bug 133980 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2020-09-15 07:43:40 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 6f1e02c96b887750f974c187a82ecd6236e6a435
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!
Comment 6 Commit Notification 2020-09-15 08:50:51 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ffc8cc8d7891ef4be1a364116a2bc9075f51b2b9

tdf#135682 sw: fix lost selection-all when doc starts with table

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-09-15 08:59:21 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/d3a874cedc6129bace47fbee4b781e7a5e30b65f

tdf#135682 sw: fix lost selection-all when doc starts with table

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.