Bug 134085 - Start Center: Document names mismatched with their thumbnails with RTL language UI
Summary: Start Center: Document names mismatched with their thumbnails with RTL langua...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.1 target:7.0.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Start-Center RTL-UI Regressions-cairo-speedup
  Show dependency treegraph
 
Reported: 2020-06-17 23:04 UTC by Rizal Muttaqin
Modified: 2020-08-10 22:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Doc Thumbnails (Recent Files and Templates) with RTL UI (475.27 KB, image/png)
2020-06-17 23:04 UTC, Rizal Muttaqin
Details
Before vs After the mentioned commit (403.51 KB, image/png)
2020-07-16 14:19 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2020-06-17 23:04:55 UTC
Created attachment 162133 [details]
Doc Thumbnails (Recent Files and Templates) with RTL UI

Step to reproduce:
1. Set locale to Arabic
2. Open some files
3. Close all opened documents and see the Start Center

As we can see in the screenshot, there are some issues appear

1. Document thumbnails are wrong, they are exchanged randomly, some are even missing. This appears both in Recent Files list and also in Templates list.
2. No close button so no way to remove the files from Start Center. Sometime the button appear in random place (e.g hovering an area on top BH40-BaseHandbook file triggered close button in the upper right MG44-MathGuide or vice versa, but I can not click it and this is hardly repeatable)


Version: 7.1.0.0.alpha0+
Build ID: cd47dba9aa4b91bb0edf0744561d29e2eef61cc9
خيوط المعالج: 4; نظام التَّشغيل: Linux 4.20; مصيّر الواجهة: المبدئيّ; VCL: kf5
Locale: id-ID (id_ID.UTF-8); UI: ar-SA
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-11_19:46:20
Calc: threaded
Comment 1 Eyal Rozenberg 2020-06-19 16:52:59 UTC
Confirmed with:

Version: 7.0.0.0.beta1
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Linux 5.2; UI render: default; VCL: gtk3
Locale: en-US (en_IL); UI: en-US
Calc: threaded
Comment 2 Eyal Rozenberg 2020-06-19 16:55:48 UTC
I've marked this issue with dataLoss, since a user who gets confused about which file they're editing - due to the mismatch of thumbnail and filename - could very easily make changes or deletions intended for one file in another file, save these changes, and thus lose the original data.
Comment 3 Eyal Rozenberg 2020-06-19 16:57:37 UTC
This also happens with a Hebrew language interface, so it's not Arabic-specific. Confirmed on the same build.
Comment 4 Rizal Muttaqin 2020-06-20 23:07:53 UTC
Reproducible also in Windows build


Version: 7.1.0.0.alpha0+ (x64)
Build ID: 63d4e8aa10186b4ed0e3106c116ad25c5fb5ed6d
خيوط المعالج: 4; نظام التَّشغيل: Windows 10.0 Build 18363; مصيّر الواجهة: Skia/Raster; VCL: win
Locale: id-ID (id_ID); UI: ar-SA
Calc: threaded
Comment 5 Rizal Muttaqin 2020-06-20 23:22:01 UTC
Not repro in

إصدارة: 6.4.1.2 (x64)
معرّف البناء: 4d224e95b98b138af42a64d84056446d09082932
خيوط المعالج: 4; نظام التَّشغيل: Windows 10.0 Build 18363; مصيّر الواجهة: المبدئيّ; VCL: win; 
المحليّة: id-ID (id_ID); لغة الواجهة الرسومية: ar-SA
Calc: threaded
Comment 6 Buovjaga 2020-06-23 13:12:56 UTC
Bibisected with Linux 6.5 repo to https://git.libreoffice.org/core/+/f1d6788fe1767f97e3ca2c67c7415f8c18c3d618%5E!/
tdf#130768 need to use mnOutOffX/mnOutOffY

Adding Cc: to Armin Le Grand
Comment 7 Rizal Muttaqin 2020-06-27 11:18:35 UTC
This is not reproducible with gen backend


Version: 7.1.0.0.alpha0+
Build ID: 3ba009e0c2b7800305103f8ec86df58625fed955
خيوط المعالج: 4; نظام التَّشغيل: Linux 4.20; مصيّر الواجهة: المبدئيّ; VCL: x11
Locale: id-ID (id_ID.UTF-8); UI: ar-SA
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-25_05:32:26
Calc: threaded
Comment 8 Xisco Faulí 2020-07-16 11:25:48 UTC
Reproduced using SAL_RTL_ENABLED=1 with gtk3, not with gen.

@Caolán, sorry for pinging you again but since you fixed bug 134841 I thought you might be interested in this issue too
Comment 9 Xisco Faulí 2020-07-16 11:35:52 UTC
after giving it a second thought, I think it should be treat as a highest/critical bug and should be fixed asap
Comment 10 Heiko Tietze 2020-07-16 11:52:09 UTC
Confirming no issue with gen but with gtk3.
Comment 11 Caolán McNamara 2020-07-16 13:26:51 UTC
FWIW its not a gtk3 thing specifically, but a thing belonging to the "fancier" drawing backends, of which the cairo backend used by the gtk3 port is one
Comment 12 Caolán McNamara 2020-07-16 13:56:14 UTC
I think its wrong before that commit too, wrong names on the images. I think we have 99.9% of this right and then fell down at the last hurdle and discarded our mirrored values
Comment 13 Xisco Faulí 2020-07-16 14:19:51 UTC
Created attachment 163123 [details]
Before vs After the mentioned commit
Comment 14 Caolán McNamara 2020-07-16 14:44:55 UTC
yeah, I bet the "XLS-PICTURE BUG Example" text is on the wrong image
Comment 15 Xisco Faulí 2020-07-16 14:54:17 UTC
(In reply to Caolán McNamara from comment #14)
> yeah, I bet the "XLS-PICTURE BUG Example" text is on the wrong image

oh, you're right. I didn't notice that. This issue started to happen after

https://cgit.freedesktop.org/libreoffice/core/commit/?id=828504974d70111e4a35b31d579cf42fe660a660

author	Armin Le Grand (Collabora) <armin.le.grand@me.com>	2020-02-21 16:58:17 +0100
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2020-02-21 20:16:59 +0100
commit	828504974d70111e4a35b31d579cf42fe660a660 (patch)
tree	4c2f7720b3efaecf55b8fa7b9b3eeccb278160e6
parent	813cde918338bccc4f711230616340cad2c1d4a0 (diff)
tdf#130768 speedup huge pixel graphics Cairo
Comment 16 Caolán McNamara 2020-07-17 19:20:08 UTC
https://gerrit.libreoffice.org/c/core/+/98982 would fix it for at least the cairo (gtk+headless+online) case. I'm sure it would put things into the right place for windows, though without testing I'm unsure if it would then reverse the contents of the graphics which is something I see happens in the skia case
Comment 17 Caolán McNamara 2020-07-19 17:18:19 UTC
The highlight of an icon is also missing in RTL which it exists in LTR.
Comment 18 Caolán McNamara 2020-07-19 18:43:36 UTC
https://gerrit.libreoffice.org/c/core/+/98982 makes the images appear in the right place and restores the highlighting rectangle under RTL (which is missing under gen too)
Comment 19 Commit Notification 2020-07-20 09:39:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6a54960f6b38a7d549ed33419cf55f4e718cf7b9

tdf#134085 DrawTransformedBitmap in wrong place for RTL

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-07-20 11:07:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/582419f5ce2e0e7ca58df035b082c866f76efafa

tdf#134085 DrawTransformedBitmap in wrong place for RTL

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Caolán McNamara 2020-07-20 11:08:37 UTC
that gives the expected results at least
Comment 22 Xisco Faulí 2020-07-20 11:41:08 UTC
Verified in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1db7decf3fb172542f5fce03ce7bf0cb310d1ffc
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 23 Commit Notification 2020-07-29 18:24:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-0":

https://git.libreoffice.org/core/commit/79586f26d6253f38aa0a37a571bb02b51b747d59

tdf#134085 DrawTransformedBitmap in wrong place for RTL

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Rizal Muttaqin 2020-08-10 22:30:06 UTC
I verify this bug has been fixed

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 4.20; UI render: default; VCL: kf5
Locale: id-ID (id_ID.UTF-8); UI: ar-SA
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-03_12:22:47
Calc: threaded


Thank you Caolán