Bug 134802 - [ENHANCEMENT] Proposal of a new "Paste Special" dialog box
Summary: [ENHANCEMENT] Proposal of a new "Paste Special" dialog box
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.2.0
Keywords: needsUXEval
: 106852 (view as bug list)
Depends on:
Blocks: Dialog Paste-Special
  Show dependency treegraph
 
Reported: 2020-07-14 14:02 UTC by Rafael Lima
Modified: 2021-08-06 12:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Prototype for a new Paste Special Dialog box (70.30 KB, image/png)
2020-07-14 14:48 UTC, Rafael Lima
Details
ODG file with the proposed dialog (87.56 KB, application/vnd.oasis.opendocument.graphics)
2020-09-15 21:17 UTC, Rafael Lima
Details
Example for solutions (105.21 KB, image/png)
2020-11-24 16:09 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2020-07-14 14:02:54 UTC
I am using LO Calc 6.4.4.2 on Ubuntu 20.04. When I copy a range of cells containing formulas (ex: a column of numbers resulting from a formula) and I want to copy and paste the values transposed onto a row, it keeps pasting values as a column.

Steps to reproduce:
1 - Create a column of formulas resulting in numbers
2 - Ctrl-C to copy the cells containing the formula results
3 - Ctrl + Shift + V to open Paste Special dialog
4 - Check the "Transpose" option
5 - Click "Paste Values-Only" button at the top left corner of the dialog

Results: It paste the values, but without transposing them

Note that if I click the "Transpose" button at the top right corner of the dialog and uncheck the "Formula" option, it will still paste the transposed Formulas.

I think there is either a bug here of at least some inconsistency with this dialog box.

In any case, I cannot paste transposed values.
Comment 1 Rafael Lima 2020-07-14 14:07:58 UTC
UPDATE: I learned the correct way to paste transposed values only. I just needed to uncheck "Formula" and check "Transpose" and then click "Ok".

Anyway, as an end user I think the dialog box could be redesigned, because those buttons at the top of the dialog are confusing. They give the impression that the options below will be applied after you click them.

If possible, I'd like to change this bug report to an Enhancement request.
Comment 2 Rafael Lima 2020-07-14 14:48:08 UTC
Created attachment 163020 [details]
Prototype for a new Paste Special Dialog box

In addition to my previous comments, I would like to propose a new design for the Paste Special dialog box. The main highlights are:
- Redesign of the quick action buttons, with the addition of two new actions
- Addition of the Shif cels up and left options
Comment 3 m.a.riosv 2020-07-16 18:26:52 UTC
Pls then change the 'importance' from 'normal' to 'enhancement' and change bug title accordantly.
Comment 4 Rafael Lima 2020-07-16 20:06:23 UTC
I changed the title and the "Importance" to indicate that this is an enhancement request.
Comment 5 QA Administrators 2020-07-17 03:52:54 UTC Comment hidden (obsolete)
Comment 6 Thomas Lendo 2020-09-15 09:07:39 UTC
Adding needsUXEval.

I like the proposed design of the dialog window, especially:

+ "Quick actions" title in addition to the "Custom actions" title.
+ The quick action buttons have a symbol AND text description per default. (It's always irritating to wait for a tool tip when moving the mouse cursor over the symbols in the current dialog.)
+ More "Quick actions" than now. Paste All, Values only and Formats are important options so that the user hasn't to click through all the check boxes below.

Questions:

- What's with the "Operations" actions of the current dialog? They're missing in the proposal.
- Are the "Custom actions" and "Shift cells" options linked together (in opposite to the "Quick actions" above)? Then they should all be grouped so that it's visible for the user that 'Paste All', 'Text', etc. and 'Don't shift', 'Down' etc. are all part of the "Custom actions" and that they have nothing to do with the "Quick actions".

Do we have metrics which option combinations are most used by LibreOffice users?
Comment 7 Heiko Tietze 2020-09-15 09:59:01 UTC
In addition to Thomas' comment: Keep localization in mind, words are usually longer in other languages. Putting Selection and Options together is questionable.
But more quick actions are nice to have and brings me to the idea of our three-column layout. Why not have the quick actions as a (extendable) preset list on the left and we show the configuration on single click (double to execute). Right hand there could be some kind of graphics as a preview.
Comment 8 Rafael Lima 2020-09-15 21:17:36 UTC
Created attachment 165552 [details]
ODG file with the proposed dialog

I attached the ODG file with the proposed dialog so that other people can edit it and improve the proposal.

The file has 2 pages:
1) The original proposal that was posted as a PNG file
2) A new proposal with the addition of the "Operations" section
Comment 9 Rafael Lima 2020-09-15 21:26:39 UTC
> - What's with the "Operations" actions of the current dialog? They're
> missing in the proposal.

I had left them out in the original proposal to make the dialog look "cleaner". I added them in the new proposal that has been attached as an ODG file.

> - Are the "Custom actions" and "Shift cells" options linked together (in
> opposite to the "Quick actions" above)? Then they should all be grouped so
> that it's visible for the user that 'Paste All', 'Text', etc. and 'Don't
> shift', 'Down' etc. are all part of the "Custom actions" and that they have
> nothing to do with the "Quick actions".

I considered them as a separate block for 2 reasons:
1) Shift actions use radio buttons meaning that only one can be selected, whereas Custom actions use checkboxes because multiple actions can be selected.
2) This separation is consistent with the current design; The main change I did was combining the existing "Options" section with the "Selection" section, which all use checkboxes.

> Do we have metrics which option combinations are most used by LibreOffice
> users?

This would be useful, because I believe some actions are rarely used. I chose the buttons at the top based on my way of using Calc and also on the opinions of my students, who often use Calc and ask where some functions are.
Comment 10 Heiko Tietze 2020-11-24 16:09:21 UTC
Created attachment 167541 [details]
Example for solutions

From left to right: Current situation, Proposal with 3 columns, Proposal with 4 columns, and Presets (see comment 7) (the buttons should show Image+Text but don't out of the box; "Run Immediately" off means the button applies settings only)
Comment 11 Roman Kuznetsov 2020-11-24 21:57:07 UTC
(In reply to Heiko Tietze from comment #10)
> Created attachment 167541 [details]
> Example for solutions
> 
> From left to right: Current situation, Proposal with 3 columns, Proposal
> with 4 columns, and Presets (see comment 7) (the buttons should show
> Image+Text but don't out of the box; "Run Immediately" off means the button
> applies settings only)

I like a last right variant with Presets in first column, but I dislike icons on buttons in that case. I would prefer buttons with labels there 

And I would change "Selection" label to "Paste" and item label "Paste all" to simple "All" like:

Paste:
 All
 Numbers
 Text
 Date&Time
 etc.
Comment 12 Rafael Lima 2020-11-25 12:23:28 UTC
I liked the last layout, with the 5 buttons stacked. However, I guess it would look nicer if the icons were followed by some text.

I understand the localization issue, however the labels for the Presets are short. Maybe it won't be a big issue. Also, don't button sizes in the dialog adjust to the label size?
Comment 13 Commit Notification 2020-11-27 09:40:23 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4c0c77f10c3967c720cb0511dc26986a5b003f33

Resolves tdf#134802 - Improved "Paste Special" dialog box

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Gabor Kelemen 2021-04-13 07:08:23 UTC
*** Bug 106852 has been marked as a duplicate of this bug. ***
Comment 15 BogdanB 2021-05-07 04:19:07 UTC
It's done now. Verified in
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 1a99b4e44190e182d56a04678850d62635d74c65
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded