Download it now!
Bug 134943 - Enabling toggling of the Impress “Presenter Screen/Presenter Console” using the “Presenting Context Menu”
Summary: Enabling toggling of the Impress “Presenter Screen/Presenter Console” using t...
Status: RESOLVED DUPLICATE of bug 62179
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-19 04:29 UTC by Óvári
Modified: 2020-07-24 16:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Presenting Context Menu (9.26 KB, image/png)
2020-07-19 04:31 UTC, Óvári
Details
Screen sharing of the “Presenting: …” window in Jitsi Meet (11.39 KB, image/png)
2020-07-19 04:32 UTC, Óvári
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2020-07-19 04:29:14 UTC
Description:
Please enable the “Presenting Contextual Menu” to show/hide the “Impress Presenter Screen/Presenter Console”.

This is helpful when there is only one display and LibreOffice Impress is used with Jitsi Meet [1, 2]. The “Presenting: …” window can be shared with Jitsi Meet for everyone in the online conference to see. The Presenter Console can easily be turned on to show the notes for the current slide, time, etc for only the presenter to see.

This is also helpful when there is two displays and LibreOffice Impress is used with Jitsi Meet [1, 2]. The Presenter Console can be easily turned off and one display can used for the Presenting and the other display can be used to show Jitsi Meet in Tile View [3]. This way the presenter can write on the Impress slides and also see if anyone has their hand up or are writing in the Chat in the Jitsi Meet room.

This would enables feature discovery, instead of using advanced settings [4]. The Presenter Screen can also be turn on and off during a presentation. It also provides improvement in the user experience.

This would also nicely complement the new features being added to Presenter [5, 6].

What do you think?

Thank you

[1] https://jitsi.documentfoundation.org/
[2] https://meet.jit.si/
[3] https://jitsi.org/blog/new-feature-brady-bunch-style-layout/
[4] https://blog.documentfoundation.org/blog/2020/06/02/lo-tuesday-tt-impress-presenter-screen/
[5] https://libreofficemaster.blogspot.com/2020/07/new-features-in-impress-presenter.html
[6] https://bugs.documentfoundation.org/show_bug.cgi?id=90978

Steps to Reproduce:
1. Open Impress Presentation
2. Menu Bar → Slide Show → Start from First Slide
3. Right click on the Slide to bring up the “Presenting Contextual Menu”
4. Enhancement:
Select “Show Presenter Console” if the Presenter Console is not shown
or
Select “Hide Presenter Console” if the Presenter Console is shown.


Actual Results:
Unable to easily show/hide the Presenter Console when in a presentation.

Expected Results:
Easily show/hide the Presenter Console when in a presentation.


Reproducible: Always


User Profile Reset: No



Additional Info:
[1] https://jitsi.documentfoundation.org/
[2] https://meet.jit.si/
[3] https://jitsi.org/blog/new-feature-brady-bunch-style-layout/
[4] https://blog.documentfoundation.org/blog/2020/06/02/lo-tuesday-tt-impress-presenter-screen/
[5] https://libreofficemaster.blogspot.com/2020/07/new-features-in-impress-presenter.html
[6] https://bugs.documentfoundation.org/show_bug.cgi?id=90978
Comment 1 Óvári 2020-07-19 04:31:01 UTC
Created attachment 163251 [details]
Presenting Context Menu

Please add the “Show Presenter Console” or “Hide Presenter Console” to this contextual menu.
Comment 2 Óvári 2020-07-19 04:32:16 UTC
Created attachment 163252 [details]
Screen sharing of the “Presenting: …” window in Jitsi Meet
Comment 3 Óvári 2020-07-19 04:34:47 UTC
Srijan Bhatia would you like to add this feature as it complements your work at bug 128964? Thank you
Comment 4 Óvári 2020-07-19 04:38:34 UTC
This would also help as people are doing more online conferences, education, etc from home due to the current situation worldwide.
Comment 5 Timur 2020-07-19 12:03:02 UTC
Please do not call developer when bug is not confirmed. Especially this one that needs evaluation. 

I do not quite understand what you want but I'll assume it's Presenter console with a single monitor. There's already bug for this. I proposed a solution there that I thing is easy to make yet very useful.

*** This bug has been marked as a duplicate of bug 62179 ***
Comment 6 Timur 2020-07-24 16:05:22 UTC
Srijan, if you can try to resolve bug 62179 as proposed, it would be valuable. 
I'm writing here because you're are already in cc, not to make noise there. 
Thanks for your work.
Comment 7 Srijan Bhatia 2020-07-24 16:45:09 UTC
(In reply to Timur from comment #6)
> Srijan, if you can try to resolve bug 62179 as proposed, it would be
> valuable. 
> I'm writing here because you're are already in cc, not to make noise there. 
> Thanks for your work.

Hi Timur,
I won't be contributing past 9th August.
I'll definitely try but I can't promise I'll be able to do it by then as I am busy with some other stuff as well.