Bug 134978 - FILEOPEN XLSX Pie chart data labels custom positioning is not imported
Summary: FILEOPEN XLSX Pie chart data labels custom positioning is not imported
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Tünde Tóth
URL:
Whiteboard: target:7.1.0
Keywords:
: 136235 (view as bug list)
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-07-20 11:49 UTC by NISZ LibreOffice Team
Modified: 2020-11-11 10:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Excel with custom pie chart data label position (12.86 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-07-20 11:49 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc (102.28 KB, image/png)
2020-07-20 11:49 UTC, NISZ LibreOffice Team
Details
Preliminary results (429.38 KB, image/png)
2020-09-22 13:00 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-07-20 11:49:39 UTC
Created attachment 163311 [details]
Example file from Excel with custom pie chart data label position

Attached pie chart has data labels enabled and one of the labels positioned manually outside the drawing area.
When opening this file in Calc the manually positioned label appears at the default position, on its slice.

Steps to reproduce:
1.	Open attached document

Actual results:
All labels are on their slices.

Expected results:
Label of the largest slice is positioned manually.

LibreOffice details:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a3e52f63c92876b4a3ac6df61e05b1d3510ba9c9
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-07-20 11:49:59 UTC
Created attachment 163312 [details]
Screenshot of the original document side by side in Excel and Calc
Comment 2 NISZ LibreOffice Team 2020-07-20 11:51:29 UTC
Looks like bug #121281 also suffers from this problem.
Comment 3 Xisco Faulí 2020-07-20 13:33:27 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: abea0d6647c7f1f7e76c73c26cb80e6a67dc5111
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 László Németh 2020-09-22 13:00:32 UTC
Created attachment 165772 [details]
Preliminary results

of https://gerrit.libreoffice.org/c/core/+/102981
Comment 5 Commit Notification 2020-10-09 07:24:43 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/20da1a5dd37c7edac620566c992d5a53b23a5f12

tdf#134978 Chart OOXML Import: fix pie chart label custom position

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 NISZ LibreOffice Team 2020-10-26 15:05:43 UTC
*** Bug 136235 has been marked as a duplicate of this bug. ***
Comment 7 NISZ LibreOffice Team 2020-11-11 10:39:06 UTC
Verified in

Version: 7.1.0.0.alpha1+ (x64)
Build ID: a689cf1672e89cb78fbcfa14c505850927e71f58
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-GB
Calc: threaded

Thank you!