Bug 136235 - FILEOPEN PPTX: labels of piechart illegible - labels positioned on identically colored pies
Summary: FILEOPEN PPTX: labels of piechart illegible - labels positioned on identicall...
Status: VERIFIED DUPLICATE of bug 134978
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-08-28 16:27 UTC by Gerald Pfeifer
Modified: 2020-10-29 23:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document (2.22 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-08-28 16:27 UTC, Gerald Pfeifer
Details
Visual comparison Office 365 vs LibreOffice (58.10 KB, image/png)
2020-08-28 16:29 UTC, Gerald Pfeifer
Details
Another document which exhibits similar behavior (1.15 MB, application/vnd.ms-powerpoint)
2020-09-26 11:55 UTC, Gerald Pfeifer
Details
The example document in PP and Impress 7.1alpha (108.09 KB, image/png)
2020-10-26 14:59 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-08-28 16:27:33 UTC
Created attachment 164818 [details]
Sample document

The chart on this slide is not legible since the labels are positioned on
top of the pies ... with exactly the same color.
Comment 1 Gerald Pfeifer 2020-08-28 16:29:44 UTC
Created attachment 164819 [details]
Visual comparison Office 365 vs LibreOffice
Comment 2 Xisco Faulí 2020-09-07 09:20:54 UTC
The labels were displayed outside the chart before

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a4cdd4d1266e77330d4745f369db85ee7dba265c

author	Balazs Varga <balazs.varga991@gmail.com>	2020-01-21 14:20:38 +0100
committer	László Németh <nemeth@numbertext.org>	2020-01-24 13:01:44 +0100
commit a4cdd4d1266e77330d4745f369db85ee7dba265c (patch)
tree 318b92a64666f3a5cd59a4ee860efa6832ca215e
parent 3e4cad1f4b4a6a07b516a0d205d642a985e17484 (diff)
tdf#130105 Chart OOXML Import: Fix data label position

Bisected with: bibisect-linux64-7.0

Adding Cc: to Balazs Varga
Comment 3 NISZ LibreOffice Team 2020-09-07 10:46:52 UTC
This has custom data label positions set in PP. Those are known to not be imported yet: see bug #134978.
Comment 4 Xisco Faulí 2020-09-16 11:51:17 UTC
attachment 164759 [details] from bug 136235 is also affected by this issue
Comment 5 Aron Budea 2020-09-16 12:11:34 UTC
(In reply to Xisco Faulí from comment #4)
> attachment 164759 [details] from bug 136235 is also affected by this issue
From bug 136191, actually.
Comment 6 Gerald Pfeifer 2020-09-26 11:55:03 UTC
Created attachment 165865 [details]
Another document which exhibits similar behavior

Here is another document that exhibits similar behavior (dark text on dark
blue pie in lower left quadrant).

Is this the same root cause, or should I open a different bug report?
Comment 7 NISZ LibreOffice Team 2020-10-26 14:59:15 UTC
Created attachment 166741 [details]
The example document in PP and Impress 7.1alpha

This started to look quite good since:

https://git.libreoffice.org/core/+/20da1a5dd37c7edac620566c992d5a53b23a5f12


author
Tünde Tóth <toth.tunde@nisz.hu> Thu Sep 17 16:49:02 2020 +0200 
committer
László Németh <nemeth@numbertext.org> Fri Oct 09 09:24:18 2020 +0200 

tdf#134978 Chart OOXML Import: fix pie chart label custom position
Comment 8 NISZ LibreOffice Team 2020-10-26 15:05:43 UTC
Let's mark this a duplicate. 
The other file from comment #6 is the same as the one in bug #136875 - that too got better but still not perfect.

*** This bug has been marked as a duplicate of bug 134978 ***
Comment 9 Gerald Pfeifer 2020-10-29 23:54:09 UTC
I confirm my original testcase looks as desired.

Also confirmed by "The example document in PP and Impress 7.1alpha" 
from NISZ LibreOffice Team - thank you!