Bug 135137 - Broken link to Help page from navigator rename object dialog.
Summary: Broken link to Help page from navigator rename object dialog.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords:
Depends on:
Blocks: Navigator Help-Link
  Show dependency treegraph
 
Reported: 2020-07-26 01:23 UTC by sawakaze
Modified: 2022-04-10 10:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sawakaze 2020-07-26 01:23:08 UTC
Description:
On writer, after following steps, i can not view helppage.

Steps to Reproduce:
1. open writer
2. insert table
3. select table and right click on Navigator. 
-> popup menu
4. select "Rename"
-> popup Rename object dialog
5. Press Help 
-> show "Could not find help page (404)"


Actual Results:
show "Could not find help page (404)"

Expected Results:
show help page.
note: not exist help page, but break to link
help page is text/shared/01/05190000.html

this page is able to open from "Drawing Objects" Rename page.
i think added rename function on libreoffice 7.0 can not open helppage.



Reproducible: Always


User Profile Reset: No



Additional Info:
i confirm this version 

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: ja-JP (ja_JP.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-07-23_16:54:25
Calc: threaded
Comment 1 Dieter 2020-07-27 13:25:42 UTC
I confirm it with

Version: 7.0.0.0.beta2 (x64)
Build ID: 1c213561a365b5666167321de68c9977500c9612
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Actual result: Help in "Rename Object" dialog opens https://help.libreoffice.org/7.0/en-GB/text/swriter/main0000.html?System=WIN&DbPAR=WRITER

Expected Result: ??? (Couldn't find an adequate help page)
Comment 2 sdc.blanco 2020-11-06 11:12:03 UTC
STR gives me: https://help.libreoffice.org/7.1/en-US/text/swriter/01/04040000.html

Version: 7.1.0.0.alpha1+ (x64)
Build ID: a4d4ed86991e2901ac86189e95966d4e99be4944
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: da-DK (en_DK); UI: en-US
Calc: threaded

NB 1.  bug 130733 has link to the patch that possibly gives WFM/Fixed for this bug.

NB 2.  If you click the Help button a second time (in the Rename dialog), then you will also get the Help Home page  (similar to:  bug 129745)
Comment 3 Rafael Lima 2022-01-04 12:44:27 UTC
Following the steps from the OP is leading to:
text/swriter/01/04040000.html?System=UNIX&DbPAR=WRITER&HID=modules/swriter/ui/renameobjectdialog/dialog-action_area1#bm_id1001595433265348

Which is not correct, because this is the help page for the Insert > Bookmark dialog, which has a Rename button. So the help page above is about this button.

Linking the Help button to the link below will not suffice, because this help page is about when you are assigning a name for an object (not renaming it from the Navigator)
text/shared/01/05190000.html

There doens't exist a help page for this small dialog. So the solution is to create a new one and add the HID into this new help page.

Tested on:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 4574a1ea408c2ac30042dca32d02207ec7add4da
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL
Comment 4 Dieter 2022-01-04 12:57:05 UTC
We would need a general page for renaming options, because it's the same dialog (and therefor the same help-button) for every kin d of object. But is it really necessary to have a help-button for changing a name? So perhaps it's easier to delete that button in the dialog.
Comment 5 Commit Notification 2022-01-04 19:50:41 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/2e3f6779c041ea475ba5127dbefefbd2f6a9c6fc

tdf#135137 Create help for "Rename object" dialog
Comment 6 Dieter 2022-04-10 10:14:29 UTC
VERIFIED with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d34d1db55978bdcff082af1e0f75b18fa6fc94f4
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Target is now:  https://help.libreoffice.org/7.4/en-GB/text/shared/01/05190000.html?System=WIN&DbPAR=WRITER&HID=cui/ui/objectnamedialog/dialog-action_area3#bm_id8149052

Rafaal, thanks for fixing it!