Bug 135688 - Can't open help page about Comparison on LibreOffice Writer Options
Summary: Can't open help page about Comparison on LibreOffice Writer Options
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Olivier Hallot
URL:
Whiteboard: target:7.1.0
Keywords:
: 71154 (view as bug list)
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2020-08-13 05:52 UTC by sawakaze
Modified: 2022-04-10 10:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Error page Screen cast (157.49 KB, image/png)
2020-08-13 05:54 UTC, sawakaze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sawakaze 2020-08-13 05:52:13 UTC
Description:
following steps, I can't open help page.

Steps to Reproduce:
1. open writer 
2. tool > options 
--> open Option window
3. select LibreOffice Writer > Comparison
4. press Help button

Actual Results:
Help page "Could not find help page(404)"

Help ID:modules/swriter/ui/optcomparison/OptComparison

Expected Results:
Open help page about Comparison option.


Reproducible: Always


User Profile Reset: No



Additional Info:
i confirm it

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: ja-JP (ja_JP.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-11_15:13:29
Calc: threaded
Comment 1 sawakaze 2020-08-13 05:54:08 UTC
Created attachment 164228 [details]
Error page Screen cast
Comment 2 Olivier Hallot 2020-08-13 14:22:43 UTC
Digital Archaelogy

http://gsoc-tzvetelina.blogspot.com/2009_06_01_archive.html
Comment 3 Commit Notification 2020-08-16 17:08:19 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/94dcf7ef3fdb4f4722d2cc3d3d8a5713bf45d7b3

tdf#135688 Help page for Comparison Options
Comment 4 sdc.blanco 2020-09-20 13:37:59 UTC
(In reply to Commit Notification from comment #3)
> https://git.libreoffice.org/help/commit/
> 94dcf7ef3fdb4f4722d2cc3d3d8a5713bf45d7b3
Maybe this patch also resolves: bug 71154
Comment 5 Olivier Hallot 2020-09-23 16:33:32 UTC
*** Bug 71154 has been marked as a duplicate of this bug. ***
Comment 6 Dieter 2021-12-29 18:13:07 UTC
Don't know, if status should be fixed, but I can see a very strange behaviour in

Pressing help button in Comparison dialog target is

https://help.libreoffice.org/7.3/en-GB/text/shared/optionen/01040800.html?System=WIN&DbPAR=WRITER&HID=modules/swriter/ui/optcomparison/OptComparison#bm_id491597320214148

pressing button again target is

https://help.libreoffice.org/7.3/en-GB/text/shared/optionen/java.html?System=WIN&DbPAR=WRITER&HID=cui/ui/optionsdialog/help#bm_id30195

Reproducible when closing dialog and reopening it.

Additional information:
Help page mentioned, that it "needs further work for correctness and completion" (see also bug 146052 comment 2 and discussion in bug 136434). Bug 71154 asked for more informations, but has been marked as a duplicate. So perhaps it should be reopened or summary of bug 135688 should be extended.
Comment 7 Olivier Hallot 2022-04-06 13:37:46 UTC
Cannot verify the dual help page indicated in comment#6.

Version: 7.3.2.2 / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: pt-BR
Calc: threaded

On the issue of "need further work..", an expert advise is necessary to turn the feature documentation more end-user readable.
Comment 8 Dieter 2022-04-06 13:42:26 UTC
(In reply to Olivier Hallot from comment #7)
> Cannot verify the dual help page indicated in comment#6.

I also can't reproduce anymore

Version: 7.3.2.2 (x64) / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: zh-CN (de_DE); UI: en-GB
Calc: CL
Comment 9 Dieter 2022-04-10 10:11:04 UTC
VERIFIED with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d34d1db55978bdcff082af1e0f75b18fa6fc94f4
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL