Bug 136200 - Add a form to edit/add pre-defined "Table Design" styles in the sidebar
Summary: Add a form to edit/add pre-defined "Table Design" styles in the sidebar
Status: RESOLVED DUPLICATE of bug 105933
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Table-Styles
  Show dependency treegraph
 
Reported: 2020-08-27 17:33 UTC by Rafael Lima
Modified: 2021-04-20 07:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice Table Design Sidebar (9.73 KB, image/png)
2020-08-27 17:33 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2020-08-27 17:33:40 UTC
Created attachment 164770 [details]
LibreOffice Table Design Sidebar

There is a functionality named "Table Design" available in LO Impress when a table is selected. With it, the user can choose among some pre-defined table designs and apply them to the selected table.

However, there is no way the user can edit the designs current available, or even add new designs. This would be an awesome feature to implement.

Also, I'd like to point out that the available designs exist since the OpenOffice era. It seems that they're hard-coded into LibreOffice.

I added an attachment showing the functionality I'm mentioning in this Enhancement request.
Comment 1 Heiko Tietze 2021-04-20 07:20:05 UTC
There is bug 101802 requesting to consolidate the UI, bug 137138 wants to have a preview in the Stylist like Impress has, and finally bug 105933 to introduce the missing UI to edit a table style. => DUP of this

*** This bug has been marked as a duplicate of bug 105933 ***