Bug 136251 - Upright (non-italic) lowercase greek symbols displayed as italic in Math
Summary: Upright (non-italic) lowercase greek symbols displayed as italic in Math
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 142159 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-08-29 00:07 UTC by Ming Hua
Modified: 2021-05-08 00:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing upright greek symbols displayed as italic (5.46 KB, image/png)
2020-08-29 00:07 UTC, Ming Hua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Hua 2020-08-29 00:07:47 UTC
Created attachment 164837 [details]
Screenshot showing upright greek symbols displayed as italic

The two sets of Greek symbols in Math, called Greek and iGreek, are supposed to be upright and italic shapes, respectively.

However currently this distinction only works for uppercase symbols.  As an example, %ALPHA and %iALPHA, wich gives upright and italic Α respectively; but for lowercase symbols, both %alpha and %ialpha gives italic α.

This is also the case for the %var-xxx and %ivar-xxx symbols.

I have this problem with both 6.4.6 and 7.0.0 on Windows 10:

Version: 6.4.6.2 (x64)
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

and

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU 线程: 2; 操作系统: Windows 10.0 Build 18363; 界面渲染: Skia/点阵; VCL: win
Locale: zh-CN (zh_CN); 界面: zh-CN
Calc: threaded
Comment 1 Regina Henschel 2020-08-29 13:47:55 UTC
It is not a bug.

Math formulas are based on MathML. There one character identifiers are usually rendered in italic in browsers. To get an upright character you need to set explicitly the attribute mathvariant="normal". That is attribute 'nitalic' in LibreOffice.

LibreOffice has the setting 'GreekCharStyle' with modes 0, 1 and 2  to determine how the character set 'Greek' is used.

Mode 0: all greek characters are upright
Mode 1: all greek characters are italic
Mode 2: uppercase greek characters are upright, lowercase are italic

The default setting is Mode 2. Your expected behavior corresponds to mode 0.

Depending on the mode, LibreOffice adds the attribute mathvariant="normal" in MathML to force the character to upright, and adds no attribute in case italic.

In case character set 'iGreek' the attribute mathvariant="normal" is never written, so that all characters are italic.

The character set 'iGreek' was introduced to make it easier for the user to force italic in case the user has set Mode 0. '%iALPHA' is essentially the same as 'italic %ALPHA'.

To change the mode go to Tools > Options > LibreOffice Advanced.
There click on button 'Open Expert Configuration'.
Search for 'GreekCharStyle' (without quotations marks).
Double-click the item and enter '0' (without quotation marks) for to get upright %beta.
OK, OK, OK. Restart LibreOffice.
Comment 2 Ming Hua 2020-08-29 16:47:23 UTC
(In reply to Regina Henschel from comment #1)
> LibreOffice has the setting 'GreekCharStyle' with modes 0, 1 and 2  to
> determine how the character set 'Greek' is used.
> 
> Mode 0: all greek characters are upright
> Mode 1: all greek characters are italic
> Mode 2: uppercase greek characters are upright, lowercase are italic
> 
> The default setting is Mode 2. Your expected behavior corresponds to mode 0.
Thanks for the explanation, Regina.

This configuration setting definitely satisfy my need, however it seems not documented anywhere, neither in the HTML help pages or the _Math Guide_ book, despite the latter having a whole section and exaustive tables for Greek symbols.  Perhaps the guide was first written when the default mode was 0?

I guess I'll send an revision request for the Math Guide to the documentation team.
Comment 3 Ming Hua 2021-05-08 00:11:38 UTC
*** Bug 142159 has been marked as a duplicate of this bug. ***